Yeelight binding issue (2.4.0, 2.3.0), few channels than before and can't find items

Tags: #<Tag:0x00007fc900caae10> #<Tag:0x00007fc900caad48> #<Tag:0x00007fc900caac58>

I’m running OH2.3 which was pretty stable (even if upgrading sadly brought several issues) and my only one yeelight rgb v2 was working fine, with 3 channels (Brightness, Color and Color_Temperature).

Then it stopped working suddenly (after i came back home from vacation).
So i updated the yeelight binding from 2.1.0 to 2.3.0 and 2.4.0 without success, because now i have:

  • only two channels (color and colorTemperature), so i can’t control the lamp (turning it on/off ).
  • in PaperUI i see only one lamp (and i have two), and i can’t find the second one.
  • by now i can operate on it only in the paperui control tab (but i guess tweaking the old working configuration in items list i could fix this.

May it be due to an android yeelight app update? I know am i not the only one affected by that, so how did you resolve?
I don’t want to change swap into the Xiaomi mi/io binding because the yeelight app is way more polished than the xiaomi one, and i like it way better.
Thanks in advance

Color Items can be used as Switches and Dimmers. To turn on the light, just send ON command to your color Item. Put your Color Item on your Sitemap as a Switch and you can turn it on and off like any switch. Put it on your Sitemap as a Slider to issue dimming commands.

I can’t help with the other problems.

first of all, many thanks for the reply.

And yes, that’s what I immediatly tried but it doesn’t work. And even if turned on elseway (yeelight app, google home) I can’t control it no more through openhab.
In the log:tail i can only see the commands i send but have no error in response, i don’t know if it matters.

Sorry for the noob question, but deleting some temp files or cache could be useful?
At the moment i don’t know what else i could try, besides deleting and resinstalling the binding in different versione and the items itselfs.

Again, thanks in advance for the attention

I usually doesn’t hurt to try. Clear the Cache

But this usually helps with core OH problems, not problems with individual bindings. I don’t use this binding so can’t help much beyond generic advice.

Well I’m very sorry to write this but after a year of openhab I’m totally disappointed, and i feel to write my experience for posterity.

I’ve followed your guide, which i am grateful of, but nothing resolved. And today mqtt (with mosquitto) wasn’t working either, don’t know why and i had no errors in the openhab.log file.
Following other suggestions here i’ve tried to delete temp and cache, and the result was that i couldn’t even control the other xiaomi stuff no more.

Something clearly wasn’t working in the openhab core then, too many random issues together (and i’ve already tested the hardware to be sure the problem was the machine itself, ssd with windows10).

In my experience the latest version of openhab (2.3.0) was pretty buggy and the migration from 2.2.0 was fairly too complicated to recommend, i had to fix too many problems.

I just write this post as a “little warning” because after weeks of struggling and sudden errors now nothing it’s working and i have to restart from zero because after so many years of experience I know that starting to understand problems takes too much time.

In oH2.2.0 i had lights, rollershutters, persistences, a lot of rules, all fully working for months and, the most important thing, everything was stable without the need of tweaking.
I would, sadly, strongly recommend to not upgrade to 2.3.0 unless stricly necessary.

Thanks anyway for the help, I hope not to be disrespectful.

UPDATE: While reinstalling from scratch on RPi I tried every backup i had on Windows and only one of them partially worked. I say partially because mqtt and yeelight binding worked, all xiaomi stuff and camera did not.
Luckily I’m used to such nonsense, so I didn’t mind and started fixing everything and the funny, magic thing is that the old yeelight binding (2.1.0) works like a charm, and i finally could add the second lamp.

Happy ending, somehow!

How would I go back to openhab 2.2

All good I find a away to go to Openhab 2.4. have it working now if any one like to find out how.