Yum repo problem

Just tried to do an install on Centos 7.6. When I try to run “yum install openhab2” it fails to download the package. I looked at the repo in a web browser and it all looks right but the files seem to have a “:” preceding the filename. Anyone got some advice on how to fix this or is the repo need some attention?

Ex: https://dl.bintray.com/openhab/rpm-repo2/stable/2.4.0/:openhab2-2.4.0-1.noarch.rpm

Managed to get the snapshot repo to cooperate, didn’t try the testing repo.

Hi @BiloxiGeek,

I couldn’t replicate this problem, could you check that you have the same settings as I do?

image

@Benjy
My openhab.repo file looks identical, I have the snapshot and testing repos listed but not enabled.

openhab2-2.4.0-1.noarch.rpm FAILED
https://dl.bintray.com/openhab/rpm-repo2/stable/2.4.0/openhab2-2.4.0-1.noarch.rpm: [Errno 14] HTTPS > Error 302 - Found–:--:-- ETA
Trying other mirror.
Error downloading packages:
openhab2-2.4.0-1.noarch: [Errno 256] No more mirrors to try.

When browsing the repo via firefox and then viewing the source I’m seeing a colon character preceding all three filenames:

href="[:openhab2-2.4.0-1.noarch.rpm]
href="[:openhab2-addons-2.4.0-1.noarch.rpm]
href="[:openhab2-addons-legacy-2.4.0-1.noarch.rpm]

I was able to get the files in a very roundabout way. Tried using lynx and after it failed copied and pasted the cloudfront.net redirect address into firefox and could download the file that way.

This is fine, the RPM files should still download.

This may be an issue with the repo check, try adding the following to the openhab.repo file:

repo_gpgcheck=0

Still no joy, keep getting the 302 error. Tried repo_gpgcheck on and off, gpgcheck on and off. Always getting the same error. Never seen a repo behave this way.

This is possibly related: When using yumdownloader or “yum reinstall” I get prompted to accept the GPG key, respond yes but the key is never downloaded to /etc/pki/rpm-gpg.

https://dl.bintray.com/openhab/rpm-repo2/stable/repodata/repomd.xml: [Errno -1] repomd.xml signature could not be verified for openHAB-Stable

Neither have I, and I’m struggling to reproduce the error you’re getting on Centos 7.

When using yumdownloader or “yum reinstall” I get prompted to accept the GPG key, respond yes but the key is never downloaded to /etc/pki/rpm-gpg.

Are you able to test installing a package with another RPM repo from Bintray? You may be having a network issue with that particular domain.

Otherwise, I’ll try having a play around with other installations on VMs, see what I can get.

@Benjy this is the first time I’ve used a bintray based repo so I don’t know of any others. I did think it’s possible my pi-hole is interfering but just tested with pi-hole disabled and got the
same thing.

My guess the package/repo Signature / Digest is no longer acceptable for modern OSes.
The software creating the RPM package probably needs to be updated to reflect current minimum security requirements.
I am using RHEL 8 and the work around i used was to disable FIPS mode and reboot.

You can also try:

rpm -ivh --nodigest --nofiledigest   <dir_path/openhab2_pkg_file>

References: