Z-Stick Gen5 Schlage not connecting

  • Platform information: Raspberry Pi 3 B+
    • Hardware: Z-Stick Gen 5
    • OS: openhabianpi-raspbian-201804031720-gitdba76f6-crc9e93c3eb
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: Unable co connect a Schlage Connect to Z-Stick

Hello all. I’m new to OpenHAB and decided to start off with two of the tougher devices it seams. Ecobee 4 and Schlage Locks. Ecobee is mostly working but I can’t seem to get past go on the Schlage.

I am unable to get a Schlage Connect Z-Wave Lock to successfully pair with a Aeotec Z-Stick Gen5. I have used the following procedures with distance measuring in inches between the devices.:

  1. Factory reset Z-Stick Gen5
  2. Pressed Z-Stick button until flashing yellow (unpair)
  3. Typed in master code followed by zero on the Schlage (received green check-mark)
  4. Tapped Z-Stick button until flashing blue (Pair)
  5. Typed in master code followed by zero on the Schlage

I receive different results at this point. Most of the time, I receive no further notifications. Sometimes, the Z-Stick will blink blue rapidly for a brief second then go back to slow flashing blue (like its trying to talk but only briefly) then both devices time out. Only a couple time at this point have I received a red check-mark on the lock.

I did install the latest binding using paper-ui and plugged in the zstick to setup the COM port, but I’m doing all the pairings with the z-stick removed from the Pi. Should I be doing this in Openhab? Is there a different pairing procedure for security devices? I seem to read lots of conflicting information when googling issues with Openhab and Schlage.


This won’t work - as you have found. When including a secure device, you MUST include devices through the UI since it performs a key exchange that must take place within 15 seconds of the inclusion. This makes it impossible to include by pressing the button on the stick, and you instead need to use the inbox button in the UI.

I’m also assuming you’re using 2.4, but you don’t say the version.


Thanks for the response!
I’m on 2.4.0-1.

I actually just reinstalled openhabian so I have fresh install. Before I install a binding, do I need a special version of Z-Wave or is the Z-Wave binding listed in paper UI (Version 2.4) the correct version?

Can you identify a good guide I can follow for setting up a secure zwave device?

Again, thanks for your help,

Not really - there’s nothing especially different about secure inclusion.

The binding readme has the following -:

Secure inclusion must be started from the binding directly (ie with the controller plugged in to the USB and Online). This is because once the device is included into the network, a key exchange takes place between the binding and the device. This key exchange must take place within a very short time of the inclusion, and if it doesn’t succeed, the device must be excluded and included again. Secure inclusion will generate a lot of activity on the network, so you should avoid other activities at the same time, and the device being included should be close to the controller to reduce any retries that could cause the security handshake to fail.

Secure inclusion works in much the same way as non-secure inclusion other than the hard requirement to start inclusion from the binding. Put the binding into inclusion mode, then put the device into inclusion mode. Some secure devices such as locks may also require that you type in a passcode at this point. Note that the binding will only remain in inclusion mode for 30 seconds, so inclusion of the device must start within this period.

Well, I’ve tried a few times without success. I followed the following procedure:

  1. Reinstalled a fresh version of openhabianpi
  2. Unpair zstick and lock using button on zstick.
  3. Installed the zwave binding in paperui
  4. Configured zwave binding by adding the controller in paperui ( z-wave serial controller reads as online)
  5. set zwave binding to pair mode in habmin
  6. Set lock to pair mode. (Lock responds with red X or times out (usually times out)

I’m at the end to my limited openhab/zwave knowledge. Can someone help? Do I need to unpair a failed pairing in openhab somehow?


How close was the controller to the lock while including? I usually have mine touching, but sometimes it still takes a couple tries.

The lock may include, but not securely, so you will have to exclude it each time. Sometimes I reset the locks too, but only when they are really fiesty. You may end up with some ghost nodes when your done, but these can be removed.

Thanks for the advice 5iver! I was nearly touching.

I solved the issue. Put new batteries in it and presto!

I have a working switch that is labeled just on and off. I was trying to use the button widget and two states without luck. I’m now trying to figure out which widget to use to make a battery indicator and an alarm/event tracker. Any advice?

If you search the forum, you’ll find rule and item examples I’ve posted for my BE469s.

I’m having the same issue… I have tried everything mentioned above. OpenHab2 finds the lock but the Schlage never gives a green check and security is never included.

I added new batteries, had the rpi3/controller touching the lock… I have reset the lock as well. Nothing is working.

Z-Wave BE469NX Touchscreen Deadbolt
Z-Stick Gen 5
OH2 = 2.4.0-1

OK— FIXED… I changed the sec key (was never used so no big deal), performed a hard reset of lock, performed exclusion, deleted the node and node.xml in openhab2, then kicked off another inclusion with RPI3 touching lock. This worked (green check).

1 Like

I can confirm @slombard’s procedure works:

  1. Hard reset on the lock.
  2. Ensure node is deleted from controller in HABmin and org.eclipse.smarthome.core.thing.Thing.json file.
  3. Initiate inclusion from HABmin.
  4. Initiate inclusion on lock.

I made sure to leave it alone for a good five minutes before refreshing HABmin and adding the Thing after auto-discovery. Got the green checkmark under “Using Security.”

openHAB 2.5.6 Release Build
ubuntu on Dell Inspiron 7773
Aeotec Z-Stick Gen5
Kwikset SmartCode 888