Z-Wave addon updates (Jackson’s db) [SOLVED]

Hi, I have no idea what I’m doing despite trying to spend as much time as I reasonably can to do research. Feel free to reply with rtfm and a relevant link if that’s how things work here. I was able to add a device to Jackson’s database and it seems to have been accepted by sihui but I’ve been apt-get updating and upgrading my 2.5 install all week, and the addons has had a couple updates, but the device still shows as “unknown device”. Is there someway for me to check my pi’s addons path for the device definition to see if it hasn’t made it there or maybe check further up the chain in the apt and git repositories so I can have some handling of what has occurred following the device being added to Jackson’s db? It seems like manufacturers should be adding their products to the database instead of consumers… Thanks for any insight anyone can provide. It would be convenient if there was a way to download one of these device definitions directly from the Jackson database into the addons so I could see if I just have it created wrong.


Hi David and welcome to the OpenHAB community!
Is this device a battery powered device? If so, it may need woken up numerous times before the zwave binding has enough information to know what the device is. Battery powered devices ‘go to sleep’. If you find the documentation for your device, it will give instructions on how to wake the device, usually by pushing a button or poking a paper clip in a hole. You set OpenHAB into inclusion mode, then wake the device, wait a minute or two and do it again. Sometimes this must be repeated numerous times.
If it is a mains powered device, none of this matters and never mind

Edit to add:
yeah that dimmer looks to be a mains powered device. Try running inclusion again

Hi Andrew, I’ve removed the “thing” and re-searched for it each time but I haven’t tried the exclusion steps. Forgive my ignorance but that’s where I have the zwave usb stick forget it instead of just OpenHAB, correct?


Edit: typos

I’m unsure what you are asking me, please reword your question

I don’t think you will need to exclude it on the stick if that is what you are asking.

Also, if you aren’t doing so, please try using the Habmin user interface for administering your zwave devices. Habmin really works good for zwave stuff

you know and also… take a peek at the logs… you maybe see whats going on during an inclusion, I don’t think I need to say

latest snapshot ?

Andrew, yeah I was talking about doing the exclude procedure from the aeotec gen5 and then re adding it instead of using the paperui’s thing remove (trash can) button. I went ahead and did the exclude since it was something I hadn’t gotten around to yet but it didn’t solve my problem as you probably guessed :slight_smile:. I’ll try to find the habmin and try that next. Thanks for the suggestion! When I tail the logs they pretty much just say “Device discovery could not resolve to a thingType!” which I’m betting is the equivalent to the unknown device status in paperui. I can give a dump of them here if it’s helpful. Thank you!

Hi robmac! This could very well be the problem. I had thought that using the unstable branch (https://openhab.jfrog.io/openhab/openhab-linuxpkg unstable Release) was going to give me the latest snapshot/nightly but now I’m in doubt. Should I be using git instead of apt? I could try to draw that conclusion better if I knew where to look for how far along my submission to Jackson’s db has progressed beyond being accepted. Thank you!

I appreciate the help; I’m trying to not be a newbie by reading the documents I can find but it’s not clicking together for me yet. I’m happy to rtfm when pointed to where :+1:

Looks like your submission was accepted on July 28th, but the database files used by the binding haven’t been updated yet according to the GitHub Z-Wave Binding repo history. Maybe @chris can push a button or execute a few commands to accomplish that. :slight_smile:

1 Like

I think it is on his list for tomorrow as he is travelling at the moment.


Let the man have a bloody holiday then!!!
only kidding :wink:
@dmnotme sounds like you are going to have to wait a day or two to play with new toy

Okay, I’ll sit tight and watch that git history for an update. Thanks folks!

I’m not sure if the specific device, but I will do a database update this afternoon when I find some internet.


Thanks for pushing the database update @chris. A new Thing definition for @dmnotme’s device got added with that update. After having triggered a new build, these database updates should now be part of the latest 2.5.0-SNAPSHOT build #1652. :slight_smile:

1 Like

That seems to have done it! Thanks!


Great David!
Please change thread title to include [SOLVED] and put a check in the box in the post which helped you fix the issue, thanks

All the replies helped!

1 Like