Z-Wave associations not created

I have

  • Aeotec Z-Stick Gen5
  • Heatit Z-Water relay
  • Heatit Z-Temp2 Thermostat

Ale these devices are connected and I see them communicating fine.

The problem is when I want to associate the thermostat switch to relay endpoints.

I open Thermostat thing and under Association Group 3 i select my Z-Water relay endpoint 6 and 7.

UID: zwave:device:6b61ef08d9:node22
label: Heatit Z-Temp2 Thermostat - Prysznic
thingTypeUID: zwave:thermofloor_HeatIt4512666_00_000
configuration:
  config_10_1: 5
  group_1:
    - controller
  group_3:
    - node_21_6
    - node_21_7
  group_2: []
  action_heal: false
  config_1_1: 900
  config_6_2: 10
  config_7_1: 1
  config_8_1: 50
  config_12_2: 400
  config_9_2: 3
  config_11_2: 50
  config_2_2: 10
  config_3_2: 10
  config_4_2: 0
  config_13_2: 0
  config_14_1: 0
  node_id: 22
  config_5_2: 0
bridgeUID: zwave:serial_zstick:6b61ef08d9
location: Prysznic

After clicking “Save” I see in the log:

2021-01-17 19:18:12.973 [INFO ] [openhab.event.ConfigStatusInfoEvent ] - ConfigStatusInfo [configStatusMessages=[ConfigStatusMessage [parameterName=group_3, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null]]]

But there is no confirmation message. Just PENDING.

After I trigger the thermostat change I see the change in relay, but on endpoint 1, not 6 and 7.

2021-01-17 19:15:27.308 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'HeatitZTemp2ThermostatPrysznic_Setpointheating' changed from 22 °C to 29 °C
2021-01-17 19:15:27.391 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'HeatitZTemp2ThermostatPrysznic_ThermostatOperatingState' changed from 0 to 1
2021-01-17 19:15:27.428 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'HeatitZWater_Switch1' changed from OFF to ON

Is this an issue with my hardware, OpenHAB or my setup?

I have exactly the same setup running in my pi4 + OH 3.2.M4

  • Aeotec Z-Stick Gen5 (ZW090) - UZB
  • Heatit Z-Water relay
  • Heatit Z-Temp2 thermostat

and exactly the same problem. I mean: when I try creating an association from any of my five Z-Temp2 thermostats to the Z-Water relay (in my case this is node 2) switch 4, for example, using the Association Group 3 with “Node 2 (Endpoint 4)” selection, I get the PENDING error. Somehow the association gets created but not towards Z-Water switch 4, as one would expect, but instead always towards the switch 1.

As I was trying to overcome this issue, I tried e.g. Home Assistant, just to see if I could establish the associations there but that was a dead end, too. Then I tried a trial version of Homeseer, which did the trick. With Homeseer I was able to make the needed associations to the switches 1-5. After doing the trick with Homeseer I was then able to come back to Openhab and add all the Z-Temp2 thermostats back again. Definitely a hack, and time-taking one as I was somehow able to create multiple Z-wave device IDs for the Z-Temp2 thermostats, which then required me to go back to Homeseer’s side and delete the “ghost” Z-wave devices. But, after some trial and error it indeed worked.

Currently, my OH3.2.M4 setup with Z-Water + 5 x Z-Temp2 works, and I’m able to update e.g. the Z-temp2 item properties (like calibrating temperature + humidity offsets) without issues: the group associations seem to stay untouched, so long I don’t try to re-associate them. Now during the heating season I’ve not wanted to fiddle with the association groups, but I plan to do that in the spring perhaps. As a “backup” for the winter time, I actually bought a Fibaro Homecenter Lite 3 box just to have a tool to re-pair the Heatit devices quickly (in case of an emergency), but I’ve not yet had a reason to use the Fibaro HCL3 lite box as my OH3 has been stable.

Slightly off-topic: one noteworthy issue I should mention if you go my path and establish these associations successfully: perhaps 2-3 times during the last 2 months my Z-temp2 thermostats have gone to a coma state, where they have not sent the “heating required” signal to the Z-water even though the setpoint temp setting is higher than the measured ambient themp of that Z-temp2 device. I’ve tried e.g. Z-wave network healing + Z-Temp2 device healing, but none of that has worked. What has worked for me: removing 1 battery from the failing Z-Temp2 for a couple of seconds. After this the heating required -signal has again been immediately sent from the Z-Temp2 directly to the Z-Water.

I think the issue you mentioned is an Openhab / Z-wave binding problem and not a hardware problem. Dunno how this could be debugged, however.

I tried setting up the associations with OH 3.3.0 but the problem still persists.
Did you Tomasz figure out how to set the associations for the different EPs?

I gave up and just written the automations manually using Rules.

configuration: {}
triggers:
  - id: "1"
    configuration:
      itemName: HeatitZTemp2ThermostatPrysznic_ThermostatOperatingState
      state: "1"
    type: core.ItemStateChangeTrigger
  - id: "2"
    configuration:
      itemName: HeatitZTemp2ThermostatPrysznic_ThermostatOperatingState
      state: "1"
    type: core.ItemStateUpdateTrigger
conditions: []
actions:
  - inputs: {}
    id: "3"
    configuration:
      itemName: HeatitZWater_Switch1
      command: ON
    type: core.ItemCommandAction

Well, for anyone facing the same issue: I got around by using the Z-Wave PC Controller tool in Simplicity Studio - Silicon Labs. Register (free) and login to get access to the Z-Wave tools.
Plugged the Aeotec stick in my laptop and created the associations with the tool. It took me some moments to find out the right sequence to get the node and group details and create the associations (waking up the wall controller nodes for each set of changes) but in the end I got all associations just the way I wanted them.
Fixing the multiple endpoint associations in the OpenHAB binding would be a far better solution of course …

2 Likes

Hi Olli,

Did you fixed why your z-Temp2 goes to ‘coma state’ ?

I’m really interested on this, 'cause I’m facing also this issue, that’s how I find this post.

My self I get a Z-Water and 6x Z-Temp2. Firstly I associate these device with my Homey domo box. Try to associate with & without security mode, and did this several time. The devices seems to work okay for a while (or some days), but then one or another goes to ‘coma state’… and I could do nothing to wake up them again… It was really frustrating. But I have another zwave device (Gas meter North Q) which stand in the basement, and I loose too often the signal.

So I decided to change my zwave strategy as I also read that Homey box has poor antena power. Thus I installed on my NUC, Zwave2MQTT (with my aeon Z‐Stick Gen5), the signal is much better and no problem at all to reach devices downstairs or upstairs. Cool. But I’m still facing ‘coma state’ issues with the Z-Temp2 ! I also try healing the device, try to schedule the polling of the device… but I have always to remove a battery each 5-6 days on each devices (not at the time). I’m desperate…
I didn’t try to associate them in secure mode S2 with Zave2MQTT, but I don’t if this make sense.

Note that in both setup (Homey / Z‐Stick Gen5) I was able to configure the group with the raly of the Z-Water without issues.

Is there maybe a device parameter to change to make the connection more robust? I got others 17 zwave devices working perfectly…

If you or someone has any clue, any hint on this… it would be very appreciated.

Regards,

Ivan