Z-Wave binding crashes under Windows 10

Tags: #<Tag:0x00007efebcb46d30> #<Tag:0x00007efebcb46c68>

Hi there,

I know several topice here about crashing of zwave binding, but none of it had any solution that worked for me. Hope we can change this now.

I have openHAB2 running on a tiny PC with Windows 10 Home & JAVA 8. Everything works fine, even persistance, Grafana and connection to my self programmed MQTT-Client. But now I’m struggeling with the next step of installation, Z-Wave. I installed thebinding, and the stick is recognized by the system at COM3. But when starting openHAB, afer some time, when everything is to be initialized, openHAB crashes.

When I remove the Z-Wave stick, everything works fine agein (except zwave of course).

Many thanks,
Gerhard

Here is my openhab.log file (cleand up):

2020-11-23 08:22:34.965 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - Creating ZWave discovery service for zwave:serial_zstick:e028ab49 with scan time of 60
2020-11-23 08:22:34.966 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Active zwave:serial_zstick:e028ab49
2020-11-23 08:22:34.967 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2020-11-23 08:22:36.814 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.
2020-11-23 08:22:36.814 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller zwave:serial_zstick:e028ab49.
2020-11-23 08:22:42.270 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘COM3’
2020-11-23 08:22:42.291 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Starting receive thread
2020-11-23 08:22:42.299 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Starting ZWave thread: Receive
2020-11-23 08:22:42.301 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2020-11-23 08:22:42.301 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initialising ZWave controller
2020-11-23 08:22:42.321 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2020-11-23 08:22:42.321 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2020-11-23 08:22:42.331 [DEBUG] [ve.internal.protocol.ZWaveController] - Event listener added.
2020-11-23 08:22:42.341 [DEBUG] [ve.internal.protocol.ZWaveController] - Event listener added.
2020-11-23 08:22:42.341 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Scheduling network mesh heal for 18 hours time.
2020-11-23 08:22:42.341 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2020-11-23 08:22:42.341 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

This is events.log:

2020-11-23 08:22:36.804 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:e028ab49’ changed from UNINITIALIZED to INITIALIZING
2020-11-23 08:22:36.814 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:e028ab49’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline

And this is addons.config:

:org.apache.felix.configadmin.revision:=L"30"
binding=“astro,openweathermap,mqtt,zwave”
misc=""
package=“standard”
persistence=“influxdb”
service.pid=“org.openhab.addons”
transformation=“jsonpath,scale”
ui=“dashboard,basic,paper,habpanel,homebuilder”
voice=“marytts”

And the JAVA crash dump (cleaned up):

--------------- T H R E A D ---------------

Current thread (0x00000232973c3000): JavaThread “ZWaveReceiveInputThread” daemon [_thread_in_native, id=4236, stack(0x000000db63800000,0x000000db63900000)]

… Stack Trace follows here…

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j gnu.io.RXTXPort.nativeDrain(Z)Z+0
j gnu.io.RXTXPort$SerialOutputStream.flush()V+72
j org.openhab.binding.zwave.handler.ZWaveSerialHandler$ZWaveReceiveThread.sendResponse(I)V+39
j org.openhab.binding.zwave.handler.ZWaveSerialHandler$ZWaveReceiveThread.run()V+272
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
0x00000232973c8000 JavaThread “OH-thingHandler-9” daemon [_thread_blocked, id=7776, stack(0x000000db63c00000,0x000000db63d00000)]
0x00000232973c7800 JavaThread “Timer-11” daemon [_thread_blocked, id=3660, stack(0x000000db63b00000,0x000000db63c00000)]
0x00000232973c6800 JavaThread “ZWaveReceiveProcessorThread” daemon [_thread_blocked, id=3352, stack(0x000000db63a00000,0x000000db63b00000)]
0x00000232973c6000 JavaThread “Timer-10” daemon [_thread_blocked, id=1644, stack(0x000000db63900000,0x000000db63a00000)]
=>0x00000232973c3000 JavaThread “ZWaveReceiveInputThread” daemon [_thread_in_native, id=4236, stack(0x000000db63800000,0x000000db63900000)]
0x00000232973c5000 JavaThread “Thread-69” daemon [_thread_in_native, id=3048, stack(0x000000db62200000,0x000000db62300000)]
0x00000232973c3800 JavaThread “OH-ruleEngine-8” daemon [_thread_blocked, id=7628, stack(0x000000db62000000,0x000000db62100000)]
0x00000232973ba000 JavaThread “OH-ruleEngine-7” daemon [_thread_blocked, id=9988, stack(0x000000db61d00000,0x000000db61e00000)]
0x00000232973c0800 JavaThread “OH-ruleEngine-6” daemon [_thread_blocked, id=1520, stack(0x000000db61c00000,0x000000db61d00000)]
0x00000232973c0000 JavaThread “items-queue” [_thread_blocked, id=9548, stack(0x000000db60600000,0x000000db60700000)]
0x00000232973bf000 JavaThread “OH-scheduler-7” daemon [_thread_blocked, id=6284, stack(0x000000db5fc00000,0x000000db5fd00000)]
0x00000232973bd000 JavaThread “ForkJoinPool.commonPool-worker-1” daemon [_thread_blocked, id=3168, stack(0x000000db5f700000,0x000000db5f800000)]
0x00000232973b8800 JavaThread “qtp1009816354-227” [_thread_blocked, id=2728, stack(0x000000db5f600000,0x000000db5f700000)]
0x00000232973ba800 JavaThread “qtp1009816354-226” [_thread_blocked, id=9852, stack(0x000000db5f500000,0x000000db5f600000)]
0x00000232973af800 JavaThread “OH-thingHandler-8” daemon [_thread_blocked, id=4528, stack(0x000000db5f400000,0x000000db5f500000)]
0x00000232973b6000 JavaThread “qtp1009816354-224” [_thread_blocked, id=5432, stack(0x000000db5f300000,0x000000db5f400000)]
0x00000232973ae800 JavaThread “OH-thingHandler-7” daemon [_thread_blocked, id=5532, stack(0x000000db5d500000,0x000000db5d600000)]
0x00000232973b5800 JavaThread “OH-discovery-7” daemon [_thread_blocked, id=1872, stack(0x000000db5d700000,0x000000db5d800000)]
0x00000232973b1800 JavaThread “OH-common-7” daemon [_thread_blocked, id=7692, stack(0x000000db5d800000,0x000000db5d900000)]
0x00000232973b7000 JavaThread “ForkJoinPool.commonPool-worker-2” daemon [_thread_blocked, id=9040, stack(0x000000db5e700000,0x000000db5e800000)]
0x00000232973b4800 JavaThread “OH-thingHandler-6” daemon [_thread_blocked, id=6480, stack(0x000000db5d400000,0x000000db5d500000)]

--------------- S Y S T E M ---------------

OS: Windows 10.0 , 64 bit Build 19041 (10.0.19041.546)

CPU:total 4 (initial active 4) (4 cores per cpu, 1 threads per core) family 6 model 122 stepping 1, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, aes, clmul, erms, 3dnowpref, tsc, tscinvbit

Memory: 4k page, physical 4014368k(809464k free), swap 6111520k(1468792k free)

vm_info: Java HotSpot™ 64-Bit Server VM (25.271-b09) for windows-amd64 JRE (1.8.0_271-b09), built on Sep 16 2020 19:14:59 by “” with MS VC++ 15.9 (VS2017)

time: Sun Nov 22 20:29:02 2020
timezone: Mitteleuropäische Zeit
elapsed time: 153.448101 seconds (0d 0h 2m 33s)

I don’t see anything false in my configuration, any hints out there?

Welcome.

  1. Please use code fences to make your post more readable This becomes especially important for configuration when spaces are importantwhere the forum otherwise “eats” spaces
    How to use code fences

  2. Exactly what version of openHAB? What Z-Wave stick? I have used my stick on a Windows 10 host bridged to a VirtualBox Linux VM running openHAB. In fact, that is how I first started evaluating openHAB.

Hi Bruce,

thanks for your reply. I have the 2.5.10 Release Build, and the UZB stick: https://z-wave.me/products/uzb/

Gerhard

1 Like

Thank you.

Since Z-wave is region specific, in what country are you located?

I am in the United States. I am working currently so have limited time to look at this right now.

Sure, sorry, I’m in Germany :wink:

1 Like

No worries. I have actually not tried running openHAB on Windows 10 directly.

Is this computer dedicated to openHAB or are you just evaluating the system?

Actually this should be my system of choice. I want to ave the power and flexibility of a PC, and I’m not a Linux guy.

1 Like

Fair enough.
I am an old Linux guy but also work with Windows and have a son who is a Windows expert. In fact my main system is a Debian Linux VM running on my son’s Windows Hyper-V Server. My current personal laptop is Windows 10 Home so I should be able to test further is nobody else can help/

Really appreciate if you could help. I tried so much but it always crashes. Even on a new installation without any other binding…

1 Like

OK so not necessarily Z-Wave related. I know many people run on Windows 10.

Here in the US this is a the Thanksgiving Holiday time of year so I am not sure of my time availability.

No sorry, wrong words. It always crashes when the Z-Wave stick is inserted - even on a new installation with no other bindings installed. It definitely relates to Z-Wave.

With no stick it runs smoothly.

Do you have the Windows drivers loaded for your stick? Have you tried contacting their vendor support?

This may not be an openHAB issue.

Yes, checked this. Drivers are up-to-date.

1 Like

Screenshot?

What do you mean by “crashes”? Does Windows still function after the “crash”, or do you need to restart the OS? Does OH still function after the “crash”? What is in the OH log right before the “crash”? Is there a stack trace? Are you unplugging the stick while OH is running? What other USB devices are installed in the system?

Having some more details will help a lot in troubleshooting. :slightly_smiling_face:

1 Like

Please read also my 1st post. OH crashes, so it’s the Java application. Windows itself is still running, no problem.

Yes, there is a Java stack trace, I added extractions into my 1st post.

And of yourse I do not unplug the stick when OH is running. And no other sticks inserted.

Concerning the drivers, I downloaded the latest from the manufactruer’s site. It’s really the latest. You really want to the a screenshot?

Gerhard, which Java incarnation are you running on your box? The output of “java -version” in a cmd.exe-window would be interesting.

java version “1.8.0_271”
Java™ SE Runtime Environment (build 1.8.0_271-b09)
Java HotSpot™ 64-Bit Server VM (build 25.271-b09, mixed mode)

What is in the openhab.log at the time of the Java core dump?

I’m more interested in which drivers you have loaded than whether they are recent. A UZB device should be using the SiLabs drivers… something like CP210x. Which model UZB?

These are the last (zwave related) lines before the crash:

2020-11-23 08:22:42.341 [DEBUG] [ve.internal.protocol.ZWaveController] - Event listener added.
2020-11-23 08:22:42.341 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Scheduling network mesh heal for 18 hours time.
2020-11-23 08:22:42.341 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2020-11-23 08:22:42.341 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

Well, I downloaded the latest drivers from the manufacturer’s homepage. Do you mean that different driver should be the better one?

Model is: ZMEEUZBB