Z-Wave binding, Merten/Schneider CONNECT radio system devices

@chris, is this device in the database? I couldn’t find any reference to it.


This will integrate better physically with my other wall switches than NodOn does.

Conclusion: this device is a no-go for openHAB2

Then I guess the answer is “no” ;). It doesn’t look familiar, and if you can’t find it then it’s likely not there… It can of course be added - although I suspect by the way your message is written that you might no have one yet? It’s best to add this if you have the device as we can then use the XML file to create a large chunk of the database.

You are right, but with your help I’m willing to give it a go. :slight_smile:
Should it fail, I can always return it. My shop offers a 60 day open no-questions-asked return policy.

I put in an order right now. Not in stock at the moment. Expected in 4-8 days.

Could you describe where to find the .xml file? Will it show up as an unknown device?

It shouldn’t be an issue to get it working (although I’ve not looked closely at the device).

There’s information in the link below about the database - a few paragraphs down is a section on the XML files that OH generates - any questions, just ask…


1 Like

Hi Ole Morten, any progress on this? Do you know if it fits in Elko plus frame?

Unpacked it just now.
I have only the regular Elko frames, but size and color seems to fit fine, but I will not mount it until I have successfully included it.

@chris it showed up as Unknown node39. Where do we take it from here?
(There is no .xml file in the /var/lib/openhab2/zwave directory)

The initialisation hasn’t completed - either it needs waking up if it is a battery device, or there’s something else stopping it from completing initialisation. I would first try to wake it up a few times if it is a battery device, and if that doesn’t help, gt a debug log so we can work out why it’s not completing the interrogation.

After numerous attempts I could really need som help @chris :slight_smile:
I even tried to exclude and re-include so I hope the log could give a clue to what is wrong.
I noticed it said something about parsing the .xml file, but it was not there.
Keep in mind that I’m running your re-factored binding.
Log should contain my first attempts, look for NODE 39. (debug was not on from the start)
After re-inclusion it is NODE 40 (debug on from start)


Looks like this device is actually a Merten device: 2-gang
(Not a Z-Wave Plus device, but claim battery should last 10 years :slight_smile: )

On a side note regarding the experimental binding:
Yesterday I moved my whole openHAB2 installation to a new (cooler running) PC.
After moving the stick, most of the nodes appeared in the inbox, but 4 of 5 Aeotec Multisensors (all USB powered) and 1 of 2 battery powered NodOn remotes remained Unknown (waited a long time, woke them up numerous times).
I then just copied the .xml files from the old PC over to the new, and the nodes instantly worked, so I have a feeling there is ‘something’ not optimal regarding discovery.
I must also say that during my trial of HomeSeer a few months back, the mobile phone inclusion app they had, had no problems detecting battery powered devices instantly, so it felt more robust in that regard.
Anyway, hope the log will tell you something.
Really appreciate you help :+1:

Ha, never give up.
While tailing the log, I noticed it was trying to discover NODE 40 quite often, stating it was not AWAKE.
For a full minute, I pressed the buttons repeatedly and did a few triple-cliks making it send its ID frame, and Viola:

Yes, battery devices need to be woken up a few times - not just included. This is to allow the interrogation to be completed by the device - during this time it downloads a load of information about the device and creates the XML…

Indeed :slight_smile:

The node is still Unknown though.
What is the process of including it in the database?


I thought you added this.

No, I was just happy I got the Manufacturer & Type / ID

I’ve never done this before, but can give it a go during the week-end.

I uploaded the .xml just to find it was already in the database awaiting review.
It did not show up in my initial search for Merten devices.

Now I’m at a loss on how to cancel my upload, and how to complete the database entry.
Device List

Also, after reading through the Database Guide it is not clear to me exactly what to do to my OH2 installation to get the device working once the database is updated.

Read that you need to compile it with the binding.
(New Wave manufacturer)

@chris when do you think this Merten remote will make it to the development binding?

@chris seems like you have crossed swords with this device before, more than half a year ago.
Have you given up on it? I can still return it to the shop.

The database was updated already, but I had forgotten about this issue (it was a long time ago). Nothing has changed in this respect at the moment, so I guess based on this it’s unlikely to work unfortunately.

OK. Back it goes.
It is an old device. Plenty of other wall remotes :slight_smile:

@chris are there a list of other trouble devices or do you know of others to stay away from?

No - there aren’t many devices that we haven’t made work. Some older devices like these Merten battery controllers (either remote controls, or wall switch controllers) are really designed to work within the Merten system and have the issues here with no supporting wakeup (which for a battery device makes them very difficult to manage). Otherwise I don’t think there are many devices I can think - of course I’m sure support for some command classes can be improved (or in some cases - added) but most of the time this is relatively easy to incorporate.


Is this still an issue? I had these working fine with Home Assistant, but now I started using OH, and i cant get these working.