Z-wave Binding really that bad?

  • Platform information:
    • Hardware: MacMini I5, 16 GB, 1 TB
    • OS: MaOS 10.12.6
    • Java Runtime Environment: JDK Zulu 10.9.1
    • openHAB version: 3.0
  • Issue of the topic: z-wave binding only knows half of my devices
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Hi everyone,

this is my 3rd attempt to try out openhab. I tried 2.0, 2.4 and now 3.0
Unlike before, where I used a raspberry to run Openhab I now have installed it ob the same machine as my Indigo installation using the exact same Aeotec ZStick Gen5 that is running my productive installation. I think this should be plenty of CPU power for OpenHab.

Unfortunately only about half of my (100+) devices are properly and completely discovered on Openhab. The others stay as things with no usable channels.
As I am not using any new devices that are not running on Indigo, I am very surprised.
Devices that are not put in properly include all my Fibaro motion sensors, old Hunter Douglas Blind controls and many others that I never had problems with I wanted to ask, if I might be doing something wrong or if the z-wave binding is really so bad?
Any input would be greatly appreciated.

The Z-Wave binding incorporates the database of known devices. Which devices are known is defined by the database which can be found here.
You may check if your devices are defined there. If not, follow the instructions to get them incorporated so they will be part of the next binding updates.

Maybe the devices which are not known are in reality just not reconized fully? That happens with battery driven devices. They need to be woken up (manually) a couple of times so that dicovery can be completed for them without the need to wait for several cycles of the configuted wake-up time period.

1 Like

Additionally: you state your Java environmant is 10.9.1 but OH3 needs Java 11


I am using the zwave binding since version 1.8, including all 2.x versions and now 3.0: no delays, no unknown devices, no problems. So the answer to your question

is no.

1 Like

No but user fail to read and know they usually need to wake up battery operated devices repeatedly until they respond to the NIF request as stated by the standard.

Thanks Stefan,
yes you are right the version of my installed jre is sorry for the typo.

Well, I am quite used to z-wave battery devices and their being hard to discover. Anyways I never had to manually wake them up when switching the environemnt. The wake up every hour anyways.
I have used several Vera versions and Indigo during the last 10 years.

I have manually woken up one on my Fibaro Motion Sensors several times. It still wasn’t recognize while its definately in the database. I have all different vwersions of it and none are recongized. (2.6 and 3.3 firmware).
All Fibaro Window sensors are not recognized properly as well.


Different systems handle device discovery differently. For example, when I used openzwave with Home Assistant, the binding needed to see the device as it was initially included into the network. It could not be added later.

the binding user by openHAB is based on the information a device is required to provide when a NIF (Node Information Frame) request is sent. Unfortunately, some battery operated devices only technically meet that part of the Z-Wave standard. if woken up repeatedly.

The Z-Wave binding was written by a very talented and dedicated Eurospace engineer…

Thanks Bruce,

maybe I will wait another year and then try OpenHab again. It seems my definition of a working and usable environment just differs from others.
I took a new approach to testing OpenHab this time by installing it on a more powerful hardware that was already running properly. Just to make this properly working z-wave network be partly recognized by Openhab took me several hours, because really nothing works automatically. I am just not geeky enough any more …
Thanks for you time and input, I really appreciate it.

I couldn’t get the Z-Wave to work reliably on Aeotec stick. Mostly had trouble with battery devices, but the network was very slow at times too. Now I switched to RaZberry and it works great.
My guess is, even though Aeotec sticks are mostly great, on some setups they suck.

I can’t offer you any help here, but just wanted to mention that I’ve never had any issues. I have roughly 20 zwave devices from several different manufacturers and they all just worked. I’ve never had to do anything special, just put the device into paring mode and it appears in my paperUI inbox. The only thing I can speculate is that since I paired all of my devices under openHAB and not some other system, I don’t have the same issues as you.

The Aoetec Sticks suck in many ways, especially because of poor support and bad usb when using a rpi4 but in this case the system is running perfectly - just with another software.
So in that case I wouldn’t blame Aeotec for those problems.

I the earlier versions I blamed the Raspberry for the poor perfomance using OpenHab with z-wave and that’s why I tried using a real computer to run it.