Z-Wave Bridge Offline / Error: Bridge

This! My controller is now online.

This is definitely a z-wave binding bug!

Congrats. Glad you got it working.



Thank you for your help!

I somehow turned on z-wave debugging at the console-cli and now I have my z-wave working, I would like to turn z-wave debugging off. I have not been able to re-find those commands and now my openhab.log file is so full of z-wave debugging lines it is hard to see the other information within it. Anyone got that console-cli command to turn it off?

from the docs

To disable debug logging, enter the following command -:

log:set INFO org.openhab.binding.zwave
1 Like

This stick has a design flaw in the hardware, which means that it does not work properly with the Rapsberry pi 4 USB ports.

They made a new one where the pi 4 is explicitly mentioned (That says enough) in the sales story. Z-Stick Gen5+: upgraded for Raspberry Pi 4, S2 security, and SmartStart

Somewhere on the internet I read that they have not fully adhered to the USB standard.

To solve this I bought the product below and it works for me on a PI 4 and costs +/- 7 euros / $8.50


It seems to work fine with my amd64 platform. If I have trouble, I’ll just buy the gen5+

Maybe someone in your area has an old USB 2 hub that you can borrow to test whether it works for you.

You can always choose a new product but I think that’s a waste of money (+/- $60,-)

I’ve tried it with a usb2 hub, didn’t make any difference.

But I am done with half-working things and unexplained solutions. I rather spend the $60 on something i know will work than mess with broken hardware.

That said, so far it works fine.

1 Like

Same here with my Raspberry Pi 4 / Razberry-Board… on OH 2.5 everything works fine but on OH 3 not. I have now spended several hours on it without success.

Have you tried this: [SOLVED] OH3: zwave binding Z-Wave Serial Controller Aeotec Z-Stick Gen5 remains offline - #46 by putrid

Basically, Openhab 3.0 uses serial port lockfiles in /var/lock/ which is only writable by root nowadays.

Hi @JoveToo - thank you for your hint.

I also tried this, unfortunately, this didn’t solve my problem either.
On Raspberry Pi OS Lite my file looks like this:

d /run/lock/subsys 0755 root root -

I have already tried to adapt the path and remove /subsys, again without success.

You will need to make the /var/lock/ path writable by root:dailup

Either edit /etc/tmpfiles.d/legacy.conf or copy /usr/lib/tmpfiles.d/legacy.conf to /etc/tmpfiles.d/ and edit it there. Mine also has that /run/lock/subsys line but it also had a line:

d /run/lock 0775 root dialout -

So just add it (on mine it is in front of the other line).

Don’t forget to reboot.

If openhab can’t make the lockfile, it will refuse to talk to your controller. That won’t change with getting a new controller, it will have the same problem.

Thanks @JoveToo, but unfortunately it still doesn’t work.

So, I’ve now done everything all over again, here are my steps from the beginning:

Raspberry Pi 4 4GB
Razberry Z-Wave Board (ZMEERAZ2)

Raspberry Pi OS Lite (Release date: May 7th 2021, Kernel version: 5.10)
Docker Portainer
openHAB 3.0.2 (Docker Image )

sudo apt-get update && sudo apt-get upgrade
curl -fsSL https://get.docker.com -o get-docker.sh
sudo sh get-docker.sh
sudo usermod -aG docker pi

sudo docker volume create portainer_data
sudo docker run -d -p 8000:8000 -p 9000:9000 --name=portainer --restart=always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer-ce
sudo systemctl restart docker
echo "dtoverlay=disable-bt" | sudo tee -a /boot/config.txt
sudo systemctl disable hciuart
sudo reboot
sudo useradd -r -s /sbin/nologin openhab
usermod -a -G openhab pi
sudo mkdir -p /opt/openhab/{conf,userdata,addons}
sudo chown -R openhab:openhab /opt/openhab
cp /usr/lib/tmpfiles.d/legacy.conf /etc/tmpfiles.d/

→ add d /run/lock 0775 root dialout -

Create the following stack:

version: '2.2'

    image: "openhab/openhab:latest"
    container_name: openhab
    restart: always
    network_mode: host
      - "/etc/localtime:/etc/localtime:ro"
      - "/etc/timezone:/etc/timezone:ro"
      - "/opt/openhab/addons:/openhab/addons"
      - "/opt/openhab/conf:/openhab/conf"
      - "/opt/openhab/userdata:/openhab/userdata"
      - "/dev/ttyAMA0:/dev/ttyAMA0:rwm"
      OPENHAB_HTTP_PORT: "8080"
      OPENHAB_HTTPS_PORT: "8443"
      USER_ID: "999"
      GROUP_ID: "994"
      EXTRA_JAVA_OPTS: "-Duser.timezone=Europe/Vienna"
      CRYPTO_POLICY: "unlimited"


Allright, I have also had to modify my /etc/default/openhab and had to add


In your case that should be:


It’s probably better to copy the default file to the appropriate directory and edit that but I was too lazy to figure out which one that was.

With docker i don´t have the path /etc/default/openhab but i think with this line in my docker-compose file EXTRA_JAVA_OPTS: "-Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0" should normally load the export var ${EXTRA_JAVA_OPTS}. I did this now, and you can guess, no success…

# set JVM options
ARCH=`uname -m`
case "$ARCH" in
    *arm*) ;;
  *aarch*) ;;
        *) EXTRA_JAVA_OPTS_ARCH="-XX:+UseG1GC" ;;
export JAVA_NON_DEBUG_OPTS="-XX:-UsePerfData"

Have you tried running openhab without docker? I am unsure about docker security but that might interfere. At least you would know your board is working correctly and you would have a lead on where to find the problem.

Yes, i previously had OH 2.5 in this constellation (Raspberry Pi 4 / Razberry Board) running for a long time without any problems, since the switch to OH 3 the board no longer works - like a lot more, but that’s another story … what has changed is the version of OH and the move to Docker


i have now found the solution. The following post provided me with the necessary information:

If openHAB is installed in a Docker on a Raspberry Pi OS, the serial console must be deactivated via raspi-config and the serial port must of course be activated.

@JoveToo thank you for your help.


Glad you got it solved!