Z Wave Controller Repeated ONLINE to UNINITIALIZED 'openhab-ui-zwave'

I’m fairly new to openHAB and have been trying to set up Z Waze.

I’m using a fresh new instal of OH 2.5 on a RasPi 4 and I have added a Z wave stick and started the Z wave binding.

I have managed to include a device for testing but am having problems with intermittent connection to the Z wave binding.

It looks like this is the cause: Failed installing ‘openhab-ui-zwave’

Help appreciated

SOLVED see post 9

My log loks like this:
2020-07-03 19:26:58.176 [vent.ItemStateChangedEvent] - ZWaveSerialControllerSerialSof changed from 28 to 29

2020-07-03 19:26:58.195 [vent.ItemStateChangedEvent] - ZWaveSerialControllerSerialSof changed from 29 to 30

2020-07-03 19:26:58.209 [vent.ItemStateChangedEvent] - ZWaveSerialControllerSerialSof changed from 30 to 31

2020-07-03 19:26:58.240 [hingStatusInfoChangedEvent] - ‘zwave:device:22c99d1e:node2’ changed from ONLINE: Node initialising: REQUEST_NIF to ONLINE

2020-07-03 19:27:39.825 [hingStatusInfoChangedEvent] - ‘zwave:device:22c99d1e:node2’ changed from ONLINE to UNINITIALIZED

2020-07-03 19:27:39.885 [hingStatusInfoChangedEvent] - ‘zwave:device:22c99d1e:node2’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

2020-07-03 19:27:39.886 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:22c99d1e’ changed from ONLINE to UNINITIALIZED

2020-07-03 19:27:40.131 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:22c99d1e’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

==> /var/log/openhab2/openhab.log <==

2020-07-03 19:27:40.936 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-ui-zwave’

==> /var/log/openhab2/events.log <==

==> /var/log/openhab2/openhab.log <==

2020-07-03 19:27:45.273 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

The zwave binding or the zway binding? They both use the Z-Wave standard.

I have not heard of Z Waze

Was this an upgrade to 2.5 from an earlier version? There were several breaking changes in other addons that could cause those symptoms.

Hi Bruce.

Thanks for getting back

Sorry the ZWave binding

No this was not an upgrade, Iit was a fresh download of Openhabian. Which installed openHab 2.5. I then choose to update to the latest features in the openhabian -config.

Did you import an older configuration? i am trying to help figure things out.

Which version of OH is displayed at the bottom of the page when you go to the dashboard (https://ip_or_host_name_of_your_OH_server:8443/start/index)? Are you possibly on OH 3.0?

Were you installing the binding at that time, or is this an unexpected automated install attempt?
There are problems associated with addons.cfg file that can cause that.

Wow… good call! I was trying to think of where a ‘openhab-ui-zwave’ could have come from, but makes sense if manually configured in addons.cfg! The only thing that came to mind was a new UI for OH 3.0.

Hi Guys

No config files moved over, My config files only date back to the 1st July 2020, when I started set up from scratch.
I started with zwave setup today.
I did start writing a zwave.cfg as per the guidance on line, but then I saw a post that said it was not required. I did save the config file with the port and ControlMaster values define.I have since deleted that. (Now found that there are multiple sets of documentation)

Version at bottom of dashboard is: openHAB 2.5.6 Release Build.

Thanks for trying to help me.

My addons.cfg contains this to start the binding:

A comma-separated list of bindings to install (e.g. "binding = sonos,knx,zwa

binding = astro, hue, squeezebox, wemo, harmonyhub, network, zwave

A comma-separated list of UIs to install (e.g. “ui = basic,paper”)

ui = basic, paper, habpanel, habmin, habot, classic, restdocs, dashboard,zwave

zwave isn’t a ui. You want to take that out.


This will also cause OH to attempt restarting all addons every minute, which will make your Z-Wave devices unusable and cause the Things to flop from ONLINE to UNINITIALIZED.

Keep in mind that using the addons.cfg is also optional, and if you use it and add an addon through the REST API (like a UI) or console, the addon will uninstall itself after OH is restarted. There are nuances, but basically, if you use addons.cfg, don’t install addons any other way.


Thanks rossko, must have typed it in on the wrong line at some point.

Problem solved though thanks again.

Selecting through a UI avoids issues like that :wink: