Z-Wave Database cannot create new device

I’m trying to create a new device in the z-wave database but when i try to submit a Label and Description i get a pop-up saying “Error”.

I get told “Error” if i include the node XML or not. I was granted permission to add new devices on the 25th October.


Welcome to OH.

The first error might be because no XML was pasted in. The second error is normally because this is a new manufacturer (I’m guessing it is LS Control 0x0071) that has to be added. You can open a ticket and include the XML. Only the developer @chris can add that, after it is added, you should be good to go.

There could also be an error for other reasons like a duplicate device, but I’m guessing not, since I assume you already tried to include in OH and are using the XML generated in the userdata/zwave folder. You could check this by using the TYPE:ID hex pair in the search field, something like 0004:035d or whatever.

Thanks for the welcome :slight_smile:

LS Control is in the list of manufacturers and you are correct, the manufacturer id in the XML is 0x71. The XML was generated by OH in the userdata/zwave directory and a link to that is below.


Searching for 0002:035d (Type:Device) doesn’t return any results unfortunately.

I’m usually pretty observant and I do not recall LS Control being there this morning. Give the create Device another try with the XML.

Also note, if it works now, that the Association Groups and parameters (if any) need to be manually added.

I’ve not added it recently, so it should have always been there.

Any idea on the error then? I see no devices under LS Control, so there can’t be a conflict.

EDIT: also, I guess I’m not that observant. :frowning_face:

Sorry - I didn’t look back at the error - I just saw the email saying that the manufacturer was missing…

I’ll take a look…

You’d think - right :wink:

But -:

This is presumably the same device - it doesn’t show in the list as it’s deleted, but it still checks the IDs (which is probably a bit stupid, but, hey…)

So, I’d suggest to first check if this entry is ok as it has parameters etc - it seems to just be missing the manual. If it’s ok, let me know and I’ll undelete it.

@Duncan_Hodson Please advise on the undelete.

@chris That is a new one for me. :wink: Thanks for looking into it.

Cool, that all makes sense :slight_smile:

I would agree that undeleting the device would be the best solution. I don’t know if anyone out in the world would be using OH with that device and would be relying on that db entry to be there even if it’s been subsequently deleted.

Google has very little information about the device and i’ve not been able to find a manual, but there is a page here that has some information.


If you do undelete, add a note saying that the sync button is inside the case, and to open the case you need to pop off the little plastic bump on the top to gain access to the screw which holds the thing together.


Once undeleted, with your write access you will be able to make changes. You will also need to attach something for the attachments, then mark for review.