Z-Wave device should exist in database, but isn't recognized

Hi all,

I am attempting to include a Jasco ZW4008, and am attempting to figure out if there’s an issue with the inclusion process, or if it’s just busted and needs to be replaced.

The device is included in the network, it sends the correct manufacturer ID, device type, and Device ID, they appear to match what’s in the database but remains an unknown device. I know it sometimes takes a little while for the binding to interrogate devices, but it’s mains powered and has been included for a month or more, so I’m thinking something isn’t right.

I excluded it a few times, and also did the 3-up, 3-down reset. Just now I’ve enabled debug mode and included it once more, and captured the logs. The device in question is NODE 26.

Does anybody have any ideas what might be going wrong here?

Thank you!

No, because you have not stated what version of openHAB you are running. (or what version of the zwave binding)

Sorry, forgot that… Stable across the board. 3.0.1 release build.

There were some database export issues when 3.0.1 was released. They were resolved shortly after that. You may want to try manually installing a snapshot version of the binding. The script should work or the README has the manual instructions.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Thanks Bruce, unfortunate that the released version had issues, but that’s a good explanation.

When I update to the next stable release, will I also need to remember to update the zwave binding with Scott’s script?

Actually, I would manually delete the jar file & install the binding from the upgrade.
After installing the snapshot binding you may need to delete the OH Thing & re-discover to get the latest settings.

Did this device work at one time?

Only if you installed the snapshot version. If you do use a snapshot, just remove it from the add-ons and then upgrade to the next stable version and install the version included in the stable version through the user interface. If you try the snapshot version now, uninstall the one in the user interface first, then just drop the snapshot version .jar file in the add-ons folder

1 Like

@Andrew_Rowe It worked with a different system (Hubitat).

@Bruce_Osborne The script is failing on a vanilla openhabian install, says it can’t remove existing unmanaged bindings (makes sense, there aren’t any yet). I ended up downloading the jar manually and will give it a shot. But, that did the trick! It recognized it without even needing to be re-included.

Thanks for the help, greatly appreciated!

1 Like

good work Brian! :+1:

Hey @Bruce_Osborne and @Andrew_Rowe, I’m sorry to re-open a closed thread, and even more sorry because I’m doing it to ask some rather beginner questions… :slight_smile:

I’m seeing this issue with another device, where it exists in the database, it appears to correctly complete the inclusion, the xml file is generated, but the device appears as unknown.

As noted previously in the thread, I’d tried the 3.1.x snapshot of the binding with OH 3.0.x (it was the only snapshot available at the time) and it worked to get the other device included, but I subsequently had some issues and went back to the vanilla binding. Since then I’ve updated, and I am now running 3.0.2 stable across the board.

I will keep digging into the issue, but I was wondering:

  • Do you know if the database export issues that @Bruce_Osborne referenced above also affect device identification in 3.0.2 stable? Looking at the debug log, it seems like it can’t match the device, but I’m not sure why. I see that it checks two entries for zooz_zen16, but neither results in a match. Does anything stand out to you?
  • How compatible are minor versions of the binding? If I need to pull in a new snapshot of the binding, should I always stick with one that matches the major/minor of my OH version (e.g. 3.0.x vs 3.1.x)?

FWIW, the device is a Zooz ZEN16 relay, FW version 1.3: OpenSmartHouse Z-Wave Device Database
The XML file is here: node_102.xml · GitHub
The debug log is here: zwave-debug-log-node102 · GitHub

You need to use a newer binding. 3.0.2 is from April so it presumably does not have the device that you require in the binding. The safest approach is to update to the snapshot binding as you already tried as it will have the latest database included.

I’m not sure what export issues were discussed, but I don’t think there is any problem. You need to use the snapshot version. Release versions are fixed - the code and database will not change, so downloading it again at a later time will not help.

Awesome, thanks @chris!

Back in March it looked like there were only 3.1.x snapshots available in artifactory, but now I see there are also 3.0.3 snapshots. I’ll start with 3.0.3 and see how it goes.

All 3.0.x have the same binding database. from December 2020,

You actually need 3.1.0M4 or later to get updated databases. There were changes made in snapshots and they are no longer backward compatible. I think Milestone 5 is the latest,

Thanks @Bruce_Osborne, I’m seeing some failed dependencies using a 3.1.x binding with OH3.0.2 (above and beyond the serial binding), so maybe I’ll just hold tight until 3.1 goes stable.

Thanks also for the explanation on database export timing. That’s really helpful.

1 Like