Z-Wave devices only sends update messages but no values

Tags: #<Tag:0x00007f616f669950>

I have switched my Z-Wave-Stick from Z-Way-Controller (where all sensors worked fine) and started with a new openhab2 installation and the z-wave binding.
Most devices worked from the scratch, some of them are not recognised and listed as unknown.
But even devices that seems to work, did not update with values in Openhab2:
2020-07-30 12:36:25.416 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:804e5eda:node43’ has been updated.
2020-07-30 13:34:41.139 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:804e5eda:node43’ has been updated.
2020-07-30 14:32:55.281 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:804e5eda:node43’ has been updated.
2020-07-30 15:31:08.331 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:804e5eda:node43’ has been updated.

This is from an Philio PST02A and I have re-included those door sensor but without any change.
Any hints or links for me?

Which binding did you use previously? zway or zwave? Perhaps the unknown devices are no in our community maintained device database.

I use the z-wave binding. And of course they are there. Two examples:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/367
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devices

I did not know because you did not state that. I know there is/was a zway binding too that does things differently.

I told about the z-wave-binding at the end of my first sentence. But anyway: The z-way-binding is for polling the z-way-api from an existing z-way-server. But I decided to completely switch from z-way to openhab2.

1 Like

That told me you are NOW using the zwave binding. I did not assume your OLD binding was the same.

Ok, this is up to no good if I would point you to the beginning of my first sentence. :innocent:
Any hints for me why some devices (like the PST02A) send updates but there are no values? :thinking:

Most likely they have not yet been completely initialized. It takes several wake-ups for some devices, and a length of time for battery devices.
What status do your new Things show?

It looks like a completely initialized device.!
Bildschirmfoto 2020-07-30 um 16.45.37|432x500

Do you have an Item linked to the channel of the device that is reporting?

I have put this in an .item:

Contact AlarmWZTuer “Tuerkontakt WZ Tuer” { channel=“zwave:device:804e5eda:node43:sensor_door” }
Number BatteryWZTuer “Batterie WZ Tuer” { channel=“zwave:device:804e5eda:node43:battery-level” }
Number TemperaturWZTuer “Temperatur WZ Tuer [%.1f °C]” { channel=“zwave:device:804e5eda:node43:sensor_temperature” }