Z-wave Disable "Polling Period"?

Whats the minium and maximum “Polling Period”?
A Namron 1402756 LED Dimmer got a bug that reports faulty when polled. So i would like to disable the feature. I tried setting 0 but that results in 15

The Command Poll Period has the ability to set 0 as disabled, as described in the Documentation. And I think Polling Period should have the same option?

  • Polling Period
    Set the minimum polling period for this device (in seconds)
    Note that the polling period may be longer than set since the binding treats polls as the lowest priority data within the network.

  • Command Poll Period
    Set the period to wait (in milliseconds) after a command is sent to a device before polling its state

(this was somewhat discussed over here

Polling period is set in the Thing Handler in two areas (max is 10 days)

> private final long POLLING_PERIOD_MIN = 15;
> private final long POLLING_PERIOD_MAX = 864000;
> private final long POLLING_PERIOD_DEFAULT = 86400;
> if (pollingPeriod < POLLING_PERIOD_MIN) {
>                 logger.debug("NODE {}: Polling period was set below minimum value. Using minimum.", nodeId);
>                 pollingPeriod = POLLING_PERIOD_MIN;
>             }
> if (pollingPeriod > POLLING_PERIOD_MAX) {
>                 logger.debug("NODE {}: Polling period was set above maximum value. Using maximum.", nodeId);
>                 pollingPeriod = POLLING_PERIOD_MAX;
>             }

Edit: I believe this is used in marking a node dead (and maybe other areas), so without a max, the node could stop responding and never be checked by the binding. Could put your concern on zwave github for the developer to comment, but I’m not optimistic

1 Like

Thanks @apella12 !
864000 does indeed help much.
maybe this should be added in the z-wave binding documentation? Though this may not be relevant for everyone. Its still a relevant information.

(a side note: in my particular case, I’m using the dimmers daily, and they report correct to controller when used locally, so that should satisfy the binding, and not marking them as dead)

Just for info to people with similar issues.

I have just replaced all of these dimmers because of this problem (in my case branded EcoDim, they are all the same devices manufactured by Shenzhen SHYUGJ Technology Co. / HZC Electric). They all get marked as “dead” nodes after a while. Only way to resolve this state is to remove the mains power; after re-powering the dimmers switch back to “online”.

I have written to the manufacturer to see if they have an updated OTA firmware which they sent me (1.13) however this unfortunately did not solve the issue. @putrid, how did you determine that the problem is related to the polling response?

Its been discussed at another thread. and @kvolden describes the issue here

The dimmer reports the last value set on manually turning the dimmer-knob. regardless of what the actual value are.
My workaround was setting "Command Poll Period" to 0
Elektroimportøren (local distributor, who own the brand) have no clue. And I’ve been in contact with Shenzhen, just like you. And it seems like they don’t care, or have the interest to fix it. And I’ve gotten a few EcoDim 07, and they seems to report correct when polled(?), but are missing some features compared to the Namron ones.
(I don’t recall all the details regards those dimmers now)
(btw: Some EcoDim samples have been known to be sold as Namron at elektroimportøren. I hade to return them a couple of times before I got a Namron)

1 Like