Z-Wave: Fibaro Multisensor will not be recognized

Hi OpenHab Community!

I’ve got a Fibaro Multisensor that worked with OpenHAB 1.8, but I couldn’t get this working with OH 2 that I just setted up. First I installed the beta 4 version via package repository, afterwards changed to snapshot, but today I started again from scratch with the snapshot manual installation.

I removed all openhab files from my debian system (on a RasPi 2 using Raspbian). The node10.xml file wasn’t regenerated afterwards.
The device was added as a thing and listed in the things overview in HABmin, but is shown as unknown. In the attributes tab no information are available (e. g. no manufacturer). I also pushed the button three times to start initialization again, according to the log the device woke up and communicated with my controller.
My other z-wave devices are working.

Maybe the first lines of the log are already helpful, you can find the full log for this node in the attachment (see below):

2016-12-19 23:19:14.228 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 10: Node found
2016-12-19 23:20:54.956 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 10: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2016-12-19 23:21:16.790 [WARN ] [ding.zwave.handler.ZWaveThingHandler] - NODE 10: Initialising Thing Node...
2016-12-19 23:45:45.962 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 10: MANUFACTURER not set
2016-12-19 23:45:49.532 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 10: Node found
2016-12-19 23:45:49.683 [DEBUG] [ve.internal.protocol.ZWaveController] - NODE 10: Init node thread start
2016-12-19 23:45:50.589 [DEBUG] [l.initialization.ZWaveNodeSerializer] - NODE 10: Serializing from file /opt/openhab2/userdata/zwave/node10.xml
2016-12-19 23:45:50.590 [DEBUG] [l.initialization.ZWaveNodeSerializer] - NODE 10: Error serializing from file: file does not exist.
2016-12-19 23:45:50.786 [DEBUG] [alization.ZWaveNodeInitStageAdvancer] - NODE 10: Starting initialisation from EMPTYNODE

Looks like communication is working:

2016-12-20 00:01:00.541 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 10: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 19.9
  • OH2 Version:
  • Binding Version:
  • Device name: Fibaro FIBEFGMS-001-ZW5 5G 4-in-1 Multisensor
  • Device version: I assume >= 3.2

Here you could find the log where I only extracted loggings related to the node, I hope that’s enough: node10-20161219.log.txt
Right now no new xml file was generated, but here is an old one for this device I saved before reinstalling everything:

Thanks for your support and best regards,

That multisensor works fine in my openHAB2 installation, I think you just need to wake it up some more times.
Also your log looks fine from my point of view.
Or try to move the sensor closer to your controller during wake up.

I also have FGMS working in Openhab2. I would try the following:

  1. Exclude it
  2. Hardware reset it
  3. Include it
  4. Manually wake it during initialization when including it, you might need to wake it up manually several times.

Thank you both!

It looks good right now, device is recognized. I followed your tips. Exlude/Include and that right next to the controller. In the third attempt I got it working.
I already tried those steps, but it looks like the device wasn’t completly removed from the controller, so I had to set the old “connections” to failed and afterwards remove them, I also resetted the FGMS multiple times.

As a last step I saw that HABmin recognized the device, but in the log I saw security issues and I disabled the controller security settings. Are those settings important? I’m living in a house, not a flat where other families might have similar devices.

Best regards,