Z-Wave - GE / Jasco 46203 Dimmer Switch not receiving / providing updates

My System: Raspberry Pi 3, Rasbian, OpenHAB 2.5.9, Z-Stick Gen 5, JRE: OpenJDK 1.8.0_152

I have included the GE / Jasco 46203 Dimmer and GE / Jasco 46201 Switch into my OpenHAB setup. The Z-Wave Nodes are found through HABmin discovery and I can add them as things. The nodes seem to make it through initialization and I am able to add Switch/Dimmers Items. Once I try to change the values of the Items it does not turn the lights on/off. Also when I physically press the switch to turn the lights on / off it doesn’t make it back to OpenHAB. I’ve tried multiple switches so I don’t believe it to be a Hardware Issue.

I’ve looked in the logs using the Z-Wave Log Viewer and compared it to one of the switches that is working. It seem like switch is not returning a status. Seeing the logs didn’t return a status I took a look at the Lifeline Association Group and it is blank. I tried to set the Lifeline Association Group in HABMin to the controller but it doesn’t seem to take.

Thoughts on next steps would be greatly appreciated.

Log viewer output is attached

It looks like the binding is sending the commands ok, and the device is accepting them. We see the ACK very quickly after the commands are sent - this comes from the device, so it is recieving this data.

However, it is not responding to the GET request, and if it’s not actually changing level as commanded, then there is clearly something wrong. Given that it’s responding to the commands though, I’m not really sure what is up.

The only thing I can thing of is that the device was included securely, and therefore expects the commands to be encrypted. Since they aren’t encrypted, the device will ignore them. All I can suggest is to exclude the device and re-include it.

1 Like

Ok - I now see the ACK “from device” in the Log

As for the securely included devices with non-secure messages being ignored I have debugged a bit. I took a look at the attributes of the Switch Thing and the devices is using security -> My Z-Wave USB Stick is configured to Secure Inclusion Mode All Devices.

I excluded and then re-included the switch. It looks like it did secure inclusion (Logs Below). Later in the logs there are SECURE TXD / SECURE RXD. I assume this means OpenHAB and the Switch can talk securely.

I retried turning the switch on and off and I saw the same behavior / log entries in the Z-Wave Log Viewer. Looking in the actual logs it has the following log entry. Not sure if this is a mistake or normal to say security is not supported/needed.

2020-11-06 23:01:20.803 [DEBUG] [rotocol.commandclass.ZWaveBinarySwitchCommandClass] - NODE 41: Creating new message for application command SWITCH_BINARY_SET
2020-11-06 23:01:20.804 [TRACE] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 41: Encapsulating message, endpoint 0
2020-11-06 23:01:20.805 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 41: SECURITY not supported
2020-11-06 23:01:20.806 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 41: Command Class COMMAND_CLASS_SWITCH_BINARY is NOT required to be secured

To finish this out I excluded the Switch, Changed the Secure Inclusion Mode of the Z-Wave Stick to Entry Control Devices, and re-included the switch. I verified in the attributes of the Thing that the switch was not using security. Tried the switch and Success - I can use the on/off. Seems to be a viable workaround.

It’s a bit difficult to know quite what’s happening without a log, but I at least it’s now working :slight_smile:

My Logs have rolled over at this point and I’ve implemented the work around on all of my switches. I do have this chunk of the logs that shows the issue from the OpenHAB Item Change to Switch not working direction. The issue switch is Node 40.

2020-11-05_GE-Switch-Debug.txt (83.5 KB)

I am happy with the workaround. I did just added a Lock and it was included securely therefore this seems to be localized to this brand / model / version of switch or maybe my setup. If you would like to dig into this further I can recreate the issue and provide the logs for the full lifecycle (inclusion, OpenHAB command to switch, and switch status change to OpenHAB)

Thank you for the help.