Z-wave: Multiple "unknown device"

  • Platform information:

    • Hardware: Raspberry Pi 4
    • OS: openhabian 5.10.63-v7+
    • Java Runtime Environment: Zulu11.52+13-CA (build 11.0.13+8-LTS)
    • openHAB version: 3.1.0
  • Issue of the topic: Z-wave: Multiple “unknown device”

  • Please post configurations (if applicable):
    None that seams to give any clues.

  • If logs where generated please post these here using code fences:

My OH3 installation rund fairly well, but there are some issues I still need to fix. One of them are to fix my 4 z-wave devices that are listed as “Unknown Device” as thing-type.

I’m not sure if they have ever been fine once using OpenHAB. I think they worked fine when I ran Home Assistant on the same rPi and z-stick. I think these 4 devices are 2 water sensors, a Neeo brain (controller) and a Hank SCN01 button.

I have tried to solve this issue by waking both the Hanks button and one of the water detectors, but no change. I have also tried to exclude the Hank, but it didn’t seem to work. The should be orange blinks, but there were none. What does that tell me about the “unknown device”? What is the best approach here? The Hank kept beeping (2 or 3 groups of 2 short beeps) when I tried to exclude and include it but I can’t find any documentation on what that could tell me. What would you do? What more information can I add to this post that could help it?

Please go to the Things page and post the device information for your devices, e. g.:


OK, here they are. All unknown and the z-stick:

I had hoped to see the manufacturer ID, the device type and the device ID …

Are there XML files for Nodes 001, 002 005, 008 in ...userdata/zwave?

Excerpt from the manual:

Scene Controller will send battery report to the lifeline group
when Z-Button is triggered during the sleep mode. If the battery
level of the Scene Controller is less than 20%, the Scene Controller
will beep 3 times when the button is pressed.

There are only XML-file for Node 1:


The battery should be fully charged. It alternated between red and green when I removed the charge cable.

Maybe the devices are indeed unknown to openHAB?

There is a list:

Hard to tell what you actually did here. The devices are going to need to be included while on OH. If they were on the zstick from Home assistant they may show as online, but as an unknown device. They could also be unknown because they are not in the database as noted by @weberjn. My advice is to exclude from the zstick with Home Assistant and follow inclusion with OH scan. Or factory reset devices and the zstick and then include in OH, or some variation that starts with an unpaired device with the zstick in OH. Or provide more information regarding the transition history and the actual device names and model numbers.


When switching between OH2 and 3 I had to sit next to the controller and pop the battery out of most my battery powered devices to get fully discovered. One took over night

It’s as @Andrew_Rowe said - you need to wake the devices up - or wait for them to wake up a few times. The devices are simply not discovered yet - ie the binding doesn’t have enough information to link your device to the devices in the database. You can see this a) because in your first image of the properties, the manufacturer, type and id properties are not there, and in the XML, they are listed as 0x7fffffff (which is an invalid value and used when the data is not known).

Well, at least the Hank is known. I linked it in the original post.

Do you mean the devices needed to go through som kind of cold restart? Why?

Can I do this in an orderly fashion? Are these information transfers to the binding visible in the log? So that I can see if waking a device means the binding is getting more information about it.

I’m still in the reset and start over camp (alone?). I’m bothered by the fact the controller is not Node 1, as that is the default node for most battery devices to send a wake-up notification to, but I do not have the expertise of some of the other poster replies.

Anyway, to answer your question, you can set the Zwave binding to Debug mode, do your wake routine and analyze the debug file using this tool to see what is going on. Don’t forget to set it back to INFO as it is very verbose

You can set the log level in the console.
Screenshot 2021-11-29 105245

The second password is habopen

Good luck


Sorry - I don’t really know what you mean by this. You can do it “one by one” if that’s what you mean - just wake up the devices by pressing whatever button wakes it up.

Yes, all communications is logged if you enable debug logging.

I ended up connecting the Z-stick to a PC and deleting the nodes with Simplicity Studio from the controller. I then nuked the device and included it. Worked as a charm.