Z-Wave Node losing regularly connection (Eurotronics Spirit)

Dear Openhab Community

I’ve been using Openhab for a bit more than a year now. I been using the community forum, but I’m not going any further with an issue on my Z-Wave network.

1) System Information
My network consist of 5 nodes:

  • 1 Aeotec Z-Stick Gen5
  • 4 Eurotronics Spirit Z-Wave plus
    Openhab 2.5.2 running on a Synology NAS (DS718+ / CPU Intel Celeron).

2) Problem
I’ve been running this network until September 2020 without any major issues. As I restarted the heating system for this winter (beginning of October), I keep on loosing one node. It is shown as “OFFLINE - Communication error” in Paper UI.
After a while it will get back Online.
In the event.log I have following message
'2020-12-12 09:43:13.914 [hingStatusInfoChangedEvent] - 'zwave:device:78787b80:node4' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller '
That device is not as far away as some other nodes from the controller.

I’ve analysed the event.log.
Yesterday it was Offline 12,5hours and changed from OFFLINE to ONLINE 51 times.
Today, without any changes, it occurred 8 times and the device was online for 22 hours.

Moreover the heating mode, is not working.

3) What I’ve done so far
I’ve look at quite some post in the forum without finding anything

  1. Uninstall Openhab
  2. delete the whole openhab directory
  3. Exclude using the stick all single nodes
  4. Reset the stick and all Spirit to factory settings
  5. Change the battery of the faulty node
  6. Include all nodes from the stick
  7. Reinstall Openhab
  8. Add all new Z-wave from the inbox of Paper-UI
  9. Copy from my backups only the items, rules and sitemap, and persistence files.

It did not really helped.
I’ve noticed in HABmin, that

  • on the first days after the reinstallation. The nodes where not showing any neighbours.
  • yesterday, all nodes except 4 where linked to node 1 (The Stick)
  • Today using the network analyser, I got this

4) Questions

  • Do you have any idea where the problem could come from?
  • Does the device have an issue?
  • Is that a range problem?

Thanks for your support and advices.

I’m adding the z-wave debug log.
debug.log (896.5 KB)

With 4 battery powered nodes and the controller, you have a very weak mesh. All of the device must communicate directly with the controller. Adding some mains powered devices will help. Placement of the devices can help/hurt too. Walls, floors, metal garbage cans, file cabinets, etc… lots of things can cause interference.

Possibly. Since they are battery powered, have you tried manually waking them up? Have you tried replacing the batteries?

Thanks for the answer! :+1:

OK, I there any chance to verify that? Is their any measure of the signal strenght?
I want to avoid bying a main powered device that I don’t really need.

Do you have any idea, why one of the items (Heating mode) of that device is not showing up?

Yes I did wake them up, did Reinitialise or heal the devices as well, did not help eather.
The battery are brand new.

I think @5iver was being a little optimistic :slight_smile: With only battery devices in your system, you will have NO mesh network. As Scott said, all devices will need to communicate directly with the controller - there will not be any possibility for routing.

If a device is offline, it means that the controller has tried to communicate, and got no response. We see this with node 4 in your log. It’s worth noting that a lot of things can influence range - not just the distance between the nodes - so it’s difficult to compare just “by site”. Unfortunately there’s no easy way to look at signal strength, but the log is quite clear that at least node 4 has communication problems :wink:

Mesh of 1? :grinning_face_with_smiling_eyes:

Thanks @chris & @5iver
I’ve read already some thread about battery devices not being meshable.
This morning I have this sort of layout in HABmin.

That does look like a mesh for me, but I’m not an expert enough. (node 4 does communicate with 2 to reach 1).

I do understand, that both of you recommends to add a main-power device. Does it need to be a range extender or whatever plug will do?

Any idea why the heating mode is not shown as a thing for that specific node?

Correct - it does…

However - you also need to remember that this shows neighbours - not routes. So a link in this table simply means that one device can hear another device - it doesn’t mean that it will be able to route via that device. Routes are managed by the controller, and are unknown to the binding.

In this case, all devices are battery devices, so they will not participate in routing. The fact that node 4 does not appear as a neighbour to node 1 simply confirms the point I made earlier - the link from node 1 to node 4 is poor - this is causing communication problems, and timeouts, which sets the device OFFLINE.

Any mains device will be fine - they will all work as a router.

I’m not sure what “particular device” you mean. You should have a “thing” for each node in the network.

:face_with_hand_over_mouth: Oups, I mixed the wordings. I’m missing an item on that thing. Explicitly, I’m missing the heating mode item on that thing (Node 4).

Ok, I suspect you’re still mixing terms :slight_smile:

I guess you’re missing the channel? The binding only manages channels - you then create a thing to “talk” to the device via the channel, but the binding has no knowledge of items - that’s up to you to add.

If the channel is missing, then I would assume it’s not defined in the database. I’m not familiar with the device, but I see a “thermostate_mode” channel in the database - is this what you’re after?

Well, Probably not familiar enough with the terms.
You are correct the heating_mode is missing. zwave:device:78787b80:node4:thermostat_mode to be specific.
It is working well for the other 3, but is not working on node 4.

On PaperUI:
On node 4, I got :

On the other nodes, I got :

with a proper drop down list

Thanks for your great support and patience.

Well, I’m a bit confused as to what devices you have now. There is no “Heating Mode” channel for the Eurotronics Spirit in the database -:

I think we need to understand exactly what devices you have - can you provide the list of manufacturer/type/id properties for each device please.

The picture you are sending is looking good!

I’ve copied the following from PaperUI:

dbReference 	710
manufacturerId 	0148
manufacturerRef 	0003:0001,0003:0003
modelId 	Spirit
vendor 	Eurotronics

It seems to match with the link you sent.
I’m surely confused you between channels (Thermostat mode), and Items (Heating Mode)…

In all other nodes, It will show as a switch from default. But that one will show as a number…

Ok, yep - I’m a bit confused :slight_smile:

So the issue is not that the channel, or the item ( :wink: ) is missing, but that the option is missing? You’re seeing a 1 and have a numerical entry box in this node where the others have a dropdown?

I don’t really know why that is - they should all link back to the same thing definition - you could try deleting the thing and adding it back (not excluding). This will make OH re-read the thing definition. From what I can see, the definition in the database export looks ok, so hopefully that will fix it.

It did not helped. :-1:

Probably the easiest fix will be to set it as a “Selection” with the appropriate mapping in the sitemap…

Many thanks for your support. :clap: :clap:

I’ll look for a Z-Wave plug and come back on this post if the communication errors issue is solved.

I bought a Z-Wave Plug (Abus SHHA 100000 / Manufacturer 0403 / Type 003:0003).
The first day, it did improved a bit. (only 2 disconnections)
The second day (well yesterday), I had no disconnections. Let see if it keeps working stable now.

The meshing is a bit strange. The new node is node 6…But it is apparently not connected to the controller (node 1)…
I’m not sure if the neighbourhood is really representing the mesh…
Honestly that’s confusing. I Hope the network will stay stable.
Screenshot 2020-12-19 103111

I’ll keep an eye on it, and if it does stay stable, I will report this issue as solved.


It doesn’t represent the mesh - it represents neighbours that can hear each other. Note though that you have an extremely poor mesh as it looks like most of your devices are battery operated (other than node 6) - so mesh networking really will not work well.

This information is only updated periodically - normally during the heal.


I did won a couple of bids on ebay and end-up with 2 main power devices, that I spread around my flat. The connection issues have disappeared. Thanks for the support