Z-Wave not getting state changes

I have an Aeotec Gen5 usb ZWave stick and four Fibaro FGS-223 binary switch controllers. And I am finding that in the case of two of the four FGS units, it takes ages for their binary switch input state changes to be received in OpenHAB.

It seems that the immediate event message is getting lost, and it only updates when a polling cycle occurs, or when in HabMin I ask it to “refresh items”.

I think it can’t be a wireless problem, since in one case the FGS unit is within 50cm of the stick. Although in the other case the FGS is about 10 metres away.

I had previously used another ZWave stick (from ZWave.me) and that was fast. However that stick was giving a lot of error messages, so I changed to the Aeotec stick instead. So I either get error messages, or fast response…

Is there some way to resolve this?

If there are failed ghost nodes stored on the controller as part of the network, devices sometimes try to route through them causing strange delays. Have you fpollowed the instructions and looked at debug logs for clues?

Instructions: (When things don’t go as planned)

Log Viewer:

Hi Chris, many thanks for responding; you kindly posted two links a) with instructions, and b) pointing to the tool; however both links actually are the same (for the tool); — is there another link for the instructions?

1 Like

Sorry. copy/paste error. Fixed.

See also

Hi @rossko57 – I guess you are referring to the Device Configuration Parameters (see screenshot below). This looks as though it might help me, but I do have a query concerning the values to set.

  1. Polling Period says “set the minimum polling period for the device in Seconds” – but the UI actually offers a drop down list to select values in Minutes, Hours or Days, so it’s not clear if selecting a drop down entry will indeed set the correct Device Configuration Parameter value. ??

  2. Polling Period’s lowest drop down selection list value is 10 Minutes; is there a way to set it at say 1 Minute = 60 Seconds??

  3. Command Poll Period offers a default value of 1500; and it is unclear if this means Days, Hours, Minutes, Seconds, or Milli-Seconds; would changing it to 60 (= Seconds) make sense? Or it also has a drop down selection list value “Disabled”. What do you suggest?

I looked at the Java code, so I can answer my own question:

Both parameters are configured in Seconds. It seems the drop down selection values do actually map to respective seconds values. However it would be good to modify the code to make this clearer for future users.

If that code is the Z-Wave binding, please file an issue on GitHub.

This is in milliseconds.
When this parameter is set, the binding will “poll” the device for the new status after sending a command.
I don’t know what else might need setting in the device to get a response.
Example of use -

1 Like