Z-Wave serial Controller for Synology

I am currently migrating my test set-up from RPi3 to my new Synology DS916. All items/things/bindings work fine so far. I only struggle with setting up the Aeotec Z-Wave stick. On my PI3 it took me some time but finally it worked well.
Now I have running OH How can I find out which Serial Port in the HabMin Configurations I have to type in. I tried /dev/ttyACM0 with not success.
I read in a few articles I have to add the openhab user to the dialout group. How can I do this? In the Syn- settings there is no such group. I f I have to set it up new, with which preferences.
Thanks for your help.

Remove the stick, then type “ls /dev/tty*” on the console. Add the stick and repeat and you should see an extra serial port in the list - this is what you need to use…

1 Like

Thanks for your extreme fast reply.
It is “/dev/ttyACM0” and this is, what I have in Port Configuration. Any idea, where I can find more information? Maybe and issue with access rights…?

I’m not sure - there used to be some setup instructions for the Synology (maybe for OH1 though) which might have covered this in more detail. I used to use a Synology but moved away quite a while back…

I would suggest a search on the forum. I just tried “synology serial port” and came up with a bunch of hits - maybe they might help…

One here on port settings might be a good place to start -:

1 Like

THX. I already scanned most of the related articels. Nothing really helped.
Unfortunately I am not familiar with the linux world. This is why it is difficult for me to understand the commands…

There’s instructions for what I did here:-

They should hopefully get you sorted.

Thanks. I am afraid it is an issue with access right for some users. I discovered that I cannot access/see subfolders in the public/openhab/conf/ folder, when I am loged in as “Hauptbenutzer”. When I do log in as admin, I have access. The openhab user has the same rights as the Hauptbenutzer. The thing is, that I have given read/write access for the public folder for Hauptbenutzer and openhab. And for other folders this is working absolutly fine. I cannot figure out, why there is an issue in the conf folder of public/openhab. I will post this issue in the synology forum. Hopefully I can find a solution.

I guess it is kinda late, but as this thread is coming up top on a Google search with Z-Wave and Synology, I wanted to add that this information finally helped me getting the stick working after reboot (chmod 777 /dev/ttyACM0 always worked only until next reboot):