Z-wave Controller does not connect

Hi there,
i´m new to OpenHAB, tried Domoticz for a while, and want to see whats around there.
I started to install OpenHAB snapshot on my Synology DS216j with DSM 6.1 like written in the User Manual. I got problems to the Z-Wave Bindings.
My Aeotec Gen5 USB Controller will not connect. See the added screenshot.

If I run domoticz, everything is fine.
Any suggestions, how to fix it?


This means it can’t connect to the serial port - so either the port doesn’t exist, it’s already open, or there are permissions issues…

Thanks for your quick answer.
So ,the port does exist, because i use the same controller in the same port in domoticz.
I don´t know how to check, if it is already open? I hoped to avoid conflicts if i do not run both programs at the same time. How can i check permission issues on my synology?

I´m not a programmer, so explain it to me like to baby. :wink:

I would guess that it\s a permissions issue, but I’m not sure. Check the installation instructions for installing USB under Java - there are some extra options that might be the issue (at least it’s quite common).

Uff that´s hard to me. I´m a User, not a programmer, and i don´t like to work with Editors or Consoles.
I´ll try at the weekend.
We´ll see what happens.

Are you trying to run domoticz at the same time as OpenHab? If so, the first program you opened will grab the device for it’s exclusive use and will not permit the other to access or use it. Only one program can access the USB port and controller at a time.

Just wanted to throw that our there.


Thanks for this hint.
I do not run both programs at the same time.
So i think the Port should be free.
Is it necessary to reboot the synology after stopping domoticz and before starting openHAB?

No - this shouldn’t be necessary.

My guess is you need to add the extra options to tell Java about the serial port as per the earlier link.

It’s because openhab can’t see your z-stick. Here’s the instructions I keep handy for my own Synology (DS214play) - cos occasionally the DSM updates delete one or both of these files (so just re-create if that happens)…


// add user ‘openhab2’ to groups ‘dialout’ & ‘uucp’
// create the two file below (all details below)
// and then reboot server.
// doing ‘ls -l /dev/ttyA*’ should give this output like
// #> crw-rw---- 1 root dialout 166, 0 Feb 26 09:40 /dev/ttyACM0

// create ‘/lib/udev/rules.d/openhab-zwave.rules’
// with this content:
ACTION==“add”, KERNEL==“ttyACM0”, MODE=“0660”, GROUP=“dialout”

// create file (anywhere) with text below.
// chmod to 755
// chown to root:root
// move to /usr/local/etc/rc.d/S98openhabzwave.sh
// (do not create in that location as you can’t then chmod or chown the file)

echo ls -l /dev/tty* >> /volume1/public/tmp/zwavelog.txt
chown -R root.uucp /run/lock
chmod -R g+w /run/lock
chown -R root.uucp /var/lock
chmod -R g+w /var/lock
echo “do nothing”
case “$1” in
echo “usage: $0 { start | stop }” >&2
exit 1
exit 0

1 Like

What is the right user to add to the groups “dialout” and “tty”?
The link names the user “openhab” and Neil names it “openhab2”

create groups called ‘dialout’ & ‘uucp’.
add the user called openhab2 to both of those groups.
Then create the two files as it says above.
Then reboot.

It should work.

Is the Synology package using another username (openhab2) other than the usual openhab used in the Linux distributions ?

edit: it seems yes…

DAEMON_USER="$(echo ${SYNOPKG_PKGNAME} | awk {'print tolower($_)'})"

@DSTM: Yeah, this fixed it for me.
Thanks a lot.

Hm, tried this again after some Synology updates (i´m now on DSM 6.1.4 Update 5) and with OpenHab 2.2.010 (stable), but after doing the steps @DSTM wrote i cannot start openhab at the Synology Package Center. I´m only told that the openhab package cannot be executed. Has somebody any solutions?


Ok, got it. The user in Synology has to be named as “openhab” not “openhab2”.