Z-Wave stick + Danfoss RXZ2 channel; switch (Central Heating)

I followed the log:set DEBUG command as per troubleshooter, anyway, here it is to zwave.log
Zwave log attached (too big to paste)
(I rebooted the Pi and then did the scan):
Tried inclusion several times, uploaded the entire zwave.log

zwave.log.txt (145.2 KB)

The manuals I have paper copies, no online, I’ll keep looking.
Thank you for your generous support.

Link to the manual should help.

This log seems to show that you pressed the search button twice very quickly (in itself not a problem), but then the log ends, so we don’t actually see what happens during the inclusion.

Unfortunately that doesn’t provide a lot to go on.

Ah, quite, sorry:


Mine is the RX2 (2 channel), but all Danfoss HVAC Switch receivers are included here.

1 Like

Nope, I tried three times, and the inclusion is very simple. I doubt I got it wrong three times.

I shall clear that log and do it again…


Well, the logs don’t lie, and I can only go on what is in the logs - sorry.

I dont lie either , why would I. Ive been trying this all day pal.
Hat off to you though if you really can follow the log and interpret it :slight_smile:

Right, here is the log:

  • Placed the Danfoss into factory reset state.
  • Rebooted
  • In OH , Inbox->Add->Z-wave binding.(do this before attempting association as per install guide)
  • OH Searching.
  • Put Danfoss into association
  • Danfoss FAILED - flashing orange light as per install guide.
  • Put Danfoss into factory reset again
  • In OH , Inbox->Add->Z-wave binding.
  • OH Searching
  • Put Danfoss into association
  • Danfoss FAILED - flashing orange light as per install guide.
  • Put Danfoss into factory reset again
  • SSH into openhabian
  • Wait 5 mins
  • sudo su sync (to flush buffer to files)
  • Upload zwave.log

zwave.log.txt (68.1 KB)

An at all times the Danfoss LEDs were indicating correct procedure (!) until end when it failed (twice)

I didn’t say you did - all I said is that I can only go on the logs that you provide. The log that you provided was extremely short. It certainly did not contain 3 attempts at inclusion, so either you provided a log that did not match up with what you did, or you didn’t do what you thought you did!!!

And people have been trying all day to help you!

refer you to my previous post.

fedup now
will await @sihui he certainly is helping - lots

Well, this log does not tie up with what you are saying either, so something is wrong with what you’re doing!

The log is 2 minutes long!

Anyway, the log doesn’t show any devices joining, so there’s not a lot that I can say. If the controller doesn’t include the device, then there’s not a lot the binding can do. Possibly the device is faulty.

I’m not sure what you want me to refer to?

I am uploading what is in the log file. Maybe its another OH Bug?
And I ran “sudo sync” to flush buffers.
The log file keeps growing, here it is again as of now.

zwave.log.txt (68.3 KB)

anyway, sleep well, my head hurts now

What are you referring to? What bug? Sorry, but please try to be clear.

Well, you probably know how to read the logs better than me. All I can say is there are no devices being added to the controller during the inclusion.

YES, and that was the point of the OP. IT FAILS INCLUSiON . I never said I cant bind to channels, it doesn associate./ include whatever. Cant think now, too tired

Im done. sore eyes

Yes, that’s what I’m saying - there are no nodes being added to the controller during the inclusion - it’s what I said earlier -:

I also suggested that possibly the device is faulty (either the device, or the controller). Are you sure they are both for the UK and not other regions?

So, do I understand that you think the failure to perform inclusion is a bug in openhab? If so, this is clearly not the case - the inclusion is a negotiation between the device and the controller. As I keep saying, there are no devices being reported BY THE CONTROLLER.

Cant sleep, cant get this out of my head :slight_smile:

I have no idea Chris how this all works. I have no idea where if at all there is any bug. And I’m certainly not proficient or skilled to read the log and interpret it. All I see is the controller (0x0115) working (I think) going through it’s steps but that’s it. Code from https://github.com/OpenZWave/open-zwave/blob/master/config/manufacturer_specific.xml

As I say though, the OP was relating to non-association of the switch (the programmer/receiver)

I cannot see the 0x0002 ID for Danfoss anywhere in the log. In fact,. it isnt listed on that xml above either.

Could be it doesnt work. It is normally sold with a proprietary thermostat and the two are associated, however it - is supposed - to be able to connect to a 3rd party network according to the install manual.

I can of course repeat myself - the device is not joining the network. The inclusion is a transaction between the controller and the device. When the device is added to teh network by the controller, the controller will send a message to the binding to say that this is done. This is NOT happening - I can only conclude that the device is not joining the network for some reason.

No - it won’t be. The XML above is only for the controller. There will be a separate XML file for every other device that joins the network.

Until the device is communicating with the controller, there won’t be much that the binding can do.

So is the Switch (can we call it that - the Danfoss 2 ch switch) not even sending anything back when the controller enters association? I do understand if thats what you are saying.

In that case, is there any linux util you know of that works outside of OH and will debug the network, association and handshakes. Just to take OH out of the loop and run something direct using the controller?

I can’t answer that - maybe it is, but it is not enough to keep the controller happy. There is a level of communication below what the binding sees - the only way to see this is with a network sniffer. The switch might be communicating to the controller, but maybe it’s not saying all the right things to keep the controller happy. Or - it might simply not be sending anything.

No - there’s nothing for Linux. There is a windows network sniffer available, but in reality, it’s not going to help you. You might be able to decode all the low level traffic, but it probably won’t mean a lot to you, and even if it does, it won’t help you actually get it working. The problem will still exist.