Z-wave stick goes offline after sudo reboot from cron

They are enabled in each z-wave stick (I’ve tried disable it - but it cause even more problems).

Commenting items/channels you are not interested in will not reduce traffic in the Z-Wave network. Only the representation of the channel on a programming level is omitted that way, the data will still be transported.

To reduce traffic in the network you may want to disable all reports you are not interested in or reduce the frequency they are sent if you cannot disable them.

Healing the network - as far as I know - is only needed when devices change their physical location so their neighbors are no longer correct. When the devices are not moved around, a network heal is no longer needed once is has been performed successfully.
As you have more than one controller, maybe you can schedule a heal at different times for each one. That way the amount of traffic is spread over time (wireless communication is done on a shared medium, so the controllers “see” the traffic of other controllers within their own range).

Thanks for your suggestions.

Still that will unload the quantity on programming level.

Commenting items/channels you are not interested in will not reduce traffic in the Z-Wave network. Only the representation of the channel on a programming level is omitted that way, the data will still be transported.

I’ve turn off all unneeded report as well. It’s a 101-103 and 111-113 parameter. In my case its 0 and report its 3600 - Here I can increase as far as I know up to 7200? Correct me if I’m wrong but that’s all I can do regarding reports from setting menu?

For now I have set the healing at 4am for all of z-wave sticks - I will change that and put 1h break. good idea. The best time for disable the healing is the day that whole system works like harm - I will wait for it (I’m not moving the devices - they are all the time in the same spots).

That is not strictly correct. The binding will not poll any channel that is not linked, so there will normally be a reduction in traffic - but in the grand scheme of things it isn’t high unless the user has set the polling period high.

This error is normally caused by some sort of low level problem in the serial communications. It indicates that the binding and controller have got out of synchronisation - in theory, it should resync, but given you don’t know the root cause, it may be that the resync doesn’t work due to some underlying problem.

I can’t help on your problems, but I have used a Zniffer to see the actual traffic and found zwave traffic that I did not think was happening, noisy devices and surprising routes. Zniffer also shows the delay between nodes on hops. Could be more complicated with three sticks. I have only one stick with 47 nodes and the zniffer is right by the stick. I’m down to about 4 frames a minute, including Acks, just the essential info. Was only $35 here in the US.

Chris, thanks for the clarification :+1:

What stick are you use to put zniffer on?

I used the UZB from Silabs. I’m not an expert, but think any other 500 chip zstick can be flashed, if you have a spare. I and followed the instructions on the web and the free Silabs firmware.

Personally I doubt that this will help you. The problem seems to be with serial communications between the controller and the binding, or possibly the computer is too busy and it’s dropping frames. Normally if there is a problem on the network, this would manifest in other ways - typically when sending data the frames would be rejected by the controller due to lack of buffers - you typically would not see the Out Of Frame errors that are in the logs here.

Hi, Thanks for check the logs,

IT’s Dell R240 - which is running up to 2-3% of its capacity
Maybe a new driver for usb would help /

Agree Zniffer may not help with this specific problem, but with an 3 Zsticks network, I can guarantee you will learn a few things and it is only about the cost of one new device.


I don’t disagree that it’s interesting to use the sniffer, and it’s possible to learn stuff - just that I had assumed the main drive was to solve the problem reported here, and I’m not sure it will help for that.

My context was the initial post indicated a weekly reboot using a cron rule, having the network in three parts and three nightly heals on each zstick was the going-in (“working”) situation. And now all that no longer works. IMO (I know this is your area of expertise- not mine) all that is not indicative of stability and a cause of lot of network traffic and possibly, however unlikely, caused the reported problem. If not it will be useful anyway trying to streamline what he/she has.


Other possibilities. There were issues with the OH3 nrjavaserial discussed elsewhere. Your error message is not the same, but it was related to serial ports. Might want to look through the conversations. Also here.

Also don’t know if you have the IP camera binding, but there is an active thread about a conflict between Zwave and IP camera.


I will check that topic later - no I don’t have IP camera binding installed.

Hi Chris,

I found this topic: Link

Maybe this is the issue - how do you think?

Hi everyone,
It seems that not only me have this problem revently. It’s connected with serial port reservation by kernel and openhab (dialout) afterwards.

Anyone solve it? present solutions on forum with adding “d /run/lock 0775 root dialout -” in /usr/lib/tmpfiles.d/legacy.conf and then copy it to /etc/tmpfiles.d/ and reboot - doesn’t work.

Hope someone solve it on Ubuntu 20.04

@Kai - is this problem connected with openhab or with Ubuntu itself?

Hi @quarku
Since I went from 2.5 to 3.1 a couple of weeks ago (I think this is when it started), I can never restart oh without pulling/reinserting the zstick before starting oh again, otherwise the zwave bridge will not go online. I don’t have debug enabled on zwave, so I can’t be 100% sure I have the same issue as you, but I suppose I do.

Next time I need to restart, I will enable zwave debug before, but I am not home at the moment. Just wanted to to confirm you are not alone :slight_smile:

Hi Micael,

Thank you for letting me know that I’m not alone. I need to restart 20-25 times sometimes to get it online and lately even if it shows that it is online the z-wave stick lock on some LED color for example red and I can’t control anything which is paired with this stick.

Pretty much z-wave works like ***** for me. I don’t know how to solve it (tired exerything already).
So I think I will exchange z-wave nodes to shelly to make house online again.

I’ve tried new z-stick which I’ve flashed with backup copy form last month - same behavior. It is clearly something related with serial port hadling.
Symlink doesn’t help and described methods on this forum doesn’t help.

The only think I haven’t try yet is mentioned by @apella12 above. I will inform here about the results.

Just need some more time becasue its not a clear tutorial there.