Z-Wave: Supress serial_sof events

Hi There,

with OH2 and the new Z-Wave Binding there are a bunch of Messages like

zwave_serial_zstick_d90ead21_serial_sof changed from 22807 to 22808

Is it possible to stop OH2 from reporting them (or logging them to another file)? It makes it hard to find relevant events.

Bests
Pascal

You should be able to just not link an item to this channel.

1 Like

sorry for post in an old thread but i have the same error in my logfile.
can you please post an example to connect this channel to an item?

i don´t know which think it sends. my logline is:

zwave_serial_zstick_0332b7c7_serial_sof changed from 127 to 128

It’s not an error. It’s just a log entry of type smarthome.event.ItemStateChangedEvent

The proposal is NOT to link anything to the channel serial_sof (Start Frames) of the Z-Wave stick

:fearful: Thanks, i don´t see this “not:blush:

A bit late, but the solution is to go to:

-paper UI
-find the Z-Wave Serial Controller under Things
-Uncheck the Start Frames by clicking on the blue circle infront of it
The unlinking will stop the counts from showing up in the log viewer

2 Likes

@chris - just a reminder that by default on a fresh openHAB 2 setup we give users Item Linking as “simple mode” …

In simple mode, links and their according items are automatically created for new Things.

If the simple mode is turned off, the user has the full control about which items channels are linked to. Existing links will remain untouched.

This just happened to me on a fresh 2.5.0 m6 setup.
After the fresh install, I just added the z-wave dongle as my first thing, and my log got absolutely inundated with such entries.

Any ideas on how a newbie would not fall into this trap?

Sorry - I’m not sure. It’s not really a trap though, this is simply the updating of a channel.

I think I’ve seen that this can be disabled through changing the log configuration though.