Z-wave with Aeon Z-stick S2 error

  • Platform information:
    • Hardware: i7 7820 48ram
    • OS: WIN11
    • Java Runtime Environment: zulu 17.0.9
    • openHAB version: 4.0.4
      Hello all,
      I am a first time user of openHAB. Thanks for your help.
      Just installed the program on my windows machine and seems to work fine.
      I have added the first binding (which is a Aeon Zwave Z-stick S2. The bridge status seem alright (ONLINE) but anytime I try to get the network information from the stick I get an error:

Exception in thread “ZWaveReceiveProcessorThread” java.lang.NullPointerException: Cannot read the array length because “message” is null
at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager$ZWaveReceiveThread.run(ZWaveTransactionManager.java:778)

I have one device already registered to the zstick but I cant update it to openhab.
Thanks for the help,

I believe that is a z-wave 700 series stick. Only 500 series sticks will work with the OH zwave binding (there is a long and detailed history of this decision on these forums if you care to search for it). You can use 700 series devices with a 500 series stick, but OH doesn’t use the api necessary to communicate with the 700 series sticks.

There are workarounds for this where you can use some other software as an intermediary between OH and newer sticks. Here’s one of the newer one’s:

Another option is to use a “release” of an unmerged PR to address 700 devices. I have tested these changes locally for several months, but it is not official.

I believe that the 10-28-2023 Release I have on my github website will work with OH4.0.4. Bindings tend to be version dependent (this is a OH4.1 Snapshot), but sometimes they will work depending on what has changed in the build/compile process. If that doesn’t work you can try the 7-28-2023 version which was compiled just after the OH4.0.0 release. If neither works, I apologize in advance :frowning_face:

How to try (assuming UI Zwave binding is installed):

  1. Enter the karaf console sudo openhab-cli console, your sudo passwd, then habopen
  2. type bundle:list -s and note the number of the zwave binding
  3. Copy the link to the .jar file in the Release
  4. type bundle:update “number from above” “release link”

The docs have a fuller explanation on how to upgrade a binding if you have trouble.

First of all I want to thank you both guys for the quick answer. My Z-Stick is very old model (about 10 years old). How can I tell if it is a 700 or a 500 device?

If it is old, let’s assume it is 500, so no need for drastic actions. Put the binding in debug using the little gear on addon setting page for zwave and try a restart. You can also use the zwave log viewer here. There could be something else going on. We’ll also be able to see if it is a 700/500 issue from the logs. Also does that zstick have a button and did you include the one device using the button or with the OH UI inbox?

Ok, strange things happened.
Just got back to PC (after24h). Started the openhab.bat. Opened the browser and localhost . . .
Nothing was changed. Put the binding in the debug mode (as you instructed). Went back to settings page (trying to find a place from I can download the log files) and got an inbox message with a new thing - if I want to add it or not. This thing is the only item I have included in the ZStick network yesterday ( and to answer your question - yes, the stick have an external hard button which I have used to add my Wall Thermostat.) So now I have 2 things :
1.Z-wave Node081: HRT4-ZW Battery powered wall thermostat
2. Z-Wave Serial Controller

Which is correct.

Still, when I ask to Synchronize network from the zwave controller I get the same error.
I have tried to upload the openhab.log file to this post but I am restricted to upload (new user).
I tried to copy/paste it with no success.

This is the best I could come up with.

Justo got promoted to trust level :slight_smile:
I can upload now.
Here is the log file.

openhab.log (123.0 KB)

The good news is that your controller is using the 500 Application commands. The bad news is the binding doesn’t seem to process messages from the node and I don’t see why. :frowning_face:

What does appear odd is the node number. Usually the nodes are assigned in order, so two nodes should be 1 & 2. What is the history of this controller?

Also how many lines are at the bottom of the the UI page for node 81? Four or Five?
Five Lines of configured node

The device seems recognized, but I do not see the configuration commands. They should start after the Request NIF. I’m kind of thinking to unpair your thermostat. Factory reset the controller and start fresh. This time using the Inbox, Zwave Scan.

What isn’t going to work is the synchronize network or heal commands.

1 Like

For node 81 I have 4 lines at the bottom of the page.

That means the device is not configured. What are the XML entries in the Userdata/zwave (var/lib/openhab/zwave) folder?

Thank you very much for helping me Bob. I am highly interested to solve this and to make my zwave work but for the next 7 days I will be off my computer. Please allow me to get back to you once will get back home.

1 Like