Z-Way Binding not working (Channels from Things cannot be used)


  • Raspberry Pi 3 Model B with Razberry Board
  • openHABian running openHAB 2.0.0~20170120171735-1 (Build #743)
  • Z-Way Binding installed and localhost Z-Way server found and added as a thing to openHAB.
  • Z-Way server status is “Online” and connected devices are shown in inbox as expected.
  • Things from the Z-Way binding can be added as things in openHAB.


  • When clicking on a Channel for a Thing (from Z-Way), nothing happens. The browser shows Javascript errors in the console (see screenshot).

(This does not occur for Channels for Things from my Hue Bridge, which work normally. - Also, all the devices work fine via Z-Way’s own web-interface)

Does anyone know how to solve this?

Same issue here. Some additional information:

  • OpenHAB Ubuntu Package 2.0.0-1
  • Raspberry Pi 3 B with Razberry Board
  • Z-Wave.Me Version v2.2.5

Same behavior as jakobjp mentioned above.
Any fix, hint or workaround is highly appreciated.

Hi @jakobjp, @johnnyger,

sorry for the late replay.

I’ve the same issue.

A workaround is to enable the Simple Mode of Item Linking (Configuration - System - …). Removing the Things and creating them again, then the Channels are linked correctly to generated Items. I hope this helps for the moment.

I’m working on a solution …


I can confirm that the workaround works. - Hope you can get the real issue solved nonetheless.

Also, thanks for your otherwise good work on the binding. I really appreciate it!

The problem is solved with current snapshot release!