Zigbee Aeotec Zi-Stick, Zigbee Binding, ZVG1 Watervalve

I use openhab with a pi for a will with zwave. I have a aoetec zi-Stick and a couple of sonoff Temperature sensors. Those work fine on the Zigbee Binding. Recently I bought a water valve to steer my garden watering. I bought a RTX ZVG1 / Royal Gardiner.

The Water Velve connect to the hub, but does not recongnize any channels. It should only do ON/OFF. Not sure way. Is there any manual way to add channels so that I can use the valve?



You might consider switching to Zigbee2MQTT/MQTT binding.

Quick compatibility check:

Tried this, but the Zigbee2MQTT fails to start with the RTX ZVG1. It is plugged in and discovered as /dev/ttyUSB0 but when I start the Zigbee2MQTT Service it throughs an error message:

error 2023-07-12 15:07:45: Failed to start zigbee
error 2023-07-12 15:07:45: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
error 2023-07-12 15:07:45: Exiting…
error 2023-07-12 15:07:45: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)

I disabled the Zigbee Binding in Openhab so the port should be unused. Not sure if I have to de-install the Zigbee Binding in order to make the Zigbee2MQTT work.

We are leaving openHAB terrain now …

  • Check Zigbee2MQTT log file (it might be necessary to increase the log level).
  • Check port in adapter settings.
  • Use adapter: ezsp in the adapter settings (Zi-Stick seems to be based on EFR32MG21A020).
  • Check/fix accessability of port, cf. Zigbee2MQTT fails to start | Zigbee2MQTT

Great thanks. The adapter: ezsp did it. With this parameter works the usb stick.

I managed to read values from RTX ZVG1 and from the Sonoff Thermostates I have. But I am unable to switch the valve on or off. I checked Zigbee2mqtt logs but no change I do seems to hit Zigbee2mqtt. At least nothing seen in the log. Any idea ?

1 Like

Enable the Zigbee2MQTT web UI and try from there.

If you can switch the valve via the Zigbee2MQTT web UI, chances are that your openHAB MQTT Thing/Channel configuration is wrong.

Yes Zigbee2mqtt webgui works. I tried multiple channel configurations, but non seems to work. The mqtt broker in Openhab reads values but seem not to send updates. As I would assume is the channel configuration is wrong it should still receive something on the zigbee2mqtt log, shouldn’t it?

Post your channel configuration (Thing → Code tab).

Remove leading and trailing spaces and quotation marks from commandTopic.

1 Like

Thanks. Did not see that. Now it works. Thanks a lot for your help.