Zigbee alternative to Xiaomi Aqara temperature/humidity sensor?


I would like to have several temperature/humidity sensors in my flat. I have bought a Xiaomi Aqara Sensor on ebay to play with it because they are very inexpensive. I would like however to connect them over a “standard” coordinator (I have the the USB Xbee stick) because I don’t like the the “proprietary” gateway philosophy (especially a chinese one).

I have been able to add the Aqara sensor as a thing to my openhab setup, with all 3 channels (temp, humidity ,and pressure) but I don’t get the values very reliably (I only get them for 2-3 minutes after I press the button on the sensor). I read that this is a known problem and this shows me that these Aqara sensors are not real Zigbee devices (or at least don’t really respect/implement the standard).

Does anyone have a recommendation for similar sensors ? I would love to find an alternative to them that is well supported.

You could always use Zigbee2MQTT which acts as a bridge. I get periodic updates from all sensors, buttons etc.

Yes I have read about Zigbee2MQTT. But I don’t favor this solution for the same reasons @chris mentions in this thread:

  • it relies on a specific coordinator device (that I don’t own and don’t intend to buy) with a custom firmware (I don’t want to have a flash a microcontroler on such a device)
  • the MQTT side does conceptually nothing special on the Zigbee side of things. I guess that the zibgee-sheperd/custom firmware combination does something that prevents the Aqara devices from going to sleep. But this could theoretically be implemented in openHAB as well.
1 Like

Oh well I did buy and to get it up and running was only 15 dollars which was well worth it. Are you in the US?

The ones with temperature, humidity and pressure sensor should work ok with the zigbee binding.

Try enabling insecure rejoins on the coordinator, as mine also got disconnected after some minutes without these.

It may also depend on the coordinator being used. Mine is a Telegesis


They are indeed working fine as I get the 3 channels discovered with the zigbee binding. The problem is just the disconnection/sleep/that happens after a few minutes as you mention.

I agree, it may depend on the coordinator. I’m going to have a look at this “insecure rejoin” feature for the coordinator and see if I can enable it.

(Answering to myself, even if this is not great).

Here (and the posts below) is a possible explanation to why the Aqara devices might go to sleep and how to work around it.

I now have to check if this is applicable to my Coordinator and if the zigbee bindings and drivers implement this with openHAB.

Here is the documentation about the Child poll timeout for XBee (my coordinator).

I have thus raised the SP and SN values to respectively 0xAF0 and 130 (as recommended in the above linked discussion) with the XCTU tool. Hopefully this will prevent the Aqara device from being seen as not having sent the poll request.

As a side note, here is a link to the User Guide for the XBEE2 (my coordinator)

EDIT: started working again with insecure join, will test further

THIS is crap, i have used too much time on this. Putting zigbee on the shelf and concentrating on zwave

Hello, I tried with insecure join, the Aqura switches works perfectly, but stops working after restart or/after some time (goes to sleep or something)

I have a telegesis coordinator

I can send one of the devices to a smartass in here if somebody wants to test :slight_smile:

the network will have join enabled for 60 seconds.

If its only 60 seconds the sensors will not be able to re join with unsecure joining

I’m not sure I understand your point, but rejoin, and join, are not the same thing… Join does not have to be “open” for devices to rejoin.

Well, the raised SP and SN values are not enough to prevent the Aqara sensor from “disappearing”. I still have push its button for it to send values again.

I don’t know what is missing in my setup to prevent this “loss” of the sensor. Obviously this happens for a lot of other Aqara users who only rely on standard zigbee. On the other end, some similar setups (Zigbee2MQTT most notably, but I think @chris reported once that it works in his setup as well) are able to prevent this “loss”.

Without any other change on my side, things are much better since I have upgraded from openHAB 2.4.0 M5 to 2.4.0 M7: the Aqara sensor has been sending updates for 2 days without interruption, approximately 2-3x per hour.

I will keep monitoring this, hopefully it goes on like that.

Is it still working?

Yes it’s still working. As long as I keep only one sensor. I have unfortunately not been able to have more than one Aqara sensor in my zigbee network.

I currently don’t have time anymore to work on that so I have given up adding more sensors. I may come back to it later (and will then update this thread).

It doesn’t work for me. I have updated all files to the newest, but after a few minutes/hours I don’t get any new data from the xiaomi devices.

I have the openhab testing version and the newest plugin versions. Also I have a telegesis zigbee stick.

Did anyone fixed this problem already?

So I just ordered the CC2531 Stick for Zigbee2MQTT :disappointed_relieved:

Hopefully someday the standard zigbee binding will support the non standard xiaomi/aqara devices without problems…

Are you happy with the range of the cd2531? My test with the CC2531 were a nightmare. Compared to my z-wave network the range is a desaster and zigbee2mqtt is very inconvenient to support. Plus the reliablity was not to my satisfaciton. My z-wave network just works - all zigbee stuff causes issues.

I just want to get rid of the Xiaomi China Hub which had excellent range by thew way (two levels in my house without any additional repeater or plug). The zigbee binding would be my favourite choice - when supporting the cheap Xiaomi and Osram devices.

Yeah, that is also my problem currently.
I will test to set the usb stick outside of my network cabinet.

In the zigbee network I only have batterie devices, which works as endpoints.
My zwave network is also working perfectly, but it has cable devices which repeats the signal.

Three weeks ago I tried the zigbee binding again, but it doesn’t support my xiaomi water leak sensors. So I go back to the zigbee2mqtt binding.

You can use a Xiaomi Mi Smart Plug ZigBee as a repeater, it works correctly for me.