Zigbee Binding: Aqara Button offline "No supported clusters found"

I was on 2.5 Milestone 1 or so. There Aqara Button was initialized, but no channels were recognized. So I did an Update. Now the Aqara Button even doesn’t go online. It always shows “No supported clusters found”

However connectivity is established. When pressing the button the message is received
2020-01-05 18:20:10.750 [DEBUG] [zigbee.dongle.ember.ZigBeeDongleEzsp] - RX EZSP: EzspIncomingMessageHandler [type=EMBER_INCOMING_UNICAST, apsFrame=EmberApsFrame [profileId=260, clusterId=18, sourceEndpoint=1, destinationEndpoint=1, options=[EMBER_APS_OPTION_ENABLE_ROUTE_DISCOVERY], groupId=0, sequence=F0], lastHopLqi=255, lastHopRssi=-32, sender=19087, bindingIndex=255, addressIndex=255, messageContents=18 06 0A 55 00 21 01 00]

2020-01-05 18:20:10.753 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=19087/1, destinationAddress=0/1, profile=0104, cluster=0012, addressMode=null, radius=0, apsSecurity=false, apsCounter=F0, payload=18 06 0A 55 00 21 01 00]

2020-01-05 18:20:10.755 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX ZCL: ZclHeader [frameType=ENTIRE_PROFILE_COMMAND, manufacturerSpecific=false, direction=SERVER_TO_CLIENT, disableDefaultResponse=true, manufacturerCode=0, sequenceNumber=6, commandId=10]

2020-01-05 18:20:10.757 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ReportAttributesCommand [Multistate Input (Basic): 19087/1 -> 0/1, cluster=0012, TID=06, reports=[Attribute Report: attributeDataType=UNSIGNED_16_BIT_INTEGER, attributeIdentifier=85, attributeValue=1]]

2020-01-05 18:20:10.759 [DEBUG] [transaction.ZigBeeTransactionManager] - notifyTransactionCommand: ReportAttributesCommand [Multistate Input (Basic): 19087/1 -> 0/1, cluster=0012, TID=06, reports=[Attribute Report: attributeDataType=UNSIGNED_16_BIT_INTEGER, attributeIdentifier=85, attributeValue=1]] 

Additional Info:
openhab> bundle:list | grep -i zigbee
259 │ Active │ 80 │ 1.2.3 │ com.zsmartsystems.zigbee
260 │ Active │ 80 │ 1.2.3 │ com.zsmartsystems.zigbee.dongle.cc2531
261 │ Active │ 80 │ 1.2.3 │ com.zsmartsystems.zigbee.dongle.ember
262 │ Active │ 80 │ 1.2.3 │ com.zsmartsystems.zigbee.dongle.telegesis
263 │ Active │ 80 │ 1.2.3 │ com.zsmartsystems.zigbee.dongle.xbee
264 │ Active │ 80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: ZigBee Binding
265 │ Active │ 80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: ZigBee CC2531 Bridge
266 │ Active │ 80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: ZigBee Ember Bridge
267 │ Active │ 80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: ZigBee Telegesis Bridge
268 │ Active │ 80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: ZigBee XBee Bridge


Try removing the zigbee binding and CC2531, stop OH, clean the cache and reboot. After OH has fully restarted and everthing is loaded then reinstall the binding and CC253 and restart OH again.

1 Like

I did. Now the switch isn’t found at all when trying to add. Any ideas?

1 Like

Give OH another restart or two. It took a reboot and 3 restarts for OH to get going without issues.

After another reboot device is detected again, but still offline. With another error “Node hat not completed discovery”. Any ideas?

Only one reboot needed and after that just restart OH.

sudo systemctl restart openhab2

Are there any rules that use the zigbee items?

No there are no rules using the zigbee items, because this button is the only item so far. Everything works fine with Openhab, except with Zigbee I’m spending hours and having trouble all the time.
Strange thing is now that it disovers the button as soon as I go to add the device even without pressing the connect button on the switch.

So it did find and connect to the switch?

No. Same error again. It seems to be stuck internal somewhere. Since I don’t press the button and the device is shown immediately it seems that the device is found internal somewhere but there is no real communication with that device.

1 Like

Just a couple of quick points on this - I have to go out shortly.

The Aqara devices will sleep very quickly after inclusion, and this will stop the binding detecting the information it needs. There are two important phases where it is important to keep the device awake - I hope to improve this shortly by combining them, but for now both are needed…

These are -:

  1. During initial inclusion - the device must be kept awake by pressing the button every second or so while the binding reads all the basic information - this may take 10 seconds or so.
  2. When the device is created as a thing - this is when you go to the inbox and click the create thing button. At this time, the binding does a bunch of configuration to detect the channels and configure the device - again, during this phase the device should be kept awake by (I hope!) pressing the button again for another 10 or 20 seconds.

Give this a try and see what happens.


No even not pressing any button for 2 hours on the Aqara button it is instantly found with a search request. I even stopped Openhab, cleaned the cache and restartet. I then uninstalled the binding and reinstalled the binding. Still the item is immediately found. So something is wrong. And perhaps if someone remembers I’ve never managed with the CC2531 USB stick flashed with the software described here https://www.openhab.org/addons/bindings/zigbee/#cc2531-coordinator to get ZigBee working. With the current stick the Aqara temperature sensor was detected. But connection was lost after a few days. And since then I’ve never tried again with ZigBee. Now trying to add the next ZigBee device still takes hours of time. This is very sad, because Openhab is such a great software. But why are the so many problems with it?

If you have the hardware for flashing a CC2531 then give zigbee2mqtt a try.

My preferred way to communicate zigbee devices with OH.

It’s the same issue as described here but nobody could help me so far.

After upgrading to 2.5 and adding the device I am getting the same error message like descibed here. Even pressing the buttons during discovery does not help. At the moment I guess the Aqara buttons are not working with the zigbee binding.

Hi, I am having some similar problems (using a Qivicon stick instead of a CC2531). The stick itself works, I successfully connected another Zigbee device, but I was getting the same error state as @time. Because the button continued being displayed without me pressing it, I removed the relevant node manually from the JSONDB storage (/var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Items.json). Does this help you?

1 Like

Just recently got one of these buttons and so far I haven’t been able to get it set up. Trying to get it working with a Nortek controller. So far none of the advice here has worked for me. Multiple OH restarts, multiple reboots (OH 3.1.0M4 on CentOS 8), tried adding while clicking the button multiple times and still can’t get it set up.

Every attempt so far results in the thing being created but no channels and a HANDLER_INITIALIZING_ERROR: “No supported clusters found.”

The same with
Aqara D1 (WXKG07LM)

There is two versions (or more) of this button.
One version is reported working. The one I got do not.
These two look the same. But they do have differing model numbers.
Personaly I do not bother with Aqara any more ( until products get certified).