Zigbee binding - Error using Bitron Video Stick (2.5.11)

Good Morning,

For a long time i have been controlling severall zigbee devices using their respective hubs. E.g. Tradfri , Xiaomi etc. Especially the tradfri hub is starting to haunt me so i decided i would go hubless and buy a zigbee stick to control the devices directly. After searching the forums and looking at available sticks i deciced the Bitron Video ember stick was the one for me.

After plugging in the stick and installing the Zigbee binding the coordinator was dicovered and added to the PaperUI inbox. However no matter what i do and try, the coordinator fails to go online.

Some info:
Platform information: Openhab 2.5.11
Hardware: Raspberry Pi 3B+
OS: Openhabian (latest)
Java Runtime Environment:
openjdk version “1.8.0_265”
OpenJDK Runtime Environment (Zulu (build 1.8.0_265-b11)
OpenJDK Client VM (Zulu (build 25.265-b11, mixed mode)

Connected via USB:

  • RFXCom
  • Zwave Eonlabs gen5 stick
  • Bitron video AV2010/10 stick

Bitron Firmware reported by paperui thing:

What have i tried:
Searched the forums for errors i see in the debug / trace log. However they seem to be unrelated to problems other people are reporting, or the fixxes suggested in those topics didn’t work for me.

I have tested both using the paperui discoverd thing, as using a things file. Both results are the same.
Checked if openhab belongs to dialout and ttty group (already did because of zwave)

Checked the EXTRA_OPTS in /etc/default/openhab2. All serials ports are listed.
Checked this on the console if it exists in env.

Tested using symlinks to the ttyUSB* devices and configured openhab to point to both the symlink as the /dev/ttyUSB* device. (And added the symlink to EXTRA_OPTS). results are the same.

When setting a non existing serial port the binding returns an error that its not able to open is, when using the actual port it states it is connected. However the rest of the logging seems identical to me.

I have attached a part of the (repeating) debug log
Hope someone can point me in the right direction.

zigbee_debuglog.txt (15.5 KB)

There are two possible configurations for Ember sticks -:

  • 115200baud, hardware flow control
  • 57600baud, software flow control

You are using the first - I forget off the top of my head what the Bitron uses, but it could well be the second one. Currently the port is opening, but there is no response from the controller, so this is a good place to look.

1 Like

I had exactly the same problem. My solution finally is NOT to use the device showing up in the inbox but adding the controller manually as Ember EM35x Coordinator. As settings I use:

Hope that it will help you too!


Thanks for the fast reply. Well i think thats what i did. By using a things file. Could you show me your mannually created thing?
Mine is currently:

Thing zigbee:coordinator_ember:bitron "Zigbee USB Stick" [zigbee_port="/dev/ttyUSB1", zigbee_baud=115200,etc etc]

I played with those settings with the paperUI thing. will set the hardware flow control in the things file and see what happends.

If you are using things files, then you can’t change them in PaperUI. It will not work.

Yes i know. Im sorry i didn’t mention: i have played with those settings during testing. I tried if using the paperui thing made a difference to my manually created thing in order to rule out any mistaked i mannualy made.
If i set my thing to 57600 baud and no hardware control stuff starts to happen.

NB. The binding page indicated 115200 / hardware as a setting for this particular device:

Here’s my current thing:

Thing zigbee:coordinator_ember:bitron "Zigbee USB Stick" [zigbee_port="/dev/ttyUSB1", zigbee_baud=57600, zigbee_flowcontrol=2, zigbee_concentrator=1, zigbee_panid=xxxxx, zigbee_extendedpanid="XXXXX", zigbee_networkkey="XXX"]

And the log:

zigbee_log2.txt (124.9 KB)

Cool - looks good.

I personally don’t test every device, so we rely on people to update the docs if you fancy providing a PR that would be great. One point to note though is that it comes down to the firmware - not the hardware. So if firmware changes, then this can also be wrong.

Stuff starts to happen but ends in a communication error :(. Any chance you could review my log?

I’m off out now - I will try and take a look tonight or tomorrow.

Cool. Thank you very much. Here’s what is ends with:

2020-12-20 12:03:41.557 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:bitron' changed from UNKNOWN to OFFLINE: Failed to startup ZigBee transport layer

2020-12-20 12:03:41.559 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:bitron' changed from OFFLINE: Failed to startup ZigBee transport layer to OFFLINE (COMMUNICATION_ERROR)

So i got the device online. Thank you both for helping me out. For the Bitron it def. is 57600 with Software control. The thing that finaly worked was :

Thing zigbee:coordinator_ember:bitron "Zigbee USB Stick" [zigbee_port="/dev/ttyUSB1", zigbee_baud=57600, zigbee_flowcontrol=2, zigbee_panid=xxxx, zigbee_extendedpanid="xxxxxxxxx", zigbee_networkkey="xxxxx"]

WIth this configuration it started communicating yet it always ended up with a comunication error. Every time i changed the config a new “Unknown” coordinator popped up at the inbox. Once i started deleting the discovered items in the inbox my manually created item went ONLINE. Happy!

Thanks a lot!

So you finally also created the coordinator thing manually in PaperUI? Or did you stay with the .things file?

Uhm no sorry, to clarify i manually created it via .things file. But 57600 baud rate and software flow control definitely did the trick. So manual creation with these settings is the way to get it working, be it via paperui or a .things file.

Thanks again for your response!

ok, great to hear that my settings also worked for you :wink: