Zigbee Binding the port has changed

I recently installed a new usb device on my raspberry pi and it seems to have changed the port bindings. My zigbee port changed from /dev/ttyUSB0 to /dev/ttyUSB1.

I tried updating the thing configuration but it keeps reporting
zigbee:coordinator_ember:48ed089711’ changed from UNKNOWN to OFFLINE: Failed to open communications port.

How do I fix this? Do I need to delete all my zigbee items/things and start over?

Thanks for any help

Using OpenHAB 3.0.

I name my device ports so if the real device port changes it will still work.

For example below is my rfxcom device and the file: /etc/udev/rules.d/99-usb-rfxcom.rules has this in it:

SUBSYSTEM=="tty",  SUBSYSTEMS=="usb", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", SYMLINK+="rfxcom"

You get the numbers to use by running command lsusb in this examplebelow it would be: 0403:6001

Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC
Bus 002 Device 003: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 002 Device 002: ID 1941:8021 Dream Link WH1080 Weather Station / USB Missile Launcher
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0627:0001 Adomax Technology Co., Ltd QEMU USB Tablet
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

After you add the file restart the udev process.
sudo systemctl restart udev.service

You will tell if it has worked by running:
ls -l /dev/rfxcom
lrwxrwxrwx 1 root root 7 Jul 8 11:03 /dev/rfxcom → ttyUSB1

It shows that /dev/rfxcom is really /dev/ttyUSB1

You would then put /dev/rfxcom into your thing serial port instead of the real port name.

1 Like