Zigbee Binding with Nortek HUSBZB-1 not detecting Xiaomi Temperature sensor correctly

I tried adding a Xiaomi (Aqara) Temperature & Humidity Sensor. So what I did:

  1. Install ZigBee Binding

  2. Setup The Nortek HUSBZB-1 as described here

  3. Add Zigbee Coordinator by Adding Thing manually -> ZigBee Binding -> add manually -> Ember EM35x Coordinator

    1. Port: /dev/ttyUSB1
    2. Flow control: Hardware (CTS/RTS)
    3. Baud Rate: 57600
  4. In Inbox click on Discovery icon and select ZigBee Binding. Right after starting discovery for ZigBee Binding, i long press on the button until it starts blinking.

Now it seems that sometimes I have to do step 4. multiple times until it actually gets discovered. And when it gets discovered, it gets discovered as LUMI lumi.sens. When I add that one, it has no items on it. No Temperature, nothing. As well the modelId is lumi.sens. It seems like this is wrong. It should be lumi.sensor_ht according to the corresponding thing file here.

Now why does this happen? The logs seem to have lumi.sensor_ht as attributeId first. But then afterwards it becomes lumi.sens. See logs below.

Does anyone have an idea why this could be happening or how this can be fixed?

Thank you for any help.

Whole openhab.log (pastebin)

Some lines with lumi.sens(or_ht)

2019-02-05 10:08:45.689 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ReportAttributesCommand [Basic: 44204/1 -> 0/1, cluster=0000, TID=00, reports=[Attribute Report: attributeDataType=CHARACTER_STRING, attributeIdentifier=5, attributeValue=lumi.sensor_ht, Attribute Report: attributeDataType=UNSIGNED_8_BIT_INTEGER, attributeIdentifier=1, attributeValue=2]]
2019-02-05 10:08:46.188 [DEBUG] [zigbee.dongle.ember.ZigBeeDongleEzsp] - RX: EzspIncomingMessageHandler [type=EMBER_INCOMING_UNICAST, apsFrame=EmberApsFrame [profileId=260, clusterId=0, sourceEndpoint=1, destinationEndpoint=1, options=[EMBER_APS_OPTION_ENABLE_ROUTE_DISCOVERY], groupId=0, sequence=104], lastHopLqi=255, lastHopRssi=-61, sender=44204, bindingIndex=255, addressIndex=255, messageContents=18 01 0A 01 FF 42 1F 01 21 EF 0B 04 21 A8 01 05 21 3F 00 06 24 01 00 00 00 00 64 29 A5 09 65 21 36 1C 0A 21 00 00]
2019-02-05 10:08:46.192 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX APS: ZigBeeApsFrame [sourceAddress=44204/1, destinationAddress=0/1, profile=0104, cluster=0, addressMode=null, radius=0, apsSecurity=false, apsCounter=104, payload=18 01 0A 01 FF 42 1F 01 21 EF 0B 04 21 A8 01 05 21 3F 00 06 24 01 00 00 00 00 64 29 A5 09 65 21 36 1C 0A 21 00 00]
2019-02-05 10:08:46.194 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX ZCL: ZclHeader [frameType=ENTIRE_PROFILE_COMMAND, manufacturerSpecific=false, direction=SERVER_TO_CLIENT, disableDefaultResponse=true, manufacturerCode=0, sequenceNumber=1, commandId=10]
2019-02-05 10:08:46.197 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ReportAttributesCommand [Basic: 44204/1 -> 0/1, cluster=0000, TID=01, reports=[Attribute Report: attributeDataType=CHARACTER_STRING, attributeIdentifier=65281, attributeValue=!�
                      !�!?]]
2019-02-05 10:08:46.531 [DEBUG] [iscovery.ZigBeeNodeServiceDiscoverer] - 000D6F000B29A880: Node SVC Discovery: running

2019-02-05 10:09:21.248 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ReadAttributesResponse [Basic: 44204/1 -> 0/1, cluster=0000, TID=20, records=[ReadAttributeStatusRecord [attributeDataType=CHARACTER_STRING, attributeIdentifier=5, status=SUCCESS, attributeValue=lumi.sens]]]

2019-02-05 10:09:37.869 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 00158D0002D478AA: ZigBee node property discovery complete: {zigbee_logicaltype=END_DEVICE, zigbee_powerlevel=FULL, modelId=lumi.sens, vendor=LUMI, zigbee_networkaddress=44204, zigbee_powermode=RECEIVER_ON_IDLE, zigbee_powersources=[DISPOSABLE_BATTERY], zigbee_powersource=DISPOSABLE_BATTERY, hardwareVersion=30, zigbee_stkversion=2, zigbee_datecode=20160516, zigbee_zclversion=1}
2019-02-05 10:09:37.881 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 00158D0002D478AA: Update ZigBee device zigbee:device with bridge zigbee:coordinator_ember:518f3dec, label 'LUMI lumi.sens'

I am not sure, but this line seems very strange to me:

2019-02-05 10:08:46.197 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: ReportAttributesCommand [Basic: 44204/1 -> 0/1, cluster=0000, TID=01, reports=[Attribute Report: attributeDataType=CHARACTER_STRING, attributeIdentifier=65281, attributeValue=!�
                      !�!?]]

OH Version: openHAB 2.4.0 Release Build (running on openhabian)
ZigBee Binding version: 2.4.0 (binding-zigbee installed through add-ons in paper ui)

operates at a baud rate of 57600, and XON/XOFF flow control

You set an incorrect flow control setting, but I’m not sure how much that will affect the issue you’ve reported.

What version of OH and/or binding are you using?

Thank you. XON/XOFF change seems to help a bit (before i sometimes even had trouble with discovery not really detecting devices that wanted to pair).

But the sensor still gets detected wrongly as lumi.sens instead of lumi.sensor_ht. :frowning:

This will be helpful info to have for troubleshooting…

1 Like

Sorry, totally forgot.

OH Version: openHAB 2.4.0 Release Build (running on openhabian)
ZigBee Binding version: 2.4.0 (binding-zigbee installed through add-ons in paper ui)

I am not using the Mi Home binding because I want to get rid of the xiaomi bridge. I want to have more control.

I am having the same issues. I also have a HUSBZB-1, but I have a Xiaomi mijia temp sensor. I was able to make this pair the very first time I tried, but it was only reading Humidity. So I deleted the thing from paper UI and now it only ever shows up as “LUMI lumi.sens”

Jacop
this is a super old thread… try starting a new thread and explain your issue there!

I am not sure exactly what fixed this. Firstly, when any Zigbee device is detected for me it shows up as an “Unknown device” If I wait long enough it will change into what it actually is.

This time I held the button on the sensor down until the discovery light flashed. Started discovery in OpenHab for Zigbee devices. It found the “Unknown device” and then while I was waiting for it to change into it’s proper device I randomly started pressing the button on the sensor (Not holding it).

I honestly think it was just random that this worked. Not very scientific.

This is normal - it takes time to work out what the device is, so in the meantime you get an unknown device until enough information is available. If I waited until all the information is available, it would IMHO confuse users as they would see nothing at all.

This should only take a second or two for mains devices, but could take some time for battery devices especially.

This is the correct way to include Xiaomi devices - it prevents them from going to sleep, and if you don’t do this, they almost certainly won’t work properly. Otherwise they sleep almost immediately after being included and the binding cannot read the device information so doesn’t know what the device is, or what channels are available.

1 Like

Hello Jabob,

did you get this matter solved? I just bought Xiaomi Mija sensor but I can’t get it working.

No. I am fairly certain the only way to make this work is to go through a Xiaomi hub. I don’t think you can use their devices directly. I was able to get the device paired and communicate for a short period of time, but then it would go to sleep and never wake up again. I think there is a proprietary “wake up” signal that xiaomi uses. Ikea zigbee devices have a very similar problem for me. I gave up on all zigbee devices and have been focused on MQTT devices instead with no issues.

Not true. I have Xiaomi devices running with the ConBee II stick and use OpenHab Deconz binding without issues.

Have you find any Temp and Door sensor WIFI + MQTT?

Have you see or test card CC2531?

No. Deconz/Conbee has a pretty active community and many devices are supported quickly.

Sounds great, thanks! unfortunatelly I can’t buy this in Brazil, I’m think to buy xiaomi hub instead.