Zigbee binding

The first thing I would suggest is to wait a few days and then update. The build has been broken for the past few months - a PR was merged this morning that will (I hope!) fix this and I’ll do some updates to the binding over the next few days to bring everything up to date.

If that doesn’t fix it, then we’ll need a bit more information from the log. I guess you only have error/warning logging enabled - it would be good to see the full debug log.

There is an issue with the Ember that I’ve not managed to find (and neither could Silabs at the time I was hunting for it) - I don’t know if this is what you have hit, but let’s see what the above brings first.

@stopherd @5iver @chris


It looks like something is working. Just want to make sure what it is…

Am I correct to say
1 the Linear HUSBZB-1 is compatible with openhab zigbee binding.
2 Only configuration on openhab side is required.
3 Dongle firmware is already programmed so that we do NOT need to do manual firmware programming as for TI 2531.

Thank you very much.

Worked for me straight out of the box from Amazon.

  1. Yes, for the snapshot version of the binding which has a baud rate setting
  2. Yes, but there may be some permissions to play with in the OS too
  3. Yes, although the firmware could be updated

If you search the forum for HUSBZB-1, you’ll find a few topics about it.

1 Like

Sounds good. I do have debugging enabled for zigbee to a separate log, and there is a bunch of stuff happening before the point I posted. Initializing, setting keys, etc. I’ll update when I’ve gotten a change to try the updated build. Thanks!

This is a post from someone who was having a similar issue. Restarting the computer seemed to correct it, but the issue would occasionally come back after subsequent restarts.

Currently, I wouldn’t recommend the HUSBZB-1 - I’d recommend the Telegesis stick instead (inside it’s the same ZigBee chip but different firmware). As I mentioned somewhere here, there is a bug that appears on some devices which we’ve not found yet. It might work fine, or it might not work at all (let’s say 90% chance it will work - but if it doesn’t, then please don’t say you weren’t warned :wink: ).


Thank you for your response.
Below is some confusion.


are you talking about this one?


I am NOT quite sure what do you mean by some devices.
So is the bug only on HUSBZB-1? Or both HUSBZB-1 & Telegesis sticks may have that bug?

Thank you.

@5iver @stopherd
Thank you very much for your confirmation, guys.


The issue is with the Ember NCP code - HUSBZB uses this - ETRX3 does not which is why I would currently recommend this stick.

Got it. thank you.:grinning:

Not sure how can we order one, if NOT directly from www.silabs.com?
Thank you.

At least in The UK, they are easily available at places like Farnell, and eBay

Farnell/Element14 seems to cover most countries I tried - Spain, Germany, Hong Kong, Singapore… It’s not too hard I think :wink: .

The HUSBZB-1 is a combo zwave and zigbee controller. The ETRX3 does not have zwave and looks to cost about 2x as much. Chris also gave me a warning about the quickstick, but it’s been working well for me so far!

Sure - I know this doesn’t have the ZWave function, but I figured in this thread we were talking about ZigBee. I just want people to be aware of the limitations as it might not be a quick fix if someone comes across the issue (as we have already seen here!).


Your work on this project is so greatly appreciated.

I was able to get the HUSBZB-1 to work, openhab is getting the on/of events, but when i try to toggle the switch from openhab it does not work, and getting the following in the log.

[WARN ] [ing.zigbee.handler.ZigBeeThingHandler] - No handler found for zigbee:device:09a6fe9e:00124b000880c3d4:00124B000880C3D4_1_switch_onoff

Would you say it’s related to the bug or it will be fixed in your next update?

No - I don’t think it’s related to the bug. Probably it’s something else as this likely indicates that the dongle is working and the network is initialised.

What device is this and does Habmin show it as offline? After a restart, my Centralite outlet comes right up… every time. But my GE Link bulbs need encouragement! Some will come up online and some will be offline. Power cycling one of the bulbs (not necessarily one of the offline ones) and waiting a minute will get most of them back online. I just repeat until they are all online. If OH has been down for a long time, they all need a power cycle, after which they will flash. When there is a really stubborn one, I power the bulb off, start discovery, and then power it back on and the bulb will flash. If it is still offline, a power cycle will bring it back online. For really really stubborn ones, I reset the bulb and then do a discovery.

When my bulbs are marked offline, I see the error that you are getting and they cannot be controlled until back online.

Its a ORVIBO in-wall switch it shows online, and as said OH is being updated every time the switch is pressed, its simply missing the abllity to toggle the switch from OH.

Can I confirm what this means? When you click the physical switch on the device, OH updates, but if you click the switch in the OH UI, nothing happens?

If so, can you provide a debug log - for starters let’s look at exactly what happens when you click the switch - later we might want to look at the initialisation… So, if you can provide a few seconds of logging either side of you pressing the button on the UI that would be a good start…