Zigbee binding

Hi Chris,

thanks for your feedback.

Means a parallel sniffer outside of the coordinator? (A second device)?
Never heard that term before.

BR
/Franz

No - the PTI trace comes from the coordinator - it’s basically a debug output from the NCP and if there’s an assert (which happens when the NCP gets into a state from which it can’t recover) then it will print a bunch of stuff out this port so that Silabs can work out what happened.

PTI:

Thanks Chris and Ap15e.

for the update. It seems only to happen if I reinitialize the controller and do not restart openhab.
So it also looks like it creates an Error code 3 before.

openhab.log.6:2022-01-23 15:20:35.624 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 3). Disconnecting.
openhab.log.6:2022-01-23 15:32:36.303 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.

I assume this is the right table, is it?

The PTI Interface looks highly sophisticated and complex.
I guess I cannot do this with my standard zigbee stick.

BR
/Franz

Yes, but to be honest, it doesn’t provide you much information. This is already provided in the debug log - ie the binding, or more specifically the zigbee library, already uses this table to log the error.

DEBUG c.z.z.d.e.i.ash.AshFrameHandler - <-- RX ASH frame: AshFrameError [version=2, errorCode=6, Reset: Assert]

@chris Not sure if here is the place, but any chance this could get supported? Zemismart TB26-6 control via MQTT | Zigbee2MQTT

Thanks

Can you describe what doesn’t work please? That would make it easier to fix :wink:

That was fast. I tried this 6 gang Zemismart with the Zigbee bidding, but I got the " HANDLER_INITIALIZING_ERROR
No supported clusters found" on the thing. I can see lots of information, but no channels in paper UI. I just figured it was not supported yet.

From what I can see in the link you provided, this is just provided standard ON/OFF services, so it should work fine. That said, it doesn’t explicitly state this although it does talk about ON/OFF and TOGGLE which are features of the OnOffCluster and should be supported.

However maybe it is really something custom and not the standard clusters - I’m not really sure. Does it produce an XML file (in the userdata/zigbee/network folder) for the node? If so, please post this - or use the console command zigbee fingerprint for the node and post the results.

Yes it should be just 6 on/off devices. Here my xml for the “thing” and the coordinator. Thanks
040D84FFFE512216.xml (1.7 KB)
A4C13885BAB8F317.xml (45.9 KB)

this is the product link: Zemismart tuya 6 gangues zigbee interruptor de luz de parede inteligente 4x4 neutro necessário interruptores botão alexa google casa controle remoto| | - AliExpress

Unfortunately, it looks like the device is totally non-standard - at least the standard clusters such as OnOff and LevelControl that are normally associated with a light switch are not supported. Maybe there’s more information on the device out there somewhere that can help understand what it does. It’s likely this will require a code change to support, although there are already some of these chinese devices supported, so it may be similar - I’m just not sure without having a device myself.

1 Like

Well Thanks, I have very little options, on the kind of device that complies with my country standards, as size and functionality, not really security. I saw that the switchs are compatible with zigbee2mqtt, but I would rather use a bidding. Is there any information I could take out of zigbee2mqtt that would help reverse engineering this non-standard cluster?

If you can get a debug log showing what is received when each button is pressed, I might be able to do something with that…

Hi all,

last time I’ve tried to upgraded my ZigBee stick to Version 7.1.1 and figured out that this was a bad idea because it is not yet supported by openhub and cannot be downgraded.
Okay my fault then i thought I buy a new ZigBee adapter like the Sonoff ZB-E Plus (Shipped with 6.10.3 as the stick had before)

Plugged it, adjusted the port started up all fine.
Restored in the OH console with:

zigbee netbackup COORDINATOR>D896>D1EDA82EE040FFFF>CHANNEL_17>332178E8CFF39159DDEF1A49A29F9FFF>00>>00118612>5A6967426565416C6C69616E6365FFFF>>>0001901F

and waited a while to let the “node has not completed discovery” go by.

All fine so far but now i figgured out the following issues:

  1. I have roughly 40 items in my “inbox” all unknow but they already added as items
    node has not completed discovery openhab

  2. I get an assert Code 6 now 1-4 time per hour. Tried to disable things I already disabled zigbee “things” in but I still got it quite often → I tink disabling has nothing to do with the assert, right?

	Line 10202: 2022-10-13 06:54:15.444 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 3). Disconnecting.
	Line 33974: 2022-10-13 07:02:47.091 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
  C:\Users\f\Desktop\ohlogs\openhab.log.1\openhab.log.1 (1 hit)
	Line 29845: 2022-10-13 02:58:55.718 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
  C:\Users\f\Desktop\ohlogs\openhab.log.2\openhab.log.2 (1 hit)
	Line 37631: 2022-10-13 04:04:23.919 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
  C:\Users\f\Desktop\ohlogs\openhab.log.3\openhab.log.3 (2 hits)
	Line 41272: 2022-10-13 05:01:31.531 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
	Line 43494: 2022-10-13 05:01:59.214 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
  C:\Users\f\Desktop\ohlogs\openhab.log.4\openhab.log.4 (6 hits)
	Line 34999: 2022-10-13 05:41:05.348 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
	Line 37893: 2022-10-13 05:41:53.328 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
	Line 43157: 2022-10-13 05:42:17.002 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
	Line 48701: 2022-10-13 05:42:44.509 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
	Line 59283: 2022-10-13 05:45:19.925 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.
	Line 79150: 2022-10-13 05:50:50.439 [WARN ] [e.ember.internal.ash.AshFrameHandler] - ASH: ERROR received (code 6). Disconnecting.

And the items get then towards “Error: Handler”

It’s worth knowing that this string contains all the information for someone to clone your network - including the security keys. Depending on how worried you are about that, you might want to reinitialise with new keys anyway.

Correct - it’s unlikely to make any different.

Assert 6 “simply” means that the firmware in the dongle is getting into an unrecoverable state. Unfortunately it doesn’t provide any useful information about why this is happening.

Hi @chris,

serveral month later :slight_smile: from my side.

=> Al fine here For sure i did not post the original values and obfuscated tzhen.

So I was able to recover the original Stick flashed back the old Firmware and now it looks better at least.
One thing that I’ve noticed since then is that I have all already added items also in The Discovered things section. Is there a way to reset this?

Thanks
/Franz