Zigbee Channel?

Hi
sorry I just started to play with the zigbee binding.
I have some OSRAM devices. A mains powered plug and 2 RGBW garden pole sets.
My controller is a DIGI Xstick 2 ZB.

I intented to use the Plug as a repeater to have a route to the garden.

However I see a massive latency… and try to gain some knowledge here.

–> Should I set the Baud rate to highest possible for the xbee?
–> I can not change the channel. When setting it over paper ui it always jumps back to 20 (which was automatically set when the thing was created via UI)
–> So … any hints how a channel can be changed?
–> and are there channels that don’t interfere with a 2,4ghz wifi?

-> what is the flowcontrol setting for? and is hardware or software setting better?

thanks :slight_smile:

It probably won’t matter as this won’t impact the speed over the air.

This I’m not sure about - you might need to use the digi software (it’s been a long time since I wrote the S2 driver).

In general - no. In practice - yes…

By this, I mean that the 2.4 GHz spectrum is used by WiFi, BLE, DECT, 802.15.4 etc, etc. Each protocol allocates the complete spectrum, and the question is what channels you and your neighbours are using. Normally it’s possible to find a clear channel, but I can’t tell you which one it will be in your house.

I know that a large hotel chain use ZigBee in some hotels and it works well. They have a separate network for each room and also have WiFi throughout the hotel and it all co-exists well.

this article explains the channels well: https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html

However I can not change the zigbee channel, it goes back to channel 11.
I really want to use channel 25 as that is more out of the way from my WiFi.

This is on openhab 2.5.4-1 with a Bitronvideo stick
On the previous version (2.5.3-1 i think) there was a exception thrown.
I did not make any notes of that one…

I meant to post this earlier - this is a chart I use when I’m doing ZigBee training that shows the frequencies-:

1 Like

I think I didn’t provide this function in the binding since it can cause all sort of problems as there’s no guarantee that all devices will change channels. If devices miss the channel change notification, then you can loose devices - depending on how well they implement the search to try and find the network again.

I understand the implications with a channel change.
In my case I just started some testing with zigbee and want get it right from the start.

So it is the channel should be set one time and FIRSt when the usb stick is created as thing? and then include all the devices with the intented channel?

if so … Is there a way to describe the channel in the things file?
its not in the example.

when created via the UI it actually offers baud rate, channel change etc. … all of it does not really work … so might confuse users :wink:
thanks

The configuration name is zigbee_channel. I just checked though and for the S2 it is not implemented so you’d need to use the digi commander as I mentioned earlier.

Well, if you find problems, then it is useful to report them :wink: Otherwise we don’t know. I will remove the channel setting from the S2 as I’ve just confirmed this isn’t implemented.

I should add that baud rate does work - but you need to understand that it is to configure the baud rate of the link to the S2 in the binding - it can’t change the baud rate of the S2 itself since since that would require a before and after setting :wink:

well thanks for pointing me a step further

I now used the Digi Software XCTU and flashed to a newer version
Now I could configure the device a little further
but more newbie questions come up :smiley:

–> it allows me to disable security. Can I use it without in the binding? and is it advisable?

–> must the config for Baud Rate and e.g. CTS flow control match my thing definiton in openhab?

–> I cant edit the channel (after flashing the firmware its 14). anyone who knows this tool better if I can change it somewhere?

best

ZigBee won’t work without security so I’d recommend not to do this. ZigBee uses multiple layers of security, but pretty much everything requires at least transport layer security.

Yes - this allows you to configure the S2 to some definition. You then need to make the binding exactly the same configuration so that the binding can communicate with the stick.

Sorry - I’m not sure about that.

I see you hid your PANID - I wouldn’t bother as it is 100% in the open anyway if someone wanted to sniff your network. ZigBee is a secure system - it doesn’t rely on obscuring information such as the network ID etc. The network ID is sent in broadcasts and could be easily picked up by anyone in range.

thanks wasnt sure … when I see an uneditable ID i tend to hide it :D:D:D

I read more docu from DIGI now and it says their ZB series of zigbee coordinators scans the channels and selects automatically one which is not so crowded …
you said before to change a channel is not a good idea so I hope the firmware got a good glass bowl to know which channel stays less crowded in the future :wink:

I don’t think the firmware will change the channel - Embers don’t typically do this and I’d be a little surprised if Digi decided to change the Ember default too much - I think they’ve basically just added a different API.

Maybe one day I’ll look at adding this - it’s just for now something more to cause problems so best left out :wink:

yes I meant to say it does a scan and self detects a good channel

Currently the binding does this when creating a new network, but it will still use the channel that you request rather than the quietest channel - it’s something I need to change when I get a chance…

a autoscan can be a good thing as a default on a new network.
Unless I told it to use channel x. I then expect it to stay there :slight_smile:
The binding can not see the rf situation at the not yet installed future third zigbee-hop.

In my case I planned to use zigbee channel 25 before I ordered the USB stick. Plan B was to shift up all my WiFi APs a notch and use channel 11.

Do a tool for the Bitronvideo stick exist?

The binding does already perform a scan on a new network. Currently it just prints the results in the log - it doesn’t use the channel.

Sure - but it does get this information later once the network is established. I’ve posted elsewhere, but one of my customers is a large hotel chain that has a ZigBee network in each room. We tested this in a hotel with hundreds of room, and WiFi - all co-existing together just fine. The binding was configured to use the scan information, but still with such a large system it works well.

No - the binding controls this.

ok, I tried to add “zigbee_channel=25” to my .things file, but paperui still reports channel 11.
In this process I watched the logs. I could not see anything that looked like a channel change, or a channel scan.
Do I have to set some debug logging to see this?

Are you initialising the network? Please debug provide the log so I can see what you are doing.

If you don’t have debug logging set, then the logging will be minimal and you won’t really see much, so yes, if you’re debugging, please use DEBUG log level :wink:

Do I have other options than restarting the binding?
The Thing for the USB stick is probably marked as not editable in the rest api so paperui give a error when trying the “reset”…
Or are there other ways?