Zigbee Devices Keep Randomly Going Offline

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Plus Rev 1.3
    • OS: Raspbian GNU/Linux 11 (bullseye) / Linux 5.10.92-v7+
    • Java Runtime Environment: openjdk 11.0.14 2022-01-18 / OpenJDK Runtime Environment (build 11.0.14+9-post-Raspbian-1deb11u1)
    • openHAB version: openHAB 3.2.0 - Release Build

I have been using OpenHAB for a few years now without any major issues. I was on 2.5 but recently updated to 3.02 but the upgrade didn’t go well and I had to start fresh.

In the end, I set up everything again from scratch and it was all straightforward. However, I am running into an issue where my Zigbee devices randomly go offline and stay offline unless I disable/enable them again.

As a result, I cant seem to interact with them in this offline state.

Does anyone have any idea what the issue could be?

Just wanted to add that I have this problem all the time too. The devices seem to work fine for me, just seems like they’re going to sleep. I’m afraid I don’t have an answer for you but wanted to let you know you’re not alone.

1 Like

@PaxtonFettyl I appreciate you sharing your experience, mine just don’t seem to work unless they are online, wish they would work still even in an offline state.

I upped the logging for Zigbee and this is what I am seeing in the logs, not sure if anyone looking at this can make sense of it.

You need to get debug logging to work out what is happening. The small log you show as an image above really doesn’t help - this is the endgame you’re seeing here. It shows that the device is not reporting, and the binding doesn’t get a response to the poll, so after all of this, the binding will mark the device offline.

All I can say here is that the device is not responding, or not reporting. If the device is a battery device, then maybe it won’t respond to polling. It still should send reports, but really this is down to how the device got configured when it was joined to the network - if it’s not reporting, then it will be marked offline.

@chris This is a bulb that should have power at all times, so no battery issues here. I can give a larger set of logs but I didn’t want to dump a ton of info in here where most may be just “noise” and what you are looking for is the end state and a few lines before it.

Is there anything specific you recommend that I capture that would be helpful?

If this is a mains device, and it doesn’t respond to polling, then I guess there’s a chance that this is a network issue - ie the device is not available.

Does the device send reports? These should be received every hour or so (I forget the exact max report time). These should be seen periodically and if they are being received, and they stop, then again it indicates there’s a problem with the device, or the network, and the binding is probably correct in marking it offline.

Another question is what the network looks like - how many devices, and what are they, and how are they distributed. I would also suggest to look at the LQI values which should be seen in the neighbour tables of the device properties.

Another question is what you coordinator you have, and what firmware version - all this can impact your issue, depending on the devices you have, and the size of the network.

So… I think in the first instance a long log (a couple of hours) showing the device working, and then it failing would be good.

Sorry for not responding sooner, things were in a stable state for a couple of weeks, and are now back to being problematic.

I have captured this screenshot with some logs. You can see it stops polling and then they go offline.

It’s hard to comment too much without log files, but it seems that the device is no longer responding, so the binding marks the device as OFFLINE - this is exactly what it should do :slight_smile:. If it was working for quite a while without problems, then probably there is a communication issue in the network.

Where can I get more logs tho? This is all I have.

I had this issue before on 2.5 and updated to 3.0 to hopefully resolve the issue.
My ZWave devices stay connected just fine but randomly my ZigBee bulbs just go offline from the Embar stick and I need to Disable/Enable them a few times to make them work.

After that they can work for months with no issue and then other times will happen a bunch of times in a single day. Its very confusing.

Please refer to the binding docs - this describes how to enable logging.

Surely not? You must have filtered this log - earlier you said it was working ok, so why only these few lines of logging. I’m sure that you must have selectively filtered this based on some criterea?

ZWave and Zigbee are completely different and totally unrelated. They even use different frequency bands so will not interfere with eachother - this is not related.

This is likely caused by a networking issue - maybe interference, maybe some other external issue in your house or something. I don’t think it’s likely to be a binding issue at least - maybe the Ember stick has a problem in the network, but I very much doubt that.

I appreciate it’s hard to understand what’s happening - the other thing you could do is to use a second Ember stick as a sniffer.

Currently, I am not filtering on anything, not that I am aware of.
| tail -f /var/log/openhab/openhab.log /var/log/openhab/events.log

Are there additional things I can enable to give me better logging?

I have moved this device to different networks over the past year to help eliminate any issues but the same outcomes and super random.
Are there common things that can impact these devices I should be looking at?

At this point I am considering usin ZWave for everything to mitigate these issues.

Ok, then I’m not sure what to say. If you really only have a dozen or so lines in your log, then that’s strange.

Well, I’ve pointed you to the documentation that describes this, but I’m not sure what you have actually done, so it’s hard for me to say if there are additional things. I’m just surprised that if you’ve followed the dos, that you have so little data - I would have really expected to see a lot more zigbee data - hence why I assumed it was filtered. My guess is you haven’t configured logging as per what’s in the binding docs?

It’s hard to say what is happening with so little information. Sorry, but it’s hard to help here.

ZWave can have the same sort of issues - it comes down to your network topology, and network routing etc.

As suggested above, you could get a sniffer to see what is happening in the network.