Zigbee devices

Recently experimenting with different configurations and decided to run zigbee binding, Unfortunately I don’t know how to add zigbee devices
I started zigbee binding, it’s online but I don’t know how to get it to search for devices.
I have OH3.1 and cc2531

It is the same as all other bindings - you go to the UI and add a new device. It allows you to scan for new devices. When you select this, it will scan for 30 or 60 seconds (I forget the exact time).

I have sonoff devices and I know that they worked with zigbee2mqtt but I do not see them in the binding description, so they may have a problem with connecting?

Have you tried them? I don’t think there should be a problem - I don’t know what devices you have, but I know that people are using sonoff devices with openhab.

You will have issues, you need to get an ember chipset and then the sonoff stuff will get found. I tried two different models and had no joy until I went with ember.

Ember works with zigbee binding
Ember does not work with zigbee to mqtt.
Cc2531 can not handle many devices so it is not worth keeping as you need to build a mesh.

Work out which way you want to go and then buy what works and get rid of cc2531.

1 Like

More on the CC2531: by default one stick can only hold a few devices due to limited onboard memory. However, with the router approach, you will be able to increase the # of devices with CC2531. You kind of need multiple CC2531s anyway as the range isn’t that good. I have 3 of them distributed around the house. CC2531 should only be considered if you have devices that are not quite Zigbee standard compliant but able to work with Zigbee-2-mqtt.

1 Like

Thanks for any suggestions,
In this situation, I return to zigbee2tasmota, although it does not meet all my expectations,

Just to be clear, the limitations that people are talking about above are limitations of the dongle - not the binding. So these issues will also be apparent in other bindings. It all depends on your devices, and network size if it will work.

1 Like

I understand what has been written but for zigbee2mqtt there are no these problems,
On the same key, Sonoff devices work without problems, or at least report without problems, even data search as in HomeAssistant,
I wanted to avoid additional programs because I believe that the more intermediaries, the more opportunities for incorrect work,
In the case of binding OH zigbee, I could not find anything on the network at all, despite the correct connections.

Since it seems you joined the device to another network (ie zigbee2mqtt) did you force the device to leave the previous network and then rejoin with the zigbee binding? If not, it’s likely the devices would not be detected.

It’s really hard to comment on what’s happening without really being there. People are using Sonoff devices with the binding, so it’s not a binding issue as such.

Yes, I disconnected them from the previous network, Unfortunately, I do not fully understand how to start searching for new devices in the zigbee binding and I am not entirely sure if I did this part correctly.
The process of joining the network itself is not logically described (for me), maybe I made a mistake here. I also do not know how to check if the binding has passed into the troupe of adding devices

Hi Grzgorz,

I had the same problem. OH3, C2531 (Koenkk firmware) and Aqara sensors. I found out that I have to set up zigbee2mqtt properly. If in the configuration.yaml the parameter permit_join is set to true the zigbee device will automatically bind to the C2531. The file configuration.yaml will add a device with an address and a friendly_name.

In OH3 you need to install the MQTT Binding. Furthermore you nee to have a MQTT Server (usually Mosquitto).

I did not find a way that OH3 could detect the sensor which already sends data to the MQTT server (I checked looking at the log files). So I created a thing (Generic MQTT Thing) with the MQTT Binding. Then I created a channel. Under MQTT State Topic I did fill in

zigbee2mqtt/[ID from configuration.yaml]

This in short worked for me. But it is the opposite of plug and play and there might be smarter ways to bind them.

Please see the docs -:

I’m happy to take suggestions to improve this if you have ideas.

Sorry - I don’t understand what you mean by “passed into the troupe of adding devices”.

The binding is put into discovery mode in exactly the same way as every other binding - using the standard device search/scan buttons in openHAB UI.

I understand that by pressing the “scan” button, I start searching for devices, but for me it is nowhere clear whether there is a zigbee scan at the moment, it would be nice if there was a message “searching for zigbee devices”
My (sonooff) devices were not found by this binding. I installed zigbee2mqtt and everything is visible here.

As previously mentioned that happens with cc2531 and the binding. If you had used an ember chipset it would have worked just fine. If you don’t want to change dongles then just use zigbee2mqtt which you are doing.

Again - this is how openHAB works. The binding is unable to change the way the UI operates so you have to assume that it works when you start a scan. Again, this is the same for all bindings. I had previously tried to get a PR accepted where bindings could produce event messages displayed in the UI, but this was rejected by maintainers.

Ok, I understand this situation
In my particular case, it was easier for me to run zigbee2mqtt,
But thanks for the answers

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.