Zigbee2mqtt can't pair new zigbee devices

  • Platform information:
    • Hardware: Raspberry Pi 3B+
    • OS: Raspbian (Stretch)
    • Java Runtime Environment: unknown (sorry)
    • openHAB version: 2.4.0-1
  • Issue of the topic:
    I have successfully installed zigbee2mqtt and got it talking to openHAB via a local Mosquito installation bound as an MQTT broker in openHAB.

The broker shows as online and reports zigbee devices that I paired before I configured the broker in openHab but I cannot pair any new zigbee devices.

Looking at the Zigbee2mqtt log a message is being sent (probably from openHab) to disable linking of new devices. From a security point of view this makes perfect sense.

I’ve tried telling openHAB to search for new things but to no avail - it never sends a message to enable new device linking so new devices just get ignored.

I’m sure I’m missing something basic because scanning for new devices and pairing them is pretty fundamental.

Can anyone suggest what I might be missing?

You need to enable pairing mode on zigbee2mqtt. openHAB doesn’t know anything zigbee2mqtt so it has no idea how to ask it to scan for new zigbee devices. All it knows is what zigbee2mqtt publishes.

Yeah, take a look here:

Something odd is going on.

I have “permit_join: true” set in configuration.yaml and that works as expected until I configure the broker connection in openhab. With The broker connection in OH unconfigured I can pair devices. As soon as I configure OH to talk the (mosquito) broker the zigbee2mqtt log shows a message to the affect “disabling pairing of new devices” and it’s game over.

Looking at the logs OH publishes “permit_join: false” to the topic zigbee2mqtt/bridge/config as soon as I start Zigbee2MQTT.

Maybe it’s not supposed to do this but the reality for me is that the only way to add new zigbee devices is to shut down OH, re-enable joining, then capture the new topic names from the log as the device pairs before manually building .item files then restarting OH.

Not the smooth and seamless OH2 experience I was expecting when it talks to a known standard (MQTT) - hence my assumption that I must be doing something wrong.

You must have either a rule, item or addon in oh which sends config to turn off pairing. Have you copied or gotten some rules you have included in oh from some other tutorial or thread? I have chosen to not have any switches or similar to turn joining on and off in oh. I set that manually in zigbee2mqtt.

Regards s