ZigBee2MQTT Frontend not available

Hi, currently i am experiencing some issues with the ZigBee Binding and now i want to switch to ZigBee2MQTT.

But my frontend is not loading, so i cant easily add ZigBee Devices.

openhabian:8081 is not working, the site is not loading at all. openhabian:8080 is working as expected.

I installed ZigBee2MQTT via openhabian-config, as well as Mosquitto. The MQTT Binding is also installed and the Broker Thing switched to ONLINE too.

Not very clear what you did to provide sensible advise but, did you add this in your config.yaml file?

frontend: true

More info here: Frontend | Zigbee2MQTT

Check the ports too. Presumably openhabian does this automatically, but you’ll have to change the zigbee2mqtt front-end port, as the 8080 will clash with openhabian’s.

It is still not working.

Current configuration:

frontend: true
frontend:
  port: 8081
  host: localhost

You’ve used frontend twice in your configuration. Not sure that’s going to work.

Switch to another port. I think that’s the default openHAB port.

i tried

frontend: true

and

frontend:
  port: 8081
  host: localhost

both not working

port 8854 not working either

It’s the service running??

1 Like

Well, i thought it was.

sudo systemctl start zigbee2mqtt

did nothing. So i looked via systemctl and figured out, that there is no zigbee2mqtt service running at all.

I am trying to uninstall and reinstall it now.

//EDIT: After reinstalling zigbee2mqtt theres still no service running

//EDIT 2: I was false. Service is up and running

And you have a front-end?

nope

Assuming nothing else is taking up that port: I found that if zigbee2mqtt is not connected to the MQTT broker then the front end will not load. Have you confirmed that zigbee2mqtt is communicating with your MQTT broker?

You may want to start consulting the zigbee2mqtt logs to find out what is happening.

can you help me access these logs and to configure MQTT/Z2M the right way?

I never used MQTT before so i am really new to that.

I was testing and searching a bit and found following in the logs:

info  2023-01-03 18:01:47: Logging to console and directory: '/var/log/zigbee2mqtt/2023-01-03.18-01-47al' filename: log.txt
info  2023-01-03 18:01:47: Starting Zigbee2MQTT version 1.29.0 (commit #dddce571)
info  2023-01-03 18:01:47: Starting zigbee-herdsman (0.14.83)
error 2023-01-03 18:02:08: Error while starting zigbee-herdsman
error 2023-01-03 18:02:08: Failed to start zigbee
error 2023-01-03 18:02:08: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
error 2023-01-03 18:02:08: Exiting...
error 2023-01-03 18:02:08: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:103:27)
    at Controller.start (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/opt/zigbee2mqtt/lib/zigbee.ts:58:27)
    at Controller.start (/opt/zigbee2mqtt/lib/controller.ts:101:27)
    at start (/opt/zigbee2mqtt/index.js:107:5)

I went to that page:

and rerouted o that site:

My ZigBee Adapter is a SmaBit Bitron Adapter. Based on a Silicone Labs EM3587.
Quote from the site:

Initial development started on experimental (beta stage) support for Silicon Labs based Zigbee adapters. This includes all EM35X, EFR32MG12, EFR32MG13, EFR32MG21, EFR32MG24 SoCs/Modules families with Silabs EmberZNet NCP 6.7.8 firmware or later via EZSP version 8 (EmberZNet Serial Protocol) interface.

I dont know what firmware my adapter is using. How to find out?