Zigbee2mqtt random devices unresponsive

I just started using Zigbee devices.
My devices IKEA, Sunricher, Gledopto, Aqara were not supported by the oH Zigbee binding.
So, I moved to zigbee2mqtt (it was a bit of a pain to install via openhabian-config due to some issue with symlink or similar).

Now, z2m is very unstable. Devices stop working randomly without any error messages in the log Devices stop communicating randomly · Issue #19747 · Koenkk/zigbee2mqtt · GitHub

There does not seem to be any solution on github. Does any of you have any solution?

If not, I guess there is no way of using Zigbee with openHAB.
I am a bit jealous of my friend who uses Home Assistant. HA has native support (binding) that makes everything work immediately.

Lots of us use Z2M without any issues. I have one Sonoff contact sensor that goes offline regularly, but three other identical ones that don’t. I’m pretty sure the sensor is the problem.

You can try HA to see if it improves things for you. No reason to be jealous when there’s nothing stopping you from joining your friend. But if you want to stick with OH, we’ll try to help you.

For us to do that, you need to provide a lot more information about your system. Is it an RPi? What coordinator are you using? Which devices are going offline? Without any details, we can’t do anything for you.

RPi
Adapter: Sonoff ZBDongle-E
Devices: IKEA, Sunricher, Gledopto, Aqara
They all go offline randomly.

When some random devices stop working, there are no error codes in the log.
However, in the frontend UI, I press MAP, I loads forever, never finishes. In the log, “LQI succeeded” for a few working devices and then, nothing. If z2m is restarted everting works and I can see that the next device during MAP LQI would have been the device that was not working.

If I, instead of restarting z2m, force remove the first non-working device, then “LQI succeeded” continues and then stops again. If I then force remove the last non-working device, everything starts working as it should. The last non-working device was at the very end of the network (this time).

I then leave the non-responsive devices out of the network. The next day some other devices have stopped working with the same symptoms.

Okay, that helps. To be honest, you’ll get better support from the Z2M forum, since this isn’t an OH problem. But before you do that, let’s try some things with your controller.

I have the same Sonoff dongle. Is yours plugged directly into the RPi, or do you have it on an extension cable as recommended in the Z2M documentation? And do you have any AC-powered Zigbee devices acting as routers?

Also, have you updated the firmware on it? It’s very easy to do that from a web browser.

Your problems have nothing to do with openhab, that’s the same with HA. Devices like Aqara have loose zigbee-implementation, so don’t expect them to work without a little effort.
And if you want to switch to HA just do it (sorry but I’m starting to get allergic against those remarks).

Questions to narrow it down.

  • Are those IKEA devices bulbs?
  • Are any devices physically turned off?

Almost all zigbee-devices that are AC-powered act as routers in the mesh. When you switch them off the mesh rearranges. Devices from Aqara, Xiaome etc. often don’t recover after losing it’s router.
Routers in a zigbee mesh have to be stable otherwise your will always have trouble.

Directly plugged in. It has contact with many routers. LQI of about 150 to most of them.

Almos all of my devices are routers and constantly powered.

I have updated the firmware on the adapter and all IKEA devices. The other devices did not support OTA updates.

I am also fairly certain the problem is with z2m. But HA does not have to use z2m. I like OH but that does not mean it is the best in all aspects. Maybe OH can learn some things from HA?

No bulbs and no problem with Aqara sensors (they are only sensors in my network).
All of my routers are always powered.

No one thinks that it is. Both systems have strengths and weaknesses (everything does), and users should choose the one that fits their needs.

What we get tired of is people asking for help while threatening to leave OH for HA. We know you’re frustrated, and we’ll do our best to get you sorted out. But you’re not making it easier when you sound like you’ve already made a decision and are halfway out the door.

Nope, but lots of HA users choose to use Z2M, because ZHA isn’t necessarily better.

I wouldn’t rule out that it might be a problem with your controller.