ZME-UZB1 stick. Z-Wave binding does not appear in Habmin!

Hello All,

A beginner here. I am running OpenElec on Raspberry Pi 2.
I have setup Openhab and I also installed latest z-wave binding (1.8.1.jar) .
I got a new ZME-UZB1 stick, and I am facing problems making it to work.
I plugged it in. It is correctly detected at /dev/ttyACM0.
I changed the .cfg file appropriately as shown below:

The Z-Wave controller port. Valid values are e.g. COM1 for Windows and /dev/ttyS0 or

/dev/ttyUSB0 for Linux

zwave:port=/dev/ttyACM0

Z-Wave nightly heal time. This is the hour (eg 2AM) at which the automatic nightly

network heal will be performed.

zwave:healtime=2
zwave:softReset=false

I start the Openhab.

./start.sh

In my habmin window

http://192.168.1.100:8080/habmin/index.html

ideally I should see the z-wave device in the configuration/binding window. But I am unable to see it. It is just empty.

This is what I see in my command window:

I do not know where I am doing wrong.
Can somebody please help me?

Hi,

Can you start in debug mode (./start_debug.sh ) and take a look at the logs?

Thank you for the reply @federic0. I do the zwave logging as explained here : link . This is what I see in my zwave.log file.
Can you help me? Any ideas?

970-01-01 01:09:20.086 [DEBUG] [.zwave.internal.ZWaveActivator:36 ]- Z-Wave binding started. Version 1.8.1
1970-01-01 01:09:23.255 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
1970-01-01 01:09:23.264 [INFO ] [.z.internal.ZWaveActiveBinding:325 ]- Update config, port = /dev/ttyACM0
1970-01-01 01:09:23.272 [INFO ] [.z.internal.ZWaveActiveBinding:330 ]- Update config, healtime = 2
1970-01-01 01:09:23.274 [INFO ] [.z.internal.ZWaveActiveBinding:375 ]- Update config, setSUC = false
1970-01-01 01:09:23.276 [INFO ] [.z.internal.ZWaveActiveBinding:384 ]- Update config, softReset = false
1970-01-01 01:09:23.277 [INFO ] [.z.internal.ZWaveActiveBinding:393 ]- Update config, masterController = true
1970-01-01 01:09:23.278 [DEBUG] [.z.internal.ZWaveActiveBinding:282 ]- Initialising zwave binding
1970-01-01 01:09:23.420 [INFO ] [b.z.i.protocol.ZWaveController:148 ]- Starting Z-Wave controller
1970-01-01 01:09:23.422 [INFO ] [b.z.i.protocol.ZWaveController:156 ]- Z-Wave timeout is set to 5000ms. Soft reset is false.
1970-01-01 01:09:23.424 [INFO ] [b.z.i.protocol.ZWaveController:322 ]- Connecting to serial port /dev/ttyACM0
1970-01-01 01:09:23.579 [DEBUG] [eController$ZWaveReceiveThread:1413]- Starting Z-Wave thread: Receive
1970-01-01 01:09:23.590 [DEBUG] [WaveController$ZWaveSendThread:1197]- Starting Z-Wave thread: Send
1970-01-01 01:09:23.594 [INFO ] [b.z.i.protocol.ZWaveController:342 ]- Serial port is initialized
1970-01-01 01:09:23.594 [DEBUG] [b.z.i.protocol.ZWaveController:1154]- Starting Z-Wave thread: Input
1970-01-01 01:09:26.599 [DEBUG] [veController$WatchDogTimerTask:178 ]- Initialising network
1970-01-01 01:09:26.634 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = GetVersion (0x15), type = Request (0x00)
1970-01-01 01:09:26.636 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 1
1970-01-01 01:09:26.637 [DEBUG] [WaveController$ZWaveSendThread:1211]- Took message from queue for sending. Queue length = 0
1970-01-01 01:09:26.642 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = MemoryGetId (0x20), type = Request (0x00)
1970-01-01 01:09:26.644 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 1
1970-01-01 01:09:26.648 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 03 00 15 E9
1970-01-01 01:09:26.650 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = SerialApiGetCapabilities (0x07), type = Request (0x00)
1970-01-01 01:09:26.652 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 2
1970-01-01 01:09:26.651 [DEBUG] [WaveController$ZWaveSendThread:1268]- NODE 255: Sending REQUEST Message = 01 03 00 15 E9
1970-01-01 01:09:26.658 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = SerialApiSetTimeouts (0x06), type = Request (0x00)
1970-01-01 01:09:26.661 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 3
1970-01-01 01:09:26.667 [DEBUG] [i.p.s.GetSucNodeIdMessageClass:30 ]- Get SUC NodeID
1970-01-01 01:09:26.670 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = GetSucNodeId (0x56), type = Request (0x00)
1970-01-01 01:09:26.672 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 4
1970-01-01 01:09:28.286 [DEBUG] [z.internal.ZWaveNetworkMonitor:315 ]- Network Monitor: Queue length is 4 - deferring network monitor functions.
1970-01-01 01:09:31.670 [ERROR] [WaveController$ZWaveSendThread:1309]- NODE 255: Timeout while sending message. Requeueing - 2 attempts left!
1970-01-01 01:09:31.672 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 5
1970-01-01 01:09:31.673 [DEBUG] [WaveController$ZWaveSendThread:1211]- Took message from queue for sending. Queue length = 4
1970-01-01 01:09:31.676 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 03 00 15 E9
1970-01-01 01:09:31.678 [DEBUG] [WaveController$ZWaveSendThread:1268]- NODE 255: Sending REQUEST Message = 01 03 00 15 E9
1970-01-01 01:09:33.287 [DEBUG] [z.internal.ZWaveNetworkMonitor:315 ]- Network Monitor: Queue length is 4 - deferring network monitor functions.
1970-01-01 01:09:36.680 [ERROR] [WaveController$ZWaveSendThread:1309]- NODE 255: Timeout while sending message. Requeueing - 1 attempts left!
1970-01-01 01:09:36.682 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 5

Did you install habmin’s jar file in addons?
You do have access to habmin but not to zwave or you have no access at all to habmin?

A slight progress. I added

-Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0

in my start.sh script. I think I get better results now. I have attached them below. But even now I am not able to see the z-wave device in the configuration/binding in my browser of habmin. I downloaded habmin onto my Openhab main folder and then extracted it. I can see the habmin under webapps/habmin. Is that wrong?

1970-01-01 01:04:09.975 [DEBUG] [.zwave.internal.ZWaveActivator:36  ]- Z-Wave binding started. Version 1.8.1
1970-01-01 01:04:12.220 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
1970-01-01 01:04:12.233 [INFO ] [.z.internal.ZWaveActiveBinding:325 ]- Update config, port = /dev/ttyACM0
1970-01-01 01:04:12.235 [INFO ] [.z.internal.ZWaveActiveBinding:330 ]- Update config, healtime = 2
1970-01-01 01:04:12.237 [INFO ] [.z.internal.ZWaveActiveBinding:375 ]- Update config, setSUC = false
1970-01-01 01:04:12.238 [INFO ] [.z.internal.ZWaveActiveBinding:384 ]- Update config, softReset = false
1970-01-01 01:04:12.240 [INFO ] [.z.internal.ZWaveActiveBinding:393 ]- Update config, masterController = true
1970-01-01 01:04:12.241 [DEBUG] [.z.internal.ZWaveActiveBinding:282 ]- Initialising zwave binding
1970-01-01 01:04:12.391 [INFO ] [b.z.i.protocol.ZWaveController:148 ]- Starting Z-Wave controller
1970-01-01 01:04:12.394 [INFO ] [b.z.i.protocol.ZWaveController:156 ]- Z-Wave timeout is set to 5000ms. Soft reset is false.
1970-01-01 01:04:12.395 [INFO ] [b.z.i.protocol.ZWaveController:322 ]- Connecting to serial port /dev/ttyACM0
1970-01-01 01:04:12.576 [DEBUG] [eController$ZWaveReceiveThread:1413]- Starting Z-Wave thread: Receive
1970-01-01 01:04:12.588 [DEBUG] [WaveController$ZWaveSendThread:1197]- Starting Z-Wave thread: Send
1970-01-01 01:04:12.592 [INFO ] [b.z.i.protocol.ZWaveController:342 ]- Serial port is initialized
1970-01-01 01:04:12.592 [DEBUG] [b.z.i.protocol.ZWaveController:1154]- Starting Z-Wave thread: Input
1970-01-01 01:04:15.600 [DEBUG] [veController$WatchDogTimerTask:178 ]- Initialising network
1970-01-01 01:04:15.635 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = GetVersion (0x15), type = Request (0x00)
1970-01-01 01:04:15.637 [DEBUG] [WaveController$ZWaveSendThread:1211]- Took message from queue for sending. Queue length = 0
1970-01-01 01:04:15.640 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 0
1970-01-01 01:04:15.642 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 03 00 15 E9
1970-01-01 01:04:15.645 [DEBUG] [WaveController$ZWaveSendThread:1268]- NODE 255: Sending REQUEST Message = 01 03 00 15 E9
1970-01-01 01:04:15.646 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = MemoryGetId (0x20), type = Request (0x00)
1970-01-01 01:04:15.649 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 1
1970-01-01 01:04:15.655 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = SerialApiGetCapabilities (0x07), type = Request (0x00)
1970-01-01 01:04:15.657 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 2
1970-01-01 01:04:15.663 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = SerialApiSetTimeouts (0x06), type = Request (0x00)
1970-01-01 01:04:15.665 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 3
1970-01-01 01:04:15.668 [DEBUG] [eController$ZWaveReceiveThread:1481]- Receive Message = 01 10 01 15 5A 2D 57 61 76 65 20 33 2E 39 39 00 01 95
1970-01-01 01:04:15.669 [DEBUG] [i.p.s.GetSucNodeIdMessageClass:30  ]- Get SUC NodeID
1970-01-01 01:04:15.672 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = GetSucNodeId (0x56), type = Request (0x00)
1970-01-01 01:04:15.673 [DEBUG] [b.z.i.protocol.ZWaveController:620 ]- Enqueueing message. Queue length = 4
1970-01-01 01:04:15.682 [DEBUG] [eController$ZWaveReceiveThread:1405]- Receive queue ADD: Length=1
1970-01-01 01:04:15.682 [DEBUG] [b.z.i.protocol.ZWaveController:1163]- Receive queue TAKE: Length=0
1970-01-01 01:04:15.688 [DEBUG] [eController$ZWaveReceiveThread:1481]- Receive Message = 01 0C 00 0A 05 00 01 02 01 03 21 20 86 7A
1970-01-01 01:04:15.688 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 10 01 15 5A 2D 57 61 76 65 20 33 2E 39 39 00 01 95
1970-01-01 01:04:15.696 [DEBUG] [eController$ZWaveReceiveThread:1405]- Receive queue ADD: Length=1
1970-01-01 01:04:15.701 [DEBUG] [b.z.i.protocol.ZWaveController:1164]- Process Message = 01 10 01 15 5A 2D 57 61 76 65 20 33 2E 39 39 00 01 95
1970-01-01 01:04:15.706 [DEBUG] [b.z.i.protocol.ZWaveController:192 ]- Message: class = GetVersion (0x15), type = Response (0x01), payload = 5A 2D 57 61 76 65 20
1970-01-01 01:04:15.866 [DEBUG] [.i.p.s.MemoryGetIdMessageClass:41  ]- Got MessageMemoryGetId response. Home id = 0xE4CE8809, Controller Node id = 1
1970-01-01 01:04:15.868 [DEBUG] [.z.i.p.s.ZWaveCommandProcessor:63  ]- Sent message Message: class = MemoryGetId (0x20), type = Request (0x00), payload =
1970-01-01 01:04:15.871 [DEBUG] [.z.i.p.s.ZWaveCommandProcessor:64  ]- Recv message Message: class = MemoryGetId (0x20), type = Response (0x01), payload = E4 CE 88 09 01
1970-01-01 01:04:15.872 [DEBUG] [.z.i.p.s.ZWaveCommandProcessor:65  ]- Checking transaction complete: class=MemoryGetId, expected=MemoryGetId, cancelled=false
1970-01-01 01:04:15.874 [DEBUG] [.z.i.p.s.ZWaveCommandProcessor:68  ]-          transaction complete!
1970-01-01 01:04:15.875 [DEBUG] [b.z.i.protocol.ZWaveController:635 ]- Notifying event listeners: ZWaveTransactionCompletedEvent
1970-01-01 01:04:15.877 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
1970-01-01 01:04:15.879 [DEBUG] [WaveController$ZWaveSendThread:1327]- NODE 255: Response processed after 39ms/140ms.
1970-01-01 01:04:15.880 [DEBUG] [WaveController$ZWaveSendThread:1211]- Took message from queue for sending. Queue length = 2
1970-01-01 01:04:15.883 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 03 00 07 FB
1970-01-01 01:04:15.886 [DEBUG] [WaveController$ZWaveSendThread:1268]- NODE 255: Sending REQUEST Message = 01 03 00 07 FB
1970-01-01 01:04:15.903 [DEBUG] [eController$ZWaveReceiveThread:1481]- Receive Message = 01 2B 01 07 05 02 01 15 04 00 00 01 FE 83 FF 88 CF 1F 00 00 FB 9F 7D A0 67 00 80 8$
1970-01-01 01:04:15.923 [DEBUG] [b.z.i.protocol.ZWaveController:1163]- Receive queue TAKE: Length=0
1970-01-01 01:04:15.923 [DEBUG] [eController$ZWaveReceiveThread:1405]- Receive queue ADD: Length=1
1970-01-01 01:04:15.932 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 2B 01 07 05 02 01 15 04 00 00 01 FE 83 FF 88 CF 1F 00 00 FB 9F 7D A0 6$
1970-01-01 01:04:15.941 [DEBUG] [b.z.i.protocol.ZWaveController:1164]- Process Message = 01 2B 01 07 05 02 01 15 04 00 00 01 FE 83 FF 88 CF 1F 00 00 FB 9F 7D A0 67 00 80 8$
1970-01-01 01:04:15.949 [DEBUG] [b.z.i.protocol.ZWaveController:192 ]- Message: class = SerialApiGetCapabilities (0x07), type = Response (0x01), payload = 05 02 01 15 04 0$
1970-01-01 01:04:15.952 [DEBUG] [ApiGetCapabilitiesMessageClass:45  ]- API Version = 5.2
1970-01-01 01:04:15.954 [DEBUG] [ApiGetCapabilitiesMessageClass:46  ]- Manufacture ID = 0x115
1970-01-01 01:04:15.955 [DEBUG] [ApiGetCapabilitiesMessageClass:47  ]- Device Type = 0x400
1970-01-01 01:04:15.957 [DEBUG] [ApiGetCapabilitiesMessageClass:48  ]- Device ID = 0x1
1970-01-01 01:04:15.958 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SerialApiGetInitData
1970-01-01 01:04:15.959 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SerialApiApplicationNodeInfo
1970-01-01 01:04:15.960 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: ApplicationCommandHandler
1970-01-01 01:04:15.961 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: GetControllerCapabilities
1970-01-01 01:04:15.962 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SerialApiSetTimeouts
1970-01-01 01:04:15.963 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SerialApiGetCapabilities
1970-01-01 01:04:15.964 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SerialApiSoftReset
1970-01-01 01:04:15.965 [DEBUG] [ApiGetCapabilitiesMessageClass:56  ]- Supports: Unknown Class 0x09
1970-01-01 01:04:15.967 [DEBUG] [ApiGetCapabilitiesMessageClass:56  ]- Supports: Unknown Class 0x0a
1970-01-01 01:04:15.968 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: RfReceiveMode
1970-01-01 01:04:15.969 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SetSleepMode
1970-01-01 01:04:15.970 [DEBUG] [ApiGetCapabilitiesMessageClass:59  ]- Supports: SendNodeInfo

In my addons folder, I do not see anything related to habmin. There is just one z-wave-binding.jar file (1.8.1) version.
I do have access to habmin. For example, if I navigate to http://192.168.1.100:8080/habmin, I can see the habmin home page. But I am unable to see, the z-wave device in habmin.

Is that normal? @federic0

you should have org.openhab.io.habmin-1.7.0-SNAPSHOT.jar or another version in your addons. Make sure to follow the install instructions.

Few minutes I added this also. I tried with this but did not work.

When you open habmin, you need to click on the “configuration” tab, then on “bindings” (at the very bottom of the left pane), then you should get a list of all your installed bindings.

PS: I have problems with safari and habmin and use chrome instead.

Thanks again for the reply.
In my case, I believe my zwave stick is working correctly in the OpenHab. For example, if I open my zwave.log, I can see that the z-wave port is initialized. And it is also sending message and receiving message (to and from Node 255?). I can see this in the z-wave.log.

But the z-wave just does not appear in the habmin. I simply do not why. I have been stuck at this for 9 hours now.

I unzipped the habmin.zip and it by default has a z-wave binding. I should see that in the browsers.

I tried with 1.8.1 binding. Removed default z-wave binding from habmin - Still did not work :frowning: . No z-wave device appears in habmin folder.

Are there other ways to configure z-wave other than Habmin?
Any reply will be appreciated. Thanks for your time.

Yes, you could use https://github.com/OpenZWave/open-zwave-control-panel
But I think that is not your problem.

I think THAT is your problem. OpenElec is targeted to run as multimedia platform and lacks some features from the other linux distros for the Pi.
I recommend to install Raspbian. I have the same zwave stick and it’s working fine with habmin.

Good luck.

@sihui
Thank you for the reply.
I will give it a try in Raspbian. I will keep posted on how it goes.
So, I cannot do with the OpenElec then.

I’m not sure, but I believe that is your problem.
Setting up a new operating system on a Pi is fast and easy, you should give it a try on a spare sd card …

Maybe your problem is that you need to purchase a license for the ZME-UZB1 to work. Without this license installed the ZME-UZB1 will not be able to communicate with other zwave devices AFAIK. See here: http://forum.z-wave.me/viewtopic.php?f=3422&t=22803#p60714

No. Only when you bought a stick with a license. My ZME_UZB1 is a “non licensed” version and works fine with oh out of the box.

Really? Well mine didn’t work and my understanding was that this was because of the missing license. An Aeon Gen5 stick worked completely fine for me…

I can also confirm that an UNlicensed ZME_UZB1 works just fine with OH, although I am running it on Ubuntu. I am using it as a testing unit with OH2 while my Aeon Stick is in running on OH1.

So the ZME_UZB1 should work just fine, but I do think that perhaps the Aeon provides better range and quicker response time. But that could still be OH2 still in its beta phase and I only have 2 devices hook up to it.

Just wanted to update in case someone else is stuck at the same problem.
It was as @sihui predicted.

OpenElec was the culprit.
Got myself a new SD card.
Installed Raspbian > Installed Openhab and Habmin
Behold! It just works!

Earlier, I spent almost two days on this. Now only twenty minutes, and it simply works :smiley: !

Lesson learnt

If you want your machine to do anything other than running a media center, then do not install OpenElec!

Thanks guys for all the help.

P.S : I like OpenElec for what it does :slight_smile:

@sihui Still not resolved. I am breaking my head over this. Please help!!

As you seen in this image, I see this z-wave binding in Habmin. But I do not the USB stick on the device window :frowning: !

My port number is /dev/ttyACM0. I added it in the .cfg file.
I also added openhab to group dialout.

When I start, it does not work.
Can someone point out to what I am doing wrong. Its been three days now :frowning:

can you show the results of:
ls -l /usr/share/openhab/addons
ls -l /usr/share/openhab/webapps/habmin/
ls -l /dev/ttyACM0
ls -l /etc/openhab/configurations