ZMNHID Flush on/off thermostat

Hi there,

I have a problem getting the thermostat in Openhab 2.5 to switch.

To my setup:
It’s about controlling a refrigerator, so I put the thermostat in cool mode.
Unfortunately all possible configuration attempts did not lead to success.

Items:
Number:Temperature WKS_Q_Temp “Temperatur Wildkühlschrank Q [%.1f °C]” {channel=“zwave:device:e933b60f:node4:sensor_temperature”}
Number WKS_Q_Mode “Mode” {channel=“zwave:device:e933b60f:node4:thermostat_mode”}
Number WKS_Q_Strom “Strom akt.” {channel=“zwave:device:e933b60f:node4:meter_watts”}
Number WKS_Q_kWh “kWh” {channel=“zwave:device:e933b60f:node4:meter_kwh”}
Number:Temperature WKS_Q_Mid_Temp “Soll-Temperatur [%.1f °C]” {channel=“zwave:device:e933b60f:node4:thermostat_setpoint_heating”}

Sitemap:
Text item=WKS_Q_Temp label=“Aktuelle Temperatur WIldkühlschrank [%.1f °C]” icon=“temperature” labelcolor=[<0=“BLUE”, <5=“GREEN”, <6=“ORANGE”, >5=“RED”] valuecolor=[<0=“BLUE”, <5=“GREEN”, <6=“ORANGE”, >5=“RED”]
Setpoint item=WKS_Q_Mode label=“Mode”
Text item=WKS_Q_Strom label=“Aktueller Stromverbrauch [%.1f W]” icon=“energy”
Text item=WKS_Q_kWh label=“Aktueller Stromverbrauch [%.1f kWh]” icon=“energy”
Setpoint item=WKS_Q_Mid_Temp label=“Soll-Temperatur [%.2f °C]” icon=“temperature-max” step=0.1 minValue=0 maxValue=6

In the configuration I tried a lot changing the values 43 and 44, at the moment I use 1050 and 1020.

Does anyone had success with this thermostat in “Coolmode”?

Thanks a lot for your help,

rocsta

Is the mode a number item or string?

It‘s a number item.

The icon is determined by the Item what does the paper up say the channel type is on the Thing?

Accoording to the manual (https://qubino.com/manuals/Flush_On_Off_Thermostat_2.1_ENG.pdf?cf_id=8131) the values of 43 and 44 can be between 0-250 or 0-450 (depending if it is Fahrenheit or Celsius).
Parameter 59 needs te be 1, but according to the Things Summary, it can be changed with your item WKS_Q_Mode with a state 2 (Number). But it needs te be re-included (so exclude and then include).

But what is exactly the question? What does/doesn’t it do?

The PaperUI says:

Sensor (temperature)

zwave:device:e933b60f:node4:sensor_temperature content_copy
Number:Temperature -> ITEM: WKS_Q_Temp

Electric meter (watts)

zwave:device:e933b60f:node4:meter_watts content_copy
Number -> ITEM: WKS_Q_Strom

Electric meter (kWh)

zwave:device:e933b60f:node4:meter_kwh content_copy
Number -> ITEM: WKS_Q_kWh

Thermostat mode

zwave:device:e933b60f:node4:thermostat_mode content_copy
Number -> ITEM: WKS_Q_Mode

Setpoint (heating)

zwave:device:e933b60f:node4:thermostat_setpoint_heating content_copy
Number:Temperature -> ITEM: WKS_Q_Mid_Temp

But what is your question? Doesn’t it cool?

Can you post the state of item WKS_Q_Mode and your device parameters?

hmmm…

The PaperUI says to Parameter 44:
“This parameter defines temperature min difference between real measured temperature and set-point temperature to turn device off.
Available config. parameters (data type is 2 Byte DEC):
default value 5 (0.5 °C)
0 -127 = 0.0°C ~ 12.7 °C
1001 -1127 = -0.1°C ~ -12.7 °C”

The PaperUI says to Parameter 43:
“This parameter defines temperature min difference between real measured temperature and set-point temperature to turn device on.
Available config. parameters (data type is 2 Byte DEC):
default value 1005 (-0.5 °C)
0 -127 = 0.0°C ~ 12.7 °C
1001 -1127 = -0.1°C ~ -12.7 °C”

Quite different to the manual you linked above, but this manual refers to “QUBINO FLUSH ON/OFF THERMOSTAT 2”.
For the “QUBINO FLUSH ON/OFF THERMOSTAT” (without "2) is another manual available, which shows the same values like PaperUI: http://manual.zwave.eu/backend/make.php?lang=en&sku=GOAEZMNHID1

It seems that I have the one “without 2”.

Yes, I removed it, reset the thermostat using the i1-switch and reincluded.

“But what is exactly the question? What does/doesn’t it do?”

I used the above parameters. I set temperature to 4 °C to switch on. Hysteresis ±3 °C.
The measured temperature was 20 °C.
I expected the refrigerator would be switched on. But this never happen, regardless of the parameters I set.

Yes.

Parameter 59: Cool Mode
Item WKS_Q_Mode shows “Off” ?
Parameter 43: I tried a lot, actually 1050
Parameter 44: I tried a lot, actually 1020

Other parameters ?

The log says, when It switch the Mode-Parameter:

" 2020-02-19 23:49:36.871 [ome.event.ItemCommandEvent] - Item ‘WKS_Q_Mode’ received command 1
2020-02-19 23:49:36.873 [nt.ItemStatePredictedEvent] - WKS_Q_Mode predicted to become 1
2020-02-19 23:49:36.880 [vent.ItemStateChangedEvent] - WKS_Q_Mode changed from 0 to 1
2020-02-19 23:49:38.702 [vent.ItemStateChangedEvent] - WKS_Q_Mode changed from 1 to 0"

So it always switches back to the OFF-Mode, as I understand the heat mode. Strange …

My mistake, this is the correct manual: http://qubino.com/manuals/Flush_On%20Off_Thermostat.pdf

No, It is OFF mode, see https://www.openhab.org/addons/bindings/zwave/thing.html?manufacturer=qubino&file=zmnhid_0_0.html :

Sets the thermostat.

The thermostat_mode channel is of type thermostat_mode and supports the Number item and is in the Temperature category. The following state translation is provided for this channel to the Number item type -:

Value Label
0 Off
1 Heat
2 Cool

I think you have to remove this item, because you can’t change it without re-including the device and you have to set it once (and forget).

Then look at HABmin, as far as I know it’s a better zwave manager then paperUI. Look at parameter 59, is it still 1? If not, change it to 1 and re-include your device.

Dear all,

now that I had time again to devote myself to the subject due to Corona, the following result:

I set the parameter to 59 to 2 (Cool), excluded the Device and included it again.
After that I played around with all possible parameters all day today.

Now I am finally frustrated, because I did not manage to switch the connected device once.

I really have no idea what else I can do.
I would say that this device cannot really be controlled and operated in Openhab.

If anyone is reading this and has had other experiences, I would be happy if they had a hint after all.

Not sure if this is of any help… I’m using this device for heating, and generally it works fine.

Did you try with hysteresis on/off values both >0? It’s been a while that I installed this device, but I have something at back of my head that I may have had an issue with hysteresis values of >1000 (i.e. negative) somehow not working. This may be supported by the fact that my device is currently configured with 43/On: 0 (0,0°C) and 44/Off: 4 (0,4°C), while naturally I would have done 1002 and 2… And this should be no problem if you adjust the setpoint accordingly.

Also I’m not sure about your hysteresis values you gave above:
43: 1050 (-5,0°C) and 44: 1020 (-2,0°C)
For cooling I would expect them to be the other way around, the higher value for 43/on and the lower for 44/off?

Thankyou for your response.

“For cooling I would expect them to be the other way around, the higher value for 43/on and the lower for 44/off?”

That was a question I was asking myself. Somewhere in the manual it said that in cool mode the value 43 must be higher than 44.
But: What is meant by that.
Must the value “1050” (or similar) be higher or the transmitted value ("-5.0°C).

I then tried to find out with a test series.
I have tried 10 value constellations.
As a result I could not find any traceable behaviour. Also no behavior, which would indicate that the device was still in heat mode.