Zooz ZEN25 energy reporting

Tags: #<Tag:0x00007f434a3b8578> #<Tag:0x00007f434a3b8320>

@chris I’m installing a Zooz ZEN25 double plug and PaperUI is only allowing me to select “5” or “Disable” for the Wattage Threshold. According to the Zooz documentation this should be user-defined (0 – 655350). Can I request this to be changed in the binding? I’m trying to measure standby power draw for my appliances, but below 5W it’s just reporting zero.

What do the Attributes look like for that Thing from HABmin?
We have 2 entries for that model. That usually means there were feature changes. Zooz is pretty good about adding features, in my experience…

Same thing in Habmin: 5 or disable.

It’s the V2 revision of the Double Plug. I checked the database and both versions indicate that this parameter should be 0 to 65535.

There hasn’t been a lot of discussion about the ZEN25, so I’m guessing that it just got set up as a dropdown with these two options instead of a fill-in field. It’ll let me type in other numbers, but after saving the configuration it’ll return to 5.

I checked quickly . Are you sure you cannot fill in any value? The database entry looks like it should permit that.

image

1 Like

Hah, I was just coming back to say that I was mistaken. I didn’t realize that it only records the parameter value if I type the number and then hit the Enter key on my keyboard (I was just typing the number and then clicking the “Save” button). Sigh.

Even at a setting of 1, my TV and sound bar aren’t registering any consumption. So apparently my six-year-old LCD is surprisingly efficient when idling.

Thanks!

1 Like

If you look at the database entry you will notice a pencil icon in that parameter. That is what it means. I think we gave the 0 option to easily disable the feature.

Good to know. I haven’t had to look too closely at the database until now, so the pencil didn’t mean anything to me.

1 Like

Has this changed in OH3? I have a radial button I can select to disable but no box where I can type in a number?
snip

I did look at the “Code” panel and I was able to change the value of config_2_4 value. I put in a 10. Then, I looked back at the thing page and saw that it was pending change. So, I let it sit until the update happened.

Then I verified when I clicked on the disable button, it changed the value for config_2_4 back to 0.

Seems like maybe the text entry box for that parameter is just missing.

(I am using the V2 of the plug if that is useful)

The latest changes in the database are in a snapshot version of the binding. After installing you will need to delete & re-add the Thing. I know there was a database issue a while ago that caused issues like that.
I believe the update script works with OH3. It not, the manual instructions in the README file should still apply.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

1 Like