Zooz ZSE29 Sensor in Z-wave database, but wrong firmware

I recently purchased a Zooz ZSE29 Sensor after confirming it was listed as a compatible device here LINK1* and here LINK2*. What I failed to notice is that both databases say it’s only for firmware version up to 1.9. The device I bought is firmware version 2.0.
Of course, when I tried adding the devices to OpenHAB, the node shows up as “Unknown Device.” I am running OpenHAB 2.5.2 on the Synology DiskStation NAS. I use the Aeotec Z-stick Gen 5.

What would I need to do to get the sensor I bought to be recognized by OpenHAB? Looking over CD-Jackson’s Z-Wave Device Database Usage Guidance LINK3* page, I am not sure if this would be considered updating an existing device, adding a new version of an existing device, or a new device altogether.

From CD-Jackson’s page for this ZSE29 Sensor, I came across this post LINK4*. It’s not quite what I need, but it did link to this guide LINK5* to adding a new device to the Z-wave binding. However, the guide links to a dead link for a Z-wave Binding JAR file. I can’t seem to find a link for the binding for version 2.5.2.

Any help is appreciated. I’d really like to get this sensor added so that it can be recognized as a known device in OpenHAB.

** Apparently new users can’t post multiple links. I’ll post them as non-links:

LINK1 - openhab DOT org/addons/bindings/zwave/thing.html?manufacturer=zooz&file=zse29_0_0.html

LINK2 - cd-jackson DOT com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/970

LINK3 - cd-jackson DOT com/index.php/zwave/zwave-device-database/zwave-device-database-guide

LINK4 - community.openhab DOT org/t/rule-trigger-for-zooz-zse29-sensor/78092/9

LINK5 - community.openhab DOT org/t/modify-a-zwave-binding-jar-to-add-change-a-zwave-device-while-waiting-for-a-build/47326


Welcome to openHAB.

This database entry
is for devices with firmware 2.0 and up.
It looks like your device is not yet fully initialized, just wake it up a few times.
Also note if you are switching from battery to usb power you need to exclude and reinclude the device.

1 Like

If you want the latest zwave database definitions you need to upgrade to the most recent zwave snapshot version. This can be found here:

Drop that jar into your addons folder and restart openHAB.
You may also use a script from one of our fellow community members:

1 Like


A very good choice. Zooz (and their store, thesmartesthouse.com) has been very helpful helping us support their devices.

Thanks for the link, sihui! Not sure how I didn’t see that one. I’m glad the firmware I have is already on the database.

I’ve added the device to the zstick 2 days ago. According to the documentation, the wake up time is 4 hours. For now, I placed the motion sensor in a high traffic area hoping it would eventually be detected in OpenHAB, but as of this moment, it still shows up as “Unknown Device”. Is there some other way to manually wake it up a few times?

I am using OH 2.5.2 on Synology DS (the latest OpenHAB package for Synology is 2.5.2 which is why I’m running that version). OH 2.5.2 was released on Feb 19, 2020. The link you provided shows the device with firmware 2 was “Approved on 2020-03-02”. Does that mean there’s a good chance the ZWave binding I have doesn’t include my device with v2 firmware?

It sounds like I need to try that. The link you provided is actually for the openHAB-Distribution, I was easily able to find the ZWave binding - https://ci.openhab.org/view/Integration%20Builds%20(2.5.x)/job/openHAB2.5.x-ZWave/. This is where I should be downloading the JAR file, correct?

I was looking at the script you linked to, but that script seems to replace all of OH with the latest snapshot. Is that really what I need? Dropping the JAR file to the addons directory may be more straight-forward.

That’s what I’ve seen in these forums. That’s why I chose to buy from them :D.

There are two scripts… you are looking at the wrong one

1 Like

Thanks for the lightning fast reply. Where’s the other script? This is the link I see which is the one that seems to get the latest snapshot of OH:

That wakeup time is after binding discovery is complete. You likely need to wake the device up several times after adding it to openHAB.

I found that for a different Zooz sensor, the documentation was incorrect and it took 3 presses of the button to wake up the device. I found this after Zooz replaced the possibly defective device and the other one acted the same way.

Ahhh yes!!! It worked!!!

I did the inclusion process by pressing the tamper trigger 3 times. The Zstick added the node after the 3rd press (per the instructions for this device).

But you were right! I took off the cover, and pressed the tamper trigger 3 times (short wait) and again 3 times (repeat a few more times), and OH recognized it!! I see all the channels now.

Thanks for this very helpful tip!!

The zzManualInstaller.sh is the one you want

Please let wither Zooz support or thesmartesthouse support know the documentation is incorrect. They use the same support team, I believe.

I updated the instructions in our database which will get propagated down to the OH documentation.

I need to update my bookmarks :innocent:

1 Like

Here is the one I use. Looks the same as yours?
Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

There are two scripts in this repo and for some reason this confuses people. I’ll be doing some PRs later today and will put them into separate repos or figure out a better way to distinguish between the two.

1 Like

Ahh yes, it wasn’t immediately obvious, but now I see the two separate scripts.