ZSE29 Motion Sensor

I just bought a PI 4,
Loaded the latest Openhabian,
Have a Aeotec Gen 5 Z Wave hub
Bought 2 - ZSE29 Motion Sensors.

Anyone have a Zse29 and working? Any reviews?
My experience:
Both Sensors included just fine in simple mode and all items functions installed.
In the Configuration Parameters page the only two items that I can change successfully is both polling settings. All other setting revert back to default (as if it never gets the update). The units LEDS flash when movement is detected but nothing happens in the log.
I’ve spent hours researching, sent an email to Zooz Support. Hoping someone here can shed some light.

@5iver has one. Perhaps he can assist.

@Rick_Marshall - did you ever get it to work? I have one these ZSE29’s and have the same problem. I’ve seen a few other posts about it but not a concrete fix.

I have a ZSE29 working with no issues

What version of openHAB are you running and what issues are you seeing?

I also have a new one still in the box I could use for testing.

Hi @Bruce_Osborne - thanks for the quick response. This is a new setup with an RPi4 and openHABian. I upgraded everything through the config tool a few days ago before adding any sensors, its currently running version 2.5.9-1 (Release Build).

Caveat: I’m fairly new to OH, though I’ve become pretty good at erasing everything and starting over :slight_smile:

So far I’ve added door/window sensors, network devices, an alarm siren, etc. and these all work as expected. I get log messages when they’re triggered, I’ve added items and a sitemap, and that works as expected, I’ve created rules that fire on events, etc.

With the ZSE29, it adds to the network fine, no errors, it shows as online. I put it in test mode and it lights up to indicate motion detected, I run it not in test mode both with tamper switch engaged and not engaged, but it never seems to send any events to OH. I added items to the sitemap and they don’t respond, I’ve added rules and they never fire. I’ve put OH logging to debug and still there is no indication of anything happening with the sensor. The tamper switch does not seem to do anything, basically I just get nothing from it.

That said i may be misunderstanding something with the channel type. I added it with “Simple Mode” turned on so it would create its own channels. My door sensors seem to be Binary “Contacts” where the motion sensor channels are all of Alarm “Switch” type. I would think that I should get some type of event indication somewhere though.

Another thing I don’t think I understand is the Group/Lifeline configuration. I know it exists from several docs, but I haven’t yet found anything in OH configuration where this come into play.

If I’m just misunderstand how this thing should work I would be grateful to get pointed to some educational material, at this point I don’t know what else to do and am about to shelve it and do something else.

Resolved! I had to keep waking it up! When I added it to the controller, it identified it and said it was online. As I delved more into Command Classes, I had the suspicion that those weren’t properly setup. On a lark, I woke it up manually a couple times and noticed a lot of new action going on in the debug log, it also went offline then. I woke it up 3 or 4 more times and noticed it was loading command classes, but didn’t have a chance to complete. After about 7 or 8 wake ups, it finally completed and started working as expected.

Lessen learned: wake up a new device a few times when adding it and make sure its all completed!

1 Like

For battery operated devices that is correct. If you want to use it with USB power you must have it on USB power when including into the network. I am running off battery too.

Thank you Scottmc, This confirms what I have noticed but wasn’t convinced. I sort of gave up, left them on and eventually they worked, though making changes to the thing is time consuming waiting for updates. I guess I only woke them up once and needed to do it more like you said. Again Thank you!