Zstick on OH3

Just upgraded to 3.0 and unfortunately ran into the problem described in this thread. OH 3 can no longer see my z-wave Aeon Z-Stick. OH 2 was fine. The thread I linked to has the issue marked “Solved” but they basically used a workaround of ser2net, which shares your serial port over the network. I haven’t tried it yet because that seems rather extreme. Anyone else experience issues with OH 3 not reading serial / USB based z-wave devices? Is there something I need to do to get Zulu Java 11 (I was on openjdk-8 before) to recognize the device? I have added the openhab user account to both the tty and uucp groups. Sadly nothing seems to work and I’m almost having to look at reverting back to OH 2 since pretty much everything runs off my Z-Stick on my network. I’m running this on x86_64 Arch Linux.

I am using the same stick and it is working fine. Assume that the serial port is not available for the JVM. Thus you need to do the following:

  • ssh into the server
  • sudo nano /etc/default/openhab
  • EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyAeoTecZStick"

The ‘ttyAeoTecZStick’ will be different as i created an alias. Typical samples are in the file. Or you need to lookup your previous setting stored in /etc/default/openhab2

1 Like

Thanks @mheiss. I don’t have /etc/default/openhab because I did a manual install on Arch Linux instead of from a package back in the day. I did try adding that to /opt/openhab/runtime/bin/setenv as some people were suggesting, but that didn’t work. I also tried creating the /etc/default/openhab file and putting that in there. I do see the option is getting passed to the JVM because when I run ps, I can see the command line:

openhab 61075 30.1 10.7 5866056 764828 ? Sl 01:00 1:24 /usr/bin/java -XX:-UsePerfData -Dopenhab.home=/opt/openhab -Dopenhab.conf=/opt/openhab/conf -Dopenhab.runtime=/opt/openhab/runtime -Dopenhab.userdata=/opt/openhab/userdata -Dopenhab.logdir=/opt/openhab/userdata/logs -Dfelix.cm.dir=/opt/openhab/userdata/config -Djava.library.path=/opt/openhab/userdata/tmp/lib -Djetty.host= -Djetty.http.compliance=RFC2616 -Dnashorn.args=–no-deprecation-warning -Dorg.ops4j.pax.web.listening.addresses= -Dorg.osgi.service.http.port=8080 -Dorg.osgi.service.http.port.secure=8443 -Djava.awt.headless=true -XX:+UseG1GC -Dgnu.io.rxtx.SerialPorts=/dev/ttyACM0…

Ok yes that seems to be ok. For me that was all that i needed to do. Afterwards OH3 was running fine after the migration from OH2. But i am using a different hardware (Raspberry Pi4) and a different installation variant (OpenHabian). The controller and all my ZWave devices are working as expected with OH3. For far no issues.