Zwave 2.4 and update a thing parameter

Hey (@chris),

I’m trying out new motion sensor (Everspring 816-1). Everything works fine with the zwave binding 2.4 (detection, item link…). I just having an issue to update some parameters of the device through the PaperUI.
Fe I want to set parameter 6 to 120. This is time in seconds for ON/OFF duration…
The result is ‘Thing updated’ are the save. And in my logs, I’m getting:

2018-11-05 17:34:43.757 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[ConfigStatusMessage [parameterName=group_1, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null]]]

When I now refresh the thing parameters, the result is back to 5 (default setting)?
Any clue what I’m doing wrong?

ps tried several times to update (wakeup) the device. But no improvement. Just a lot of:

2018-11-05 17:37:14.242 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:2f4ef5d0:node38' has been updated.
2018-11-05 17:37:26.744 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:2f4ef5d0:node38' has been updated.
2018-11-05 17:37:28.465 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:2f4ef5d0:node38' has been updated.

You need to wake up the device. The binding will store the configuration locally until the device is awake and it can be transferred (hence the PENDING flag).

Make sure the device is really waking up - check the debug log, or check the last wakeup time in the properties. If it really is waking up, then please provide the debug log.

I guess that it wakes up.
And I’ve also waited 24h to be sure that the ‘default wakeup’ couldn’t solve it.

I can see ‘UPDATE_STATE_NODE_INFO_REQ_FAILED’. But not sure if I can do anything to resolve it?

The device ID is 38.
DebugNode38.xml (61.9 KB)

And maybe also the node38.xml file?
node38.xml (7.9 KB)

ps I gave the logfile extension xml. Not sure how else I should deliver the log file… :blush:


Anything else I can do/try/update? :blush:

I’m not 100% sure, but I suspect that nothing is changing, so the binding doesn’t send anything to the device. Try changing the parameter to another value, then back to the value you want, then wake up the device.

Just tried to change some things (ON/OFF duration, function typ…) in PaperUI (zwave 2.4) and habmin.
Went from 120 to 60 to 120 (Parameter 6), but the sensor keeps on 5
Went from 99 to 1 (Parameter 1), but the value always return to 99…

Debug log:

The sensor movement “OFF/ON” changes after 5 seconds back to ON/OFF.
So not very nice for outside lighting (on/off/on/off…).

Do you’ve an idea where it goes wrong? Else I see to create a rule that keep the lights a bit longer ON. But since the sensor should be capable of dealing with this…

Pushed the buttons like a fool, but the motion sensor just won’t take the new parameter into account. :cry:
Ive checked out some other sites, and apparantly, it’s not one of the easiest sensors to take hte parameters into account.

Since it’s getting darker (winter) over here, I’ve configured it with the Timers Version for the moment. Works as expected…

Let me know if you want me to test anything.

Can you provide a smaller logfile please - I can’t read this one… It reads in my viewer, so I can see that the configuration is not being sent, but I don’t seem to be able to open it with a text editor as it’s too large.

Also, when replying, please click the reply on one of my messages - otherwise I don’t get a notification and it’s easy to miss messages (which is why I didn’t reply earlier :slight_smile: ).

Sure, hereby 2 logfiles from SP816 Motion Sensor, zwave node ID 39.
In both cases, I went to PaperUI, and changed settings 6 (On-Off Duration) from 5 (default) to 120.
I woke up the sensor several times. A lot of movement in the logs, but when I check afterwards the PaperUI, it went back to 5.

log1.xml (77.2 KB)
log2.xml (124.0 KB)

Let me know if can do anything to help you!!!

So the problem is this log entry -:

16:44:22.392 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 39: Error getting configurationCommandClass

This means that the binding doesn’t know that the device supports the configuration command class - this is either because it wasn’t detected during initialisation, or the device doesn’t report it in the NIF, or somehow it got removed from the XML.

I guess that this is related to the NIF errors - the device doesn’t seem to be reporting the NIF, and without this we dont know what services it is reporting.

@chris, Maybe it’s not an issue with the binding. :blush:

After hours with the node, I (finally) noticed the 2 potential meters (clock and sun) on the node.
When I open the clock all the way, guess what… Time is at max, namely 12 minutes…
So it’s working, if you change it on hardware level.

I guess it’ll be difficult to set the duration differently on hard- and software level? Or somehow you should be capable to disable the hard setting?

I’m looking around if maybe you need to put in a special value a paramater 1 to bypass the hardware setting. …

If you have verified this that would be a nice addition to the Usage Information tab in the database: