ZWave binding migration to development version

Now merged -:

1 Like

Maybe you should remove the market place dev binding. At least it happened to me that i accidentality installed that version because of the “Security” appendix … :sunglasses:


Thanks - it’s now gone…

I successfully securely included 2 BE469 locks and an NGD00Z. One included the first try. The others took multiple attempts. The NGD00Z was the fiestiest. I think it took at least 15 tries! So, secure inclusion is definitely still working in the latest version, but it can be stubborn. I’ll put the logs in a ticket.


Thanks a lot Chris, the new version is a very nice improvement!

One small issue though… After upgrading I’m getting three battery channels with the same name for my Fibaro radiator thermostat (FGT-001) and it prevents me from modifying its properties. I’ve tried removing and adding again, removing xml and binding etc. so perhaps there’s something with the device DB?

This one appears 3 times:

2018-09-14 13:36:42.771 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 77: Initialising cmd channel zwave:device:512:node77:battery-level for PercentType

I think it should be zwave:device:512:node77:battery-level, zwave:device:512:node77:battery-level1 and zwave:device:512:node77:battery-level2.

I’ve a problem here.

I’m using a /dev/zwave_controller serial port where is connected my zwave key.
When I start searching for new devices, the controller goes offline saying “Serial Error: Port {0} does not exist”, and when I look at the properties of the controller I see /dev/ttyUSB0 and not /dev/zwave_controller. Changing the name, the controller goes up, but I’m not able to import correctly my devices.

How to solve it? Do you need a specific log for that? In case, how to collect?


Had the same error here. A simple reboot fixed it for me. But you might want to check if the serial port still has the group “dialout” and that openhab user is part of that group.

it seems it works only if you use the default port (ttyUSB0 or ttyACM0). I’ve solved pointing to one of those (depending on the controller)


I’ve updated to a new version of z-wave binding (using steps provided by Rich), but there are 2 things that look oddly, although, I’m not 100% sure it’s the binding issue.
The first one is appearance of node_1 in Association groups. When I open drop-down, I have Controller, Node 2, Node 3…Node 8, and node_1 (notice underscore in node_1). All of these nodes were here before, except node_1 (my controller is Node 1, so, I guess it’s some kind of duplicate), and I’ve tried switching Association groups to Controller, but after some time, it automatically goes back to node_1. Most of my z-wave devices are Aeon Dimmers, so, they aren’t battery powered.
The second issue is strange behavior of power readings. I’m using Aeon Dimmers to meter power usage, but I have readings for a single dimmable LED light bulb that are 268 kW (9 watts bulb) in one case, and 1.5 kW (13 watts bulb) in the other (2 different dimmers).
Again, I’m not sure it’s the binding that’s root of the issue, but it started happening after the update.

Best regards,

Not using Aeon dimmers so can’t tell, but just an idea: most devices to report power report both, current usage as well as accumulated usage (accumulated since whenever you’ve reset that device last, possibly reaching back ever i.e. to when you installed it). You don’t happen to read these values, do you ?


No, it’s not accumulated usage (kWh), because it shows 268 kW, and after turning bulb off, it shows 0 W. And it doesn’t show false data every time. Sometimes it shows real power usage reading (9 W in this case). Thank you for trying to help.

Best regards,

Hi @Chris, this is great! Would you be able to make a note on the update.lst file? This way, if users (using manual upgrade atm) try to upgrade to a snapshot to an upcoming version of 2.4.0. Then they’ll be notified of this change and what they may need to do.

Thanks for the pointer… Done…

1 Like

Mark, have you done a recent delete/rediscover of a minimote? After deleting their Things, none of mine are able to be identified. I thought this had been all sorted. Maybe something regressed or got missed in the merge?

I’ve not done a delete/rediscover in quite a while. I’ll try it on one of them now.

1 Like

A delete/rediscover worked for me. I’m on binding version Not the most current.

When you deleted the Thing, did you also delete the node.xml?

Hmmm. I’m on the same version. Try it after deleting your xmls. Somehow mine have gone missing.

Ah, I didn’t delete the node.xml. I just deleted the Thing.

Now I will try a reinitialize to see if I can regenerate the xml.