ZWAVE Binding RazBerry2 - Can't include any devices

Hi there, after days of struggling with getting my Z-WAVE configuration up and running I am going nuts!

After installing a fresh Openhab 2.4 system with new components I can’t include any Z-WAVE devices. The z-wave bindig is installed and seems to work. I can set the RazBerry2 in inclusion mode (red LED is on) but it doesn’t recognize any of my devices. The log shows no hints, that the controller is dealing with any device.

  • Platform information:
    • Hardware: Raspberry 3 B+, RazBerry2
    • Raspbian Stretch, freshly installed updated
    • Java Runtime Environment: 1.8.0_201
    • openHAB version: 2.4

I am ready to get a hammer and rid of my z-wave devices …

Any ideas?


You also need to set every single device into inclusion mode.

Thank you. I’ve double checked that by many devices and continued fiddling around. And now it’s getting really funny:

I have 3 Fibaro 102 Wallplugs. After a while I’ve got one of it included. Hooray! More than that: I could create a switch item out of that thing and I could switch in on and off. Some hope began to sprout inside me.

Then I’ve tried to include another wallplug - Bingo!. Then, the third one: success again!

Now I’ve wanted to make items out of the new added things - but: There where already three items in the control panel: Plug1, Plug2 and Plug3. Hugh?

Unfortunately: All items are linked to the first thing and after scrutinizing the three things I’ve discovered, that all three wallplugs have the same ID. ?!?

Then I’ve removed all three things and plugged the wallplugs off. After a reboot I’ve started the inclusion without any z-wave device accessible and - tadaa - I’ve got two new devices in the inbox: My very well known first wallplug - although it isn’t plugged in.

Now I’ve got a bottle of beer and wondering, what to do… I am really helpless

Problem solved. This issue may be closed by the admin.

After so many hours, days and nights of fruitless work I’ve decided to finish my Z-WAVE engagement in order to focus on my homematic configuration. That isn’t flawless either but I don’t have the time to manage two quirky systems simultaneously.

Sorry to hear you have so many problems. But if other users come around this post your statement

cannot be left uncommented: Zwave is very reliable when it comes to rf based systems, but you have to understand the basics:
Binding needs to be switched to inclusion mode, within 30 seconds you have to switch your device into inclusion mode (how to do that needs to be read in the device manual) and the device gets initialized, done.
A new thing will pop up in your inbox and is ready to use.
If that did not work you did something wrong, either with your openHAB setup or with the way your are setting your inclusion mode.
If you ever want to try it again, please don’t hesitate to ask.
Good luck.

Don’t get me wrong. I’ve already had a stable running Z-WAVE configuration. But the way to get there is really not straight forward. And maybe, tho most quirky component in that system is the human one…

Anyway, perhaps I will have a new try in the future.

1 Like