Zwave Binding Uninstalls[SOLVED] and Razberry is Offline

On Build 689 (using offline) I have not had any success with zwave and also with the Razberry card zwave controller.
The binding reports that the controller is not found :
Serial Error: Port /dev/ttyAMA0 does not exist
and on a re-start of OH2 the zwave binding is uninstalled.
I have tried setting the setenv parameter to"
both before and after installing the binding but the device is not recognised and the binding gets uninstalled on a restart.
My installation was all going smoothly back at Build #595. Started having troubles with Build #675.
Debug logfile attached.openhab.log.ZWaveDebug.xml (202.9 KB)

Thanks in anticipation for any help with this.

If you specify

binding = ...

(not commented out) in addons.cfg, then only those bindings are installed and others are uninstalled. If using that choice, add ,zwave to the list. As for the port issue, is the Linux user under which openHAB is being run allowed to use the port (by being in the dialout group. for example)? If so, what other things have you configured?

Duh! Thanks for picking that up. I should have remembered that I edited that out to simplify the install when things weren’t going well and have forgotten to put it back.
I am guessing I won’t be the last person to be caught out by that one.

The device is:
ls -la /dev/ttyAMA0
crw-rw-rw- 1 root dialout 204, 64 Jan 1 1970 /dev/ttyAMA0
I have:
grep dialout /etc/group
grep tty /etc/group
so thoiught I was in good shape there but still getting:
Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyAMA0 does not exist.
I start OH2 with sudo ./ and my /opt/openhab2 folder and sub folders are root:root. Perhaps that’s where my problem is. I might try changing to openhab:openhab.

1 Like

Hi robb01, maybe this is useful:

and this older one:

Hi anfaenger rud
Thanks for your suggestions.
I am on a Raspberry Pi2 so the device is /dev/ttyAMA0 not /dev/ttyS0 in my case and it has worked fine up until recent changes and still runs correctly if I load up z-way server.
I have not gone to the extent of re-installing the OS with openHABian - this would very much be a last resort.
I thought I would crack the problem with permissions or user/group issues but no luck so far. No doubt it will work once again as it did before. I just need to find that simple thing that is NQR at the moment.
I am wondering if it is one of those .properties or .cfg files that needed to be copied back from the zip file.

Title edited after uninstall issue resolved.

Hi Rob, I have had the same issues in the past. In my blog I have written a “How to” that should contain everything to set up the razberry card with opeHAB2. It is written in German but I guess google translate will solve that if it is a problem for you.

Hi Christian
Thanks for your reply and link to your great blog.
My Pi2 is on Wheezy rather than Jessie so uses sysVinit not systemctl.
I think because of this my apt-get install was a problem so I have reverted to the install from the zip file.

Have also done the usermod thing for tty and dialout groups.

When I include
in /etc/default/openhab2 I get a Karaf crash with a weird error:
/usr/bin/java: symbol lookup error: /opt/openhab2/userdata/tmp/libNRJavaSerial_HF_root_0/ undefined symbol: __fdelt_chk

:frowning: I searched a bit around and checked my logs but nothing that helps me to understand your issue. Unfortunately I have no idea what to do. Sorry

The puzzle continues. The surprising thing to me is that the zwave DEBUG log option is not revealing what the issue is. All I have is:
08:50:08.739 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:71cd1c22’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyAMA0 does not exist

and lines like:
08:50:08.746 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler.
08:50:08.757 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 4: Command received zwave:device:71cd1c22:node4:blinds_control --> REFRESH

I have confirmed the device is recognised and works under z-way server so it must be a permisssions/config issue in OH2. But I have
grep tty /etc/group
grep dialout /etc/group

I am running the script as sudo so I don’t expect that OH folder permissions would be the issue.
Open to any suggestions at this point.

As a next step I went back to the apt-get installation setting the bindings I want in addons.cfg first. This started up ok with no errors so I then added my items, things and sitemap in to the picture. At this point there was no error but also little activity until I refreshed the browser Paper UI when it again crashed with the error
/usr/bin/java: symbol lookup error: /opt/openhab2/userdata/tmp/libNRJavaSerial_HF_root_0/ undefined symbol: _fdeltchk
So this crash happens when the binding tries to communicate with the /dev/ttyAMA0 device.

I am now thinking more in terms of this being a bug.

This all started with the new folder structure: New folder structure
and the issues of /userdata/etc/*.properties files and /userdata/etc/org.apache,karaf., files that I had troubles with.
Has anyone else done a recent update and are successfully running the Razberry device?

Maybe I am charting new waters here.

Updated to latest off-line with Build #694 - no change.
Checked that I am on latest java version - java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ Client VM (build 25.101-b13, mixed mode)

It’s looking like it’s time to build a new SD card but I still want to know what is broken?

This appears to be due to a version change

@watou John Cocula Maintainer
This could be completely unrelated, but in case it’s not, this commit13 updated nrjavaserial from 3.9.3 to 3.12.1 three days ago.

See issue Nrjavaserial upgrade causes "Serial Error: Port /dev/ttyACM0 does not exist".
It might be better to continue this discussion over there.